community/gimp-nufraw to 0.42-6

This commit is contained in:
Kevin Mihelich 2020-01-28 13:23:30 +00:00
parent 2fa283afe1
commit f220f2cb8b
4 changed files with 48 additions and 5 deletions

View file

@ -0,0 +1,32 @@
--- a/dcraw_api.cc 2015-06-16 04:58:38.000000000 +0100
+++ b/dcraw_api.cc 2019-06-30 16:37:05.503409567 +0100
@@ -689,3 +689,3 @@
#pragma omp parallel for schedule(static) default(none) \
- shared(h,dark,rgbWB)
+ firstprivate(black,pixels) shared(h,dark,rgbWB)
#endif
@@ -702,3 +702,3 @@
#pragma omp parallel for schedule(static) default(none) \
- shared(h,dark,rgbWB)
+ firstprivate(black,pixels) shared(h,dark,rgbWB)
#endif
--- a/dcraw_indi.c 2015-06-16 04:58:38.000000000 +0100
+++ b/dcraw_indi.c 2019-06-30 17:03:59.692710441 +0100
@@ -140,2 +140,3 @@
default(none) \
+ firstprivate(iheight,iwidth,noise,threshold) \
shared(nc,image,size,noise) \
@@ -145,2 +146,3 @@
default(none) \
+ firstprivate(iheight,iwidth,noise,threshold) \
shared(nc,image,size) \
@@ -416,2 +418,3 @@
default(none) \
+ firstprivate(colors,filters,height,width) \
shared(image,code,prow,pcol,h) \
@@ -502,3 +502,4 @@
default(none) \
- shared(image,dir,diff) \
+ firstprivate(filters,height,width) \
+ shared(image,dir,diff) \
private(row,col,i,d,c,pix,guess)

View file

@ -5,7 +5,7 @@
pkgname=gimp-nufraw
pkgver=0.42
pkgrel=5
pkgrel=6
pkgdesc='Converter for raw files; utility and GIMP plugin'
url='https://sourceforge.net/projects/nufraw/'
arch=('x86_64')
@ -15,15 +15,26 @@ makedepends=('gimp')
conflicts=('gimp-ufraw')
replaces=('gimp-ufraw')
optdepends=('gimp: to use the gimp import plugin for raw images')
source=("https://downloads.sourceforge.net/nufraw/nufraw-$pkgver.tar.gz" nufraw-iostream.patch nufraw-exiv2-0.27.patch)
source=("https://downloads.sourceforge.net/nufraw/nufraw-$pkgver.tar.gz"
'0001-nufraw-iostream.patch'
'0002-nufraw-exiv2-0.27.patch'
'0003-omp_definitions.patch')
sha256sums=('ddfb592a183618c802e990211f6efce75f4801a7708ecc364666f53af25c9f90'
'fd0120af2cfa8783edd3d91a39b638fbb30ced8c692815be230a302bc55a71ad'
'ec7caabbdaa8fb67097bfb72c26a1140754e184e756ec2013863af37eed67220')
'ec7caabbdaa8fb67097bfb72c26a1140754e184e756ec2013863af37eed67220'
'8f15799e1e682330072f04af4607380b91a55edc9c9f638bdeae1ee3d2318ccf')
prepare() {
cd "nufraw-$pkgver"
patch -p1 -i ../nufraw-iostream.patch # Add missing include
patch -p1 -i ../nufraw-exiv2-0.27.patch # Fix build with exiv2 0.27 (Gentoo)
# Add missing include
patch -p1 -i ../0001-nufraw-iostream.patch
# Fix build with exiv2 0.27 (Gentoo)
patch -p1 -i ../0002-nufraw-exiv2-0.27.patch
# fix '... not specified in enclosing parallel'
patch -p1 -i ../0003-omp_definitions.patch
autoreconf -fi