mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/qt5: fix for v5
This commit is contained in:
parent
25bd73e641
commit
f229d609b7
2 changed files with 44 additions and 2 deletions
|
@ -47,7 +47,8 @@ _pkgfqn="qt-everywhere-opensource-src-${pkgver}"
|
|||
source=("http://download.qt-project.org/official_releases/qt/5.2/${pkgver}/single/${_pkgfqn}.tar.xz"
|
||||
'assistant.desktop' 'designer.desktop' 'linguist.desktop' 'qdbusviewer.desktop'
|
||||
'use-python2.patch'
|
||||
'deppath_gnu.patch' 'rpi.patch' 'undef_B0.patch')
|
||||
'deppath_gnu.patch' 'rpi.patch' 'undef_B0.patch'
|
||||
'qt5webkit-0002-Fix-QtWebKit-build-on-ARM-softfp.patch')
|
||||
md5sums=('8f60b47ca9461831d940f579ee90517e'
|
||||
'b2897dd6a2967bccf8f10e397aafee55'
|
||||
'9638a78e502719ef8fe5f8d10d0361a9'
|
||||
|
@ -56,13 +57,19 @@ md5sums=('8f60b47ca9461831d940f579ee90517e'
|
|||
'a378deccf363bd6079da459c89aff7b9'
|
||||
'21e4389ed0dd9c37e7cb48712d3bff91'
|
||||
'3f8d2f8fb4e5715f7ce79950fac3c31f'
|
||||
'8a9ba2d990d8840a2114fcffb9f9d2a4')
|
||||
'8a9ba2d990d8840a2114fcffb9f9d2a4'
|
||||
'd9eb94a6cf4f178a7d77d6b8a9280ee2')
|
||||
|
||||
prepare() {
|
||||
cd ${_pkgfqn}
|
||||
|
||||
MAKEFLAGS="-j3"
|
||||
|
||||
# Fix building on armv5
|
||||
cd qtwebkit
|
||||
patch -p1 -i "${srcdir}"/qt5webkit-0002-Fix-QtWebKit-build-on-ARM-softfp.patch
|
||||
cd ..
|
||||
|
||||
# Raspberry Pi
|
||||
# if [ "$CARCH" == 'armv6h' ]; then
|
||||
# patch -p1 -i "${srcdir}"/deppath_gnu.patch
|
||||
|
|
|
@ -0,0 +1,35 @@
|
|||
From 8a716a29721d900069d82878c45cf87a356adba3 Mon Sep 17 00:00:00 2001
|
||||
From: Allan Sandfeld Jensen <allan.jensen@digia.com>
|
||||
Date: Tue, 17 Dec 2013 12:26:58 +0100
|
||||
Subject: [PATCH] Fix QtWebKit build on ARM softfp
|
||||
|
||||
The low level interpreter depends on hardfp, so we need to disable it
|
||||
when builing on ARM targets with softfp.
|
||||
|
||||
Task-number: QTBUG-35681
|
||||
Change-Id: I8aaef546b92182a87cc7116ac452d8725de6a7db
|
||||
Reviewed-by: Jocelyn Turcotte <jocelyn.turcotte@digia.com>
|
||||
Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com>
|
||||
---
|
||||
Source/WTF/wtf/Platform.h | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
|
||||
index 3a9b509..cddc210 100644
|
||||
--- a/Source/WTF/wtf/Platform.h
|
||||
+++ b/Source/WTF/wtf/Platform.h
|
||||
@@ -771,6 +771,11 @@
|
||||
#define ENABLE_LLINT 0
|
||||
#endif
|
||||
|
||||
+/* LLINT on ARM depends on an FPU */
|
||||
+#if !defined(ENABLE_LLINT) && CPU(ARM) && !CPU(ARM_HARDFP)
|
||||
+#define ENABLE_LLINT 0
|
||||
+#endif
|
||||
+
|
||||
/* On some of the platforms where we have a JIT, we want to also have the
|
||||
low-level interpreter. */
|
||||
#if !defined(ENABLE_LLINT) \
|
||||
--
|
||||
1.8.5.1
|
||||
|
Loading…
Reference in a new issue