mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/samba to 4.16.4-2
This commit is contained in:
parent
f5004405c0
commit
f2501f0107
2 changed files with 67 additions and 3 deletions
|
@ -14,7 +14,7 @@
|
|||
pkgbase=samba
|
||||
pkgname=('smbclient' 'samba')
|
||||
pkgver=4.16.4
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=(x86_64)
|
||||
url="https://www.samba.org"
|
||||
license=('GPL3')
|
||||
|
@ -31,15 +31,22 @@ optdepends=(
|
|||
source=(https://us1.samba.org/samba/ftp/stable/${pkgbase}-${pkgver}.tar{.gz,.asc}
|
||||
samba.logrotate
|
||||
samba.pam
|
||||
samba.conf)
|
||||
samba.conf
|
||||
samba-glibc-2.36.patch)
|
||||
validpgpkeys=('81F5E2832BD2545A1897B713AA99442FB680B620') #Samba Distribution Verification Key <samba-bugs@samba.org>
|
||||
sha512sums=('9754275ace30755b75f747e201f8ad4550a823c8606e550c0ce6b3ccbaf048dd895bf2c21127271298304be7f80de9b6451091c4949ebe267ee1cf3ab497cd85'
|
||||
'SKIP'
|
||||
'2ba0691ded467e4d6e40821f6de58c00f8962209efe2e60284c0c87756ab471c22c3d63b77d506e48c90ed0d852a2a24e41be1d499cf74a73cb99da0b503c858'
|
||||
'1e6183ab0eb812b3ef687ac2c26ce78f7cb30540f606d20023669ac00ba04075487fb72e4dc89cc05dab0269ff6aca98fc1167cc75669c225b88b592482fbf67'
|
||||
'e46ee848baabb261e7468ecee43aba4d001a24f86f5322ae522abdb75030fd0ebd9063b9df0be3576c4d1654d81331f5e389aee16ec2fa138259ae4728e94efc')
|
||||
'e46ee848baabb261e7468ecee43aba4d001a24f86f5322ae522abdb75030fd0ebd9063b9df0be3576c4d1654d81331f5e389aee16ec2fa138259ae4728e94efc'
|
||||
'a6404c4ecfa60ab38fb79c5cd6af2818762ff2fe787e512c0eee0af6459d7726e168e76724a3012d895a30a68c11723e7a3f1fdb027d56dda8e1fdcc9059b915')
|
||||
### UNINSTALL dmapi package before building!!!
|
||||
|
||||
prepare() {
|
||||
cd samba-${pkgver}
|
||||
patch -Np1 -i ../samba-glibc-2.36.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
# Use samba-pkg as a staging directory for the split packages
|
||||
# (This is so RPATHS and symlinks are generated correctly via
|
||||
|
|
57
extra/samba/samba-glibc-2.36.patch
Normal file
57
extra/samba/samba-glibc-2.36.patch
Normal file
|
@ -0,0 +1,57 @@
|
|||
From eee9ff0228f52008bfc565241f6dfe07ae7a7044 Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schneider <asn@samba.org>
|
||||
Date: Tue, 2 Aug 2022 07:55:46 +0200
|
||||
Subject: [PATCH] lib:replace: Only include <sys/mount.h> on non-Linux systems
|
||||
|
||||
Details at:
|
||||
https://sourceware.org/glibc/wiki/Release/2.36#Usage_of_.3Clinux.2Fmount.h.3E_and_.3Csys.2Fmount.h.3E
|
||||
|
||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=15132
|
||||
|
||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
||||
Reviewed-by: Ralph Boehme <slow@samba.org>
|
||||
(cherry picked from commit 766151bf5b7ef95ae4c8c98b8994e5c21c5bbec0)
|
||||
---
|
||||
lib/replace/system/filesys.h | 4 +++-
|
||||
lib/replace/wscript | 3 +++
|
||||
2 files changed, 6 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/replace/system/filesys.h b/lib/replace/system/filesys.h
|
||||
index 034e5d5886c..bb9482c69af 100644
|
||||
--- a/lib/replace/system/filesys.h
|
||||
+++ b/lib/replace/system/filesys.h
|
||||
@@ -36,7 +36,8 @@
|
||||
#include <sys/param.h>
|
||||
#endif
|
||||
|
||||
-#ifdef HAVE_SYS_MOUNT_H
|
||||
+/* This include is required on UNIX (*BSD, AIX, ...) for statfs() */
|
||||
+#if !defined(LINUX) && defined(HAVE_SYS_MOUNT_H)
|
||||
#include <sys/mount.h>
|
||||
#endif
|
||||
|
||||
@@ -44,6 +45,7 @@
|
||||
#include <mntent.h>
|
||||
#endif
|
||||
|
||||
+/* This include is required on Linux for statfs() */
|
||||
#ifdef HAVE_SYS_VFS_H
|
||||
#include <sys/vfs.h>
|
||||
#endif
|
||||
diff --git a/lib/replace/wscript b/lib/replace/wscript
|
||||
index e4c2d513076..0db93d8caf1 100644
|
||||
--- a/lib/replace/wscript
|
||||
+++ b/lib/replace/wscript
|
||||
@@ -31,6 +31,9 @@ def configure(conf):
|
||||
|
||||
conf.env.standalone_replace = conf.IN_LAUNCH_DIR()
|
||||
|
||||
+ if sys.platform.rfind('linux') > -1:
|
||||
+ conf.DEFINE('LINUX', '1')
|
||||
+
|
||||
conf.DEFINE('BOOL_DEFINED', 1)
|
||||
conf.DEFINE('HAVE_LIBREPLACE', 1)
|
||||
conf.DEFINE('LIBREPLACE_NETWORK_CHECKS', 1)
|
||||
--
|
||||
2.37.1
|
||||
|
Loading…
Reference in a new issue