mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
aur/cherokee to 1.2.101-4
This commit is contained in:
parent
46ddd71e15
commit
f26264ac84
2 changed files with 24 additions and 4 deletions
|
@ -1,11 +1,12 @@
|
|||
# $Id: PKGBUILD 63849 2012-02-06 06:17:28Z foutrelis $
|
||||
# Maintainer:
|
||||
# Maintainer: Fernando Jiménez Solano <fjim@sdfeu.org>
|
||||
# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
|
||||
# Contributor: Link Dupont <link@subpop.net>
|
||||
# Contributor: Pierre Bourdin <pierre@pi3rrot.net>
|
||||
|
||||
pkgname=cherokee
|
||||
pkgver=1.2.101
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
pkgdesc="A very fast, flexible and easy to configure Web Server"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.cherokee-project.com/"
|
||||
|
@ -27,17 +28,22 @@ options=('!libtool')
|
|||
source=(http://www.cherokee-project.com/download/1.2/$pkgver/cherokee-$pkgver.tar.gz
|
||||
cherokee.rc
|
||||
cherokee.logrotate
|
||||
fix-ctk-path-handler-match.patch)
|
||||
fix-ctk-path-handler-match.patch
|
||||
cherokee-1.2.101-ffmpeg0.11.patch)
|
||||
|
||||
sha256sums=('ca465ab3772479fc843b38ffc45113bf24d8bfae9185cdd5176b099d5a17feb8'
|
||||
'4c06cebfab8b68edd4967c020bfb41b077cfff10d76596d1ed192d0b6cedbd86'
|
||||
'20e26d633f8c1cd90eb21f41dd163b73a83846e405b1ce995e072c4efefc522e'
|
||||
'2bd05e0181024c9bd02d828e8329d4d96a779e4870b1fc4f18aa8667d8c6a630')
|
||||
'2bd05e0181024c9bd02d828e8329d4d96a779e4870b1fc4f18aa8667d8c6a630'
|
||||
'6bcdcb8eaccb5516478a0c36960fbacc3d68f8bc326b9b526c388e0607a65116')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
# Fix path matching bug in CTK apps (e.g. market)
|
||||
patch -Np1 -i "$srcdir/fix-ctk-path-handler-match.patch"
|
||||
# Fix this bug : https://bugs.mageia.org/show_bug.cgi?id=6145
|
||||
patch -Np1 -i "$srcdir/cherokee-1.2.101-ffmpeg0.11.patch"
|
||||
|
||||
# Use subdirectory for logs
|
||||
sed -i -r 's|(%localstatedir%/log)|\1/cherokee|' cherokee.conf.sample.pre
|
||||
|
|
14
aur/cherokee/cherokee-1.2.101-ffmpeg0.11.patch
Normal file
14
aur/cherokee/cherokee-1.2.101-ffmpeg0.11.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- cherokee-1.2.101/cherokee/handler_streaming.c.ffmpeg 2012-06-04 12:56:16.000000000 +0800
|
||||
+++ cherokee-1.2.101/cherokee/handler_streaming.c 2012-06-04 12:56:40.000000000 +0800
|
||||
@@ -380,7 +380,7 @@
|
||||
if (likely (secs > 0)) {
|
||||
long tmp;
|
||||
|
||||
- tmp = (hdl->avformat->file_size / secs);
|
||||
+ tmp = (avio_size(hdl->avformat) / secs);
|
||||
if (tmp > rate) {
|
||||
rate = tmp;
|
||||
TRACE(ENTRIES, "New rate: %d bytes/s\n", rate);
|
||||
|
||||
|
||||
|
Loading…
Reference in a new issue