removed extra/texmacs

This commit is contained in:
Kevin Mihelich 2016-08-03 12:34:33 +00:00
parent 0c5b4f421f
commit f2c0857079
2 changed files with 0 additions and 80 deletions

View file

@ -1,68 +0,0 @@
# $Id$
# Maintainer: Ronald van Haren <ronald.archlinux.org>
# Contributor: Damir Perisa <damir.perisa@bluewin.ch> # Contributor: Christopher Reimer <c.reimer1993@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix qreal usage
pkgname=texmacs
pkgver=1.99.4
pkgrel=2
pkgdesc="Free scientific text editor, inspired by TeX and GNU Emacs. WYSIWYG editor TeX-fonts and CAS-interface (Giac, GTybalt, Macaulay 2, Maxima, Octave, Pari, Qcl, R and Yacas) in one."
arch=('i686' 'x86_64')
url="http://www.texmacs.org/"
license=('GPL')
depends=('perl' 'guile1.8' 'texlive-core' 'python2' 'libxext' 'freetype2' 'shared-mime-info'
'desktop-file-utils' 'qt4')
# do not remove texlive-core dependency, as it is needed!
optdepends=('transfig: convert images using fig2ps'
'gawk: conversion of some files'
'ghostscript: rendering ps files'
'imagemagick: convert images'
'aspell: spell checking')
makedepends=('ghostscript')
source=(http://www.texmacs.org/Download/ftp/tmftp/source/TeXmacs-${pkgver}-src.tar.gz
arm.patch)
options=('!emptydirs')
sha1sums=('77a3d292934ebb288c7f8cb77e15f168012bbf4c'
'3c431d63360da065b4021df04ed052ee6b18b8ae')
prepare() {
cd "${srcdir}/TeXmacs-${pkgver}-src"
patch -p1 -i ../arm.patch
sed -i 's/env python/env python2/' \
plugins/{mathematica/bin/realpath.py,python/bin/tm_python,sage/bin/tm_sage} \
TeXmacs/misc/inkscape_extension/texmacs_reedit.py
sed -i 's/"python"/"python2"/' plugins/python/progs/init-python.scm
sed -i '/^LDPATH/d' src/makefile.in
sed -i -e 's/guile18 /guile1.8 /g' \
-e 's/guile18-config/guile-config1.8/g' \
configure
sed -i -e 's|#include <libguile18.h>|#include <guile/gh.h>|g' src/Scheme/Guile/guile_tm.hpp
# Don't generate icon-cache and mime-database (namcap tells that they should not be in a package)
sed -i '/update-mime-database/d' Makefile.in
sed -i '/gtk-update-icon-cache/d' Makefile.in
sed -i '\/icons\/gnome 2>\/dev\/null/d' Makefile.in
}
build() {
cd "${srcdir}/TeXmacs-${pkgver}-src"
export QMAKE=qmake-qt4
export MOC=moc-qt4
export UIC=uic-qt4
export LDFLAGS="$LDFLAGS -lz"
./configure --prefix=/usr \
--mandir=/usr/share/man \
--libexecdir=/usr/lib
make
}
package() {
cd "${srcdir}/TeXmacs-${pkgver}-src"
make DESTDIR=${pkgdir} install
# fix fig2ps script
sed -i 's|${prefix}|/usr|' "${pkgdir}/usr/bin/fig2ps"
}

View file

@ -1,12 +0,0 @@
diff -urN a/src/Plugins/Qt/qt_renderer.cpp b/src/Plugins/Qt/qt_renderer.cpp
--- a/src/Plugins/Qt/qt_renderer.cpp 2013-11-03 16:09:35.000000000 -0700
+++ b/src/Plugins/Qt/qt_renderer.cpp 2014-02-03 13:45:42.670490781 -0700
@@ -271,7 +271,7 @@
if ((N(y) != n) || (n<2)) return;
STACK_NEW_ARRAY (pnt, QPointF, n);
for (i=0; i<n; i++)
- decode (x[i], y[i], pnt[i].rx(), pnt[i].ry());
+ decode (x[i], y[i], (double&)pnt[i].rx(), (double&)pnt[i].ry());
painter->setRenderHints (QPainter::Antialiasing);
painter->drawPolyline (pnt, n);
STACK_DELETE_ARRAY (pnt);