extra/mplayer to 37353-1

This commit is contained in:
David Beauchamp 2015-01-11 18:18:20 -05:00
parent aa2d73a276
commit f2c9f86856
2 changed files with 10 additions and 35 deletions

View file

@ -10,8 +10,8 @@
pkgbase=mplayer
pkgname=('mplayer' 'mencoder')
pkgver=37224
pkgrel=3
pkgver=37353
pkgrel=1
arch=('i686' 'x86_64')
makedepends=(
'libxxf86dga' 'libxxf86vm' 'libmad' 'libxinerama' 'sdl' 'lame' 'libtheora'
@ -19,24 +19,23 @@ makedepends=(
'faac' 'faad2' 'lirc-utils' 'libxvmc' 'enca' 'libvdpau' 'opencore-amr'
'libdca' 'a52dec' 'schroedinger' 'libvpx' 'libpulse' 'fribidi' 'unzip' 'mesa'
'live-media' 'yasm' 'git' 'fontconfig' 'mpg123' 'ladspa' 'libass' 'libbluray'
'libcdio-paranoia' 'opus' 'subversion' 'x264' 'libx264'
'libcdio-paranoia' 'opus' 'subversion' 'x264' 'libx264' 'rtmpdump' 'gnutls'
'gsm' 'libdvdcss' 'libdvdread' 'libdvdnav'
)
license=('GPL')
url='http://www.mplayerhq.hu/'
options=('!buildflags' '!emptydirs')
source=($pkgbase-$pkgver::svn://svn.mplayerhq.hu/mplayer/trunk#revision=$pkgver
http://ffmpeg.org/releases/ffmpeg-2.2.5.tar.bz2
http://ffmpeg.org/releases/ffmpeg-2.5.3.tar.bz2
mplayer.desktop
cdio-includes.patch
include-samba-4.0.patch
giflib51.patch
revert-icl-fixes.patch)
md5sums=('SKIP'
'a91dbd963f0ed16bf0eacaba98439d00'
'efba7c5cfbea9ce58ff693cd08f90ffa'
'62f44a58f072b2b1a3c3d3e4976d64b3'
'7b5be7191aafbea64218dc4916343bbc'
'868a92bdef148df7f38bfa992b26ce9d'
'14461fb94b7aa5dda091ba4f737df2d9'
'3579402002b7302fdf2d146639333efd')
pkgver() {
@ -46,11 +45,10 @@ pkgver() {
prepare() {
cd $pkgbase-$pkgver
mv ../ffmpeg-2.2.5 ./ffmpeg
mv ../ffmpeg-*/ ./ffmpeg
patch -p0 -i ../cdio-includes.patch
patch -p1 -i ../include-samba-4.0.patch
patch -Np0 -i ../giflib51.patch
patch -Np0 -i ../revert-icl-fixes.patch
./version.sh
@ -93,7 +91,8 @@ package_mplayer() {
'libgl' 'libxinerama' 'libvdpau' 'libpulse' 'smbclient' 'xvidcore'
'opencore-amr' 'jack' 'libmad' 'sdl' 'libtheora' 'libcaca' 'libxxf86dga'
'fribidi' 'libjpeg' 'faac' 'faad2' 'libxvmc' 'schroedinger' 'mpg123'
'libass' 'libxxf86vm' 'libbluray' 'libcdio-paranoia' 'opus'
'libass' 'libxxf86vm' 'libbluray' 'libcdio-paranoia' 'opus' 'rtmpdump'
'gsm' 'gnutls' 'libdvdnav'
)
cd $pkgbase-$pkgver
@ -116,7 +115,7 @@ package_mencoder() {
'alsa-lib' 'fontconfig' 'giflib' 'libpng' 'smbclient' 'xvidcore'
'opencore-amr' 'libmad' 'libtheora' 'fribidi' 'libjpeg' 'faac' 'faad2'
'schroedinger' 'mpg123' 'libass' 'libbluray' 'libcdio-paranoia'
'libvorbis' 'opus'
'libvorbis' 'opus' 'rtmpdump' 'gsm' 'libdvdnav'
)
make -C $pkgbase-$pkgver DESTDIR="$pkgdir" install-mencoder install-mencoder-man

View file

@ -1,24 +0,0 @@
--- libvo/vo_gif89a.c.orig 2014-06-11 10:06:29.243216331 +0000
+++ libvo/vo_gif89a.c 2014-06-11 10:08:37.346078847 +0000
@@ -75,6 +75,9 @@
#define MakeMapObject GifMakeMapObject
#define FreeMapObject GifFreeMapObject
#define QuantizeBuffer GifQuantizeBuffer
+#if defined GIFLIB_MINOR && GIFLIB_MINOR >= 1
+#define EGifCloseFile(a) EGifCloseFile(a, NULL)
+#endif
#endif
// how many frames per second we are aiming for during output.
--- libmpdemux/demux_gif.c.orig 2014-06-11 10:46:48.120883788 +0000
+++ libmpdemux/demux_gif.c 2014-06-11 10:47:28.290732272 +0000
@@ -50,6 +50,9 @@
#define DGifOpenFileHandle(a) DGifOpenFileHandle(a, NULL)
#define GifError() (gif ? gif->Error : 0)
#define GifErrorString() GifErrorString(gif->Error)
+#if defined GIFLIB_MINOR && GIFLIB_MINOR >= 1
+#define DGifCloseFile(a) DGifCloseFile(a, NULL)
+#endif
#endif
/* >= 4.2 prior GIFLIB did not have MAJOR/MINOR defines */