mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added community/coin-or-clp
This commit is contained in:
parent
2c411b20c9
commit
f2d7964663
2 changed files with 95 additions and 0 deletions
47
community/coin-or-clp/0001-Remove-MMX-header.patch
Normal file
47
community/coin-or-clp/0001-Remove-MMX-header.patch
Normal file
|
@ -0,0 +1,47 @@
|
||||||
|
From 26d0b1d47b76575260a96d1712b1e95cc996ec9c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
Date: Sat, 23 Feb 2019 11:39:31 -0700
|
||||||
|
Subject: [PATCH] Remove MMX header
|
||||||
|
|
||||||
|
---
|
||||||
|
Clp/src/ClpPackedMatrix.cpp | 6 ------
|
||||||
|
Clp/src/ClpSimplexDual.cpp | 6 ------
|
||||||
|
2 files changed, 12 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Clp/src/ClpPackedMatrix.cpp b/Clp/src/ClpPackedMatrix.cpp
|
||||||
|
index e79bfaa..df2be84 100644
|
||||||
|
--- a/Clp/src/ClpPackedMatrix.cpp
|
||||||
|
+++ b/Clp/src/ClpPackedMatrix.cpp
|
||||||
|
@@ -6747,12 +6747,6 @@ ClpPackedMatrix3::ClpPackedMatrix3()
|
||||||
|
, ifActive_(0)
|
||||||
|
{
|
||||||
|
}
|
||||||
|
-#ifdef _MSC_VER
|
||||||
|
-#include <intrin.h>
|
||||||
|
-#else
|
||||||
|
-#include <immintrin.h>
|
||||||
|
-//#include <fmaintrin.h>
|
||||||
|
-#endif
|
||||||
|
/* Constructor from copy. */
|
||||||
|
ClpPackedMatrix3::ClpPackedMatrix3(ClpSimplex *model, const CoinPackedMatrix *columnCopy)
|
||||||
|
: numberBlocks_(0)
|
||||||
|
diff --git a/Clp/src/ClpSimplexDual.cpp b/Clp/src/ClpSimplexDual.cpp
|
||||||
|
index a25cd1d..a0a5085 100644
|
||||||
|
--- a/Clp/src/ClpSimplexDual.cpp
|
||||||
|
+++ b/Clp/src/ClpSimplexDual.cpp
|
||||||
|
@@ -3550,12 +3550,6 @@ void moveAndZero(clpTempInfo *info, int type, void *extra)
|
||||||
|
}
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
-#ifdef _MSC_VER
|
||||||
|
-#include <intrin.h>
|
||||||
|
-#else
|
||||||
|
-#include <immintrin.h>
|
||||||
|
-//#include <fmaintrin.h>
|
||||||
|
-#endif
|
||||||
|
int ClpSimplexDual::dualColumn0(const CoinIndexedVector *rowArray,
|
||||||
|
const CoinIndexedVector *columnArray,
|
||||||
|
CoinIndexedVector *spareArray,
|
||||||
|
--
|
||||||
|
2.20.1
|
||||||
|
|
48
community/coin-or-clp/PKGBUILD
Normal file
48
community/coin-or-clp/PKGBUILD
Normal file
|
@ -0,0 +1,48 @@
|
||||||
|
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||||
|
# Contributor: spider-mario <spidermario@free.fr>
|
||||||
|
# Contributor: Daniel Ehlers <danielehlers@mindeye.net>
|
||||||
|
|
||||||
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
# - patch to remove MMX headers
|
||||||
|
|
||||||
|
pkgname=coin-or-clp
|
||||||
|
pkgver=1.17.0
|
||||||
|
pkgrel=1
|
||||||
|
pkgdesc="COIN-OR linear programming solver"
|
||||||
|
arch=(x86_64)
|
||||||
|
url="https://projects.coin-or.org/Clp"
|
||||||
|
license=(EPL)
|
||||||
|
groups=(coin-or)
|
||||||
|
depends=(coin-or-osi suitesparse)
|
||||||
|
source=("https://www.coin-or.org/download/source/Clp/Clp-${pkgver}.tgz"
|
||||||
|
0001-Remove-MMX-header.patch)
|
||||||
|
sha256sums=('e92cda578075289a2b70c90f2461c985523c5331c65c2a4f16abfc6da2a77adc'
|
||||||
|
'c7b7998438cc250bae33934d9f7ce0fe4600b39a71faf88f00542b938084ebcd')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd Clp-$pkgver/Clp
|
||||||
|
patch -p2 -i $srcdir/0001-Remove-MMX-header.patch
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd Clp-$pkgver/Clp
|
||||||
|
COIN_SKIP_PROJECTS="Sample" \
|
||||||
|
./configure --prefix=/usr \
|
||||||
|
--with-osi-lib="$(pkg-config --libs osi)" \
|
||||||
|
--with-osi-incdir="/usr/include/coin/" \
|
||||||
|
--with-coinutils-lib="$(pkg-config --libs coinutils)" \
|
||||||
|
--with-coinutils-incdir="/usr/include/coin/" \
|
||||||
|
--with-cholmod-lib='-lcholmod' --with-cholmod-incdir=/usr/include
|
||||||
|
make
|
||||||
|
}
|
||||||
|
|
||||||
|
check() {
|
||||||
|
cd Clp-$pkgver/Clp
|
||||||
|
# make test
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
cd Clp-$pkgver/Clp
|
||||||
|
PKG_CONFIG_LIBDIR="$pkgdir"/usr/lib/pkgconfig/ \
|
||||||
|
make DESTDIR="$pkgdir" install
|
||||||
|
}
|
Loading…
Reference in a new issue