extra/boost to 1.48.0-2

This commit is contained in:
Kevin Mihelich 2011-12-03 13:46:05 -05:00
parent e35d254e05
commit f2dd8e283f
2 changed files with 73 additions and 8 deletions

View file

@ -0,0 +1,60 @@
Index: /trunk/boost/foreach_fwd.hpp
===================================================================
--- /trunk/boost/foreach_fwd.hpp (revision 62661)
+++ /trunk/boost/foreach_fwd.hpp (revision 75540)
@@ -15,4 +15,6 @@
#define BOOST_FOREACH_FWD_HPP
+#include <utility> // for std::pair
+
// This must be at global scope, hence the uglified name
enum boost_foreach_argument_dependent_lookup_hack
@@ -26,4 +28,7 @@
namespace foreach
{
+ template<typename T>
+ std::pair<T, T> in_range(T begin, T end);
+
///////////////////////////////////////////////////////////////////////////////
// boost::foreach::tag
@@ -47,4 +52,22 @@
} // namespace foreach
+// Workaround for unfortunate https://svn.boost.org/trac/boost/ticket/6131
+namespace BOOST_FOREACH
+{
+ using foreach::in_range;
+ using foreach::tag;
+
+ template<typename T>
+ struct is_lightweight_proxy
+ : foreach::is_lightweight_proxy<T>
+ {};
+
+ template<typename T>
+ struct is_noncopyable
+ : foreach::is_noncopyable<T>
+ {};
+
+} // namespace BOOST_FOREACH
+
} // namespace boost
Index: /trunk/boost/foreach.hpp
===================================================================
--- /trunk/boost/foreach.hpp (revision 75077)
+++ /trunk/boost/foreach.hpp (revision 75540)
@@ -166,5 +166,5 @@
// at the global namespace for your type.
template<typename T>
-inline boost::foreach::is_lightweight_proxy<T> *
+inline boost::BOOST_FOREACH::is_lightweight_proxy<T> *
boost_foreach_is_lightweight_proxy(T *&, BOOST_FOREACH_TAG_DEFAULT) { return 0; }
@@ -191,5 +191,5 @@
// at the global namespace for your type.
template<typename T>
-inline boost::foreach::is_noncopyable<T> *
+inline boost::BOOST_FOREACH::is_noncopyable<T> *
boost_foreach_is_noncopyable(T *&, BOOST_FOREACH_TAG_DEFAULT) { return 0; }

View file

@ -1,4 +1,4 @@
# $Id: PKGBUILD 141623 2011-10-31 21:27:41Z ibiru $
# $Id: PKGBUILD 144044 2011-12-02 20:54:11Z ibiru $
# Maintainer: kevin <kevin@archlinux.org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Kritoke <kritoke@gamebox.net>
@ -12,17 +12,19 @@ plugrel=1
pkgbase=boost
pkgname=('boost-libs' 'boost')
pkgver=1.47.0
pkgver=1.48.0
_boostver=${pkgver//./_}
pkgrel=3
pkgrel=2
arch=('i686' 'x86_64')
url="http://www.boost.org/"
makedepends=('icu' 'python' 'python2' 'bzip2' 'zlib')
source=(http://downloads.sourceforge.net/${pkgbase}/${pkgbase}_${_boostver}.tar.gz
exceptions.patch)
exceptions.patch
BOOST_FOREACH.patch)
license=('custom')
md5sums=('ff180a5276bec773a7625cac7e2288e8'
'9b44c28b36303152050c8c82469569c5')
md5sums=('313a11e97eb56eb7efd18325354631be'
'9b44c28b36303152050c8c82469569c5'
'2db6098a1a39bced4c6162eb46418320')
_stagedir="${srcdir}/stagedir"
@ -32,9 +34,12 @@ build() {
echo "using python : 2.7 : /usr/bin/python2 ;" >> build/v2/user-config.jam
echo "using python : 3.2 : /usr/bin/python : /usr/include/python3.2mu : /usr/lib ;" >> build/v2/user-config.jam
# http://web.archiveorange.com/archive/v/Q0J4VE5bwsy3zxRXqUgd
cd "${srcdir}"/${pkgbase}_${_boostver}
patch -p0 -i "${srcdir}"/exceptions.patch
# https://svn.boost.org/trac/boost/ticket/5731
patch -p0 -i "${srcdir}/exceptions.patch"
# https://svn.boost.org/trac/boost/ticket/6131
patch -p2 -i "${srcdir}/BOOST_FOREACH.patch"
# build bjam
cd "${srcdir}/${pkgbase}_${_boostver}/tools/build/v2/engine"