diff --git a/core/pacman-mirrorlist/PKGBUILD b/core/pacman-mirrorlist/PKGBUILD
new file mode 100755
index 000000000..230a62033
--- /dev/null
+++ b/core/pacman-mirrorlist/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 66563 2010-01-31 21:48:51Z dan $
+# Maintainer: Dan McGee <dan@archlinux.org>
+
+pkgname=pacman-mirrorlist
+pkgver=20100131
+pkgrel=1
+pkgdesc="PlugBox Linux mirror list for use by pacman"
+arch=('arm')
+url="http://www.archlinux.org/pacman/"
+license=('GPL')
+groups=('base')
+backup=(etc/pacman.d/mirrorlist)
+source=(mirrorlist)
+
+# NOTE on building this package:
+# * Go to the trunk/ directory
+# * Run bash -c ". PKGBUILD; updatelist"
+# * Update the checksums, update pkgver
+# * Build the package
+
+build() {
+  mkdir -p $pkgdir/etc/pacman.d
+  install -m644 $srcdir/mirrorlist $pkgdir/etc/pacman.d/
+  # customize mirrorlist to architecture
+  sed -i -e "s/@carch@/${CARCH}/g" $pkgdir/etc/pacman.d/mirrorlist
+}
+
+md5sums=('958304eb7a6ff087e086ede79246048c')
diff --git a/core/pacman-mirrorlist/mirrorlist b/core/pacman-mirrorlist/mirrorlist
new file mode 100755
index 000000000..b3869b5cd
--- /dev/null
+++ b/core/pacman-mirrorlist/mirrorlist
@@ -0,0 +1,7 @@
+#
+# PlugBox Linux repository mirrorlist
+# Generated on 2010-02-04
+#
+
+# Main Server
+Server = http://plugapps.com/@arch@/$repo
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index ec9069ba6..7167e0632 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -3,23 +3,23 @@
 
 pkgname=pacman
 pkgver=3.3.3
-pkgrel=1
+pkgrel=2
 pkgdesc="A library-based package manager with dependency support"
 arch=('arm')
 url="http://www.archlinux.org/pacman/"
 license=('GPL')
 groups=('base')
-depends=('bash' 'libarchive>=2.7.1' 'libfetch>=2.25')
+depends=('bash' 'libarchive>=2.7.1' 'libfetch>=2.25' 'pacman-mirrorlist')
 optdepends=('fakeroot: for makepkg usage as normal user'
             'python: for rankmirrors script usage')
-backup=(etc/pacman.conf etc/makepkg.conf)
+backup=(etc/makepkg.conf)
 install=pacman.install
 options=(!libtool)
 source=(ftp://ftp.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz
         pacman.conf
         makepkg.conf)
 md5sums=('a8cef73d68e2a4c3a46fb46c33210719'
-         '98cfef5a0c41a987ba9ee5672345026b'
+         '8a1eea46c9af940a8812dfb4bbbd159d'
          'ce00f190714c02ef26117ecfdf5fa296')
 
 build() {
diff --git a/core/pacman/pacman.conf b/core/pacman/pacman.conf
index 2db138e65..47bb64ed0 100644
--- a/core/pacman/pacman.conf
+++ b/core/pacman/pacman.conf
@@ -38,10 +38,10 @@ SyncFirst   = pacman
 #
 
 [core]
-Server = http://plugapps.com/arm/core/
+Include=/etc/pacman.d/mirrorlist
 
 [extra]
-Server = http://plugapps.com/arm/extra/
+Include=/etc/pacman.d/mirrorlist
 
 [community]
-Server = http://plugapps.com/arm/community/
+Include=/etc/pacman.d/mirrorlist