extra/qt5-webkit-ng to 5.212.0-1

This commit is contained in:
Kevin Mihelich 2017-06-08 23:39:21 +00:00
parent 1fcf055e52
commit f3f1942eea
3 changed files with 70 additions and 14 deletions

View file

@ -4,10 +4,10 @@
# - disable jit on v5/v6
pkgname=qt5-webkit-ng
_qtver=tp5
_qtver=5.212.0
pkgver=${_qtver/-/}
pkgrel=4
arch=(i686 x86_64)
pkgrel=1
arch=(x86_64)
url='https://github.com/annulen/webkit/wiki'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='Classes for a WebKit2 based implementation and a new QML API (maintained fork)'
@ -16,21 +16,24 @@ makedepends=(cmake ruby gperf python2 qt5-doc qt5-tools)
optdepends=('gst-plugins-good: Webm codec support')
conflicts=(qt5-webkit)
provides=(qt5-webkit)
source=("https://github.com/annulen/webkit/archive/qtwebkit-$pkgver.tar.gz"
qtwebkit-ng-export-cmake-variables.patch::"https://github.com/annulen/webkit/commit/1467a945.patch"
qt5-webkit-icu59.patch)
sha256sums=('04bcb819675be6ebe0bba81519319dede6510512a73ef53d20465f91034ee719'
'e7839c2eb2d4f998a6c7f6316f408bb8a948c769f8d987903368b0fe689558c6'
'e1306e696ad7125fa00083aa966be0ea6fe6de555c9e1d119957f208f258edfe')
source=("https://github.com/annulen/webkit/archive/qtwebkit-$pkgver-alpha.tar.gz"
qt5-webkit-icu59.patch qt5-webkit-ng-gcc7.patch qt5-webkit-ng-functional.patch)
sha256sums=('bf8637ad44efd781893c60a932256f435f538bea63333a7f438b897500044d98'
'e1306e696ad7125fa00083aa966be0ea6fe6de555c9e1d119957f208f258edfe'
'58ecbd8708f5afe4e974fdcd6c1f32fea61ccc55dc9bb711768f2d0da6963fb8'
'c85344edcc23930c0190b2f8ec3847bf8bdbbf7f1d4fa877c502e354e5f4233e')
prepare() {
mkdir -p build
# Correctly export all needed cmake variables
cd webkit-qtwebkit-$pkgver
patch -p1 -i ../qtwebkit-ng-export-cmake-variables.patch
cd webkit-qtwebkit-$pkgver-alpha
# Fix build with ICU 59 (PLD linux)
patch -p1 -i ../qt5-webkit-icu59.patch
# Fix build with GCC 7
patch -p1 -i ../qt5-webkit-ng-gcc7.patch
patch -p1 -i ../qt5-webkit-ng-functional.patch
sed -e 's|-Wundef|-Wundef -Wno-expansion-to-defined|' -i Source/cmake/WebKitHelpers.cmake
}
build() {
@ -38,10 +41,11 @@ build() {
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && CONFIG="-DENABLE_JIT=OFF"
cmake ../webkit-qtwebkit-$pkgver \
cmake ../webkit-qtwebkit-$pkgver-alpha \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DPORT=Qt $CONFIG
-DPORT=Qt \
-DENABLE_TOOLS=OFF $CONFIG
make
}

View file

@ -0,0 +1,40 @@
--- webkit-qtwebkit-tp5/Source/JavaScriptCore/inspector/InspectorBackendDispatcher.h.orig 2017-06-01 06:14:55.587195469 +0000
+++ webkit-qtwebkit-tp5/Source/JavaScriptCore/inspector/InspectorBackendDispatcher.h 2017-06-01 06:15:23.040491577 +0000
@@ -32,6 +32,7 @@
#include <wtf/Optional.h>
#include <wtf/RefCounted.h>
#include <wtf/text/WTFString.h>
+#include <functional>
namespace Inspector {
--- webkit-qtwebkit-tp5/Source/WebCore/css/CSSValue.h.orig 2017-06-01 07:48:18.099623726 +0000
+++ webkit-qtwebkit-tp5/Source/WebCore/css/CSSValue.h 2017-06-01 07:48:41.542925091 +0000
@@ -27,6 +27,7 @@
#include <wtf/RefCounted.h>
#include <wtf/RefPtr.h>
#include <wtf/TypeCasts.h>
+#include <functional>
namespace WebCore {
--- webkit-qtwebkit-tp5/Source/WebCore/css/StyleSheetContents.h.orig 2017-06-01 08:33:31.792577087 +0000
+++ webkit-qtwebkit-tp5/Source/WebCore/css/StyleSheetContents.h 2017-06-01 08:33:44.715892348 +0000
@@ -30,6 +30,7 @@
#include <wtf/Vector.h>
#include <wtf/text/AtomicStringHash.h>
#include <wtf/text/TextPosition.h>
+#include <functional>
namespace WebCore {
--- webkit-qtwebkit-tp5/Source/WebCore/loader/ResourceLoader.h.orig 2017-06-01 09:47:50.463011889 +0000
+++ webkit-qtwebkit-tp5/Source/WebCore/loader/ResourceLoader.h 2017-06-01 09:48:21.976300680 +0000
@@ -35,6 +35,7 @@
#include "ResourceRequest.h"
#include "ResourceResponse.h"
#include <wtf/Forward.h>
+#include <functional>
namespace WTF {
class SchedulePair;

View file

@ -0,0 +1,12 @@
Index: /trunk/Source/JavaScriptCore/runtime/JSArrayBufferView.h
===================================================================
--- trunk/Source/JavaScriptCore/runtime/JSArrayBufferView.h (revision 211433)
+++ trunk/Source/JavaScriptCore/runtime/JSArrayBufferView.h (revision 211434)
@@ -168,5 +168,5 @@
void neuter();
- void* vector()
+ void* vector() const
{
return m_vector.getPredicated(
this,