removed community/z3

This commit is contained in:
Kevin Mihelich 2019-09-29 22:29:43 +00:00
parent 04628d16b3
commit f41c8a1c7a
2 changed files with 0 additions and 99 deletions

View file

@ -1,61 +0,0 @@
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor: rudy.matela
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch from Fedora to fix ARM FTBFS
pkgbase=z3
pkgname=('z3' 'python-z3')
pkgver=4.8.5
pkgrel=1
pkgdesc='High-performance theorem prover'
url='https://github.com/Z3Prover/z3'
arch=('x86_64')
license=('MIT')
# 'java-environment-common' 'mono' 'ocaml' 'ocaml-findlib'
makedepends=('cmake' 'python' 'python-setuptools' 'gcc-libs' 'gmp')
source=(https://github.com/Z3Prover/z3/archive/Z3-${pkgver}.tar.gz
z3-no-sse.patch)
sha512sums=('ca36e1a0332bd473a64f41dfdb31656fb3486178473e4fd4934dccce109a84c9686c08f94998df74bacb588eb12ea5db25dc17a564ee76f82fd2559349697309'
'90dc75045745c59456327a92b6b6b90547f7a6f130720bb683cc5f6c3ea46fcef271e74d2d319c05515af48061414d2eca3c7d6b4e36451547e07f30e8ece132')
prepare() {
cd ${pkgbase}-Z3-${pkgver}
mkdir -p build
patch -p0 -i ../z3-no-sse.patch
}
build() {
cd ${pkgbase}-Z3-${pkgver}/build
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_PYTHON_BINDINGS=1 \
-DPYTHON_EXECUTABLE=/usr/bin/python \
-DUSE_LIB_GMP=1
make
}
package_z3() {
depends=('gcc-libs' 'gmp')
provides=('libz3' 'libz3.so')
cd ${pkgbase}-Z3-${pkgver}/build
make DESTDIR="${pkgdir}" install
install -Dm 644 ../LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
rm -r "${pkgdir}"/usr/lib/python*
}
package_python-z3() {
depends=('python' 'libz3')
cd ${pkgbase}-Z3-${pkgver}/build
make DESTDIR="${pkgdir}" install
install -Dm 644 ../LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
cd "${pkgdir}"
rm -r usr/include usr/bin usr/lib/cmake usr/lib/lib*
python -m compileall .
python -O -m compileall .
}
# vim: ts=2 sw=2 et:

View file

@ -1,38 +0,0 @@
--- scripts/mk_util.py.orig 2018-10-15 13:52:38.000000000 -0600
+++ scripts/mk_util.py 2018-10-31 19:27:59.067093823 -0600
@@ -112,7 +112,7 @@ GUARD_CF=False
ALWAYS_DYNAMIC_BASE=False
FPMATH="Default"
-FPMATH_FLAGS="-mfpmath=sse -msse -msse2"
+FPMATH_FLAGS=""
def check_output(cmd):
@@ -294,10 +294,10 @@ def test_fpmath(cc):
t = TempFile('tstsse.cpp')
t.add('int main() { return 42; }\n')
t.commit()
- if exec_compiler_cmd([cc, CPPFLAGS, 'tstsse.cpp', LDFLAGS, '-mfpmath=sse -msse -msse2']) == 0:
+ if None:
FPMATH_FLAGS="-mfpmath=sse -msse -msse2"
return "SSE2-GCC"
- elif exec_compiler_cmd([cc, CPPFLAGS, 'tstsse.cpp', LDFLAGS, '-msse -msse2']) == 0:
+ elif None:
FPMATH_FLAGS="-msse -msse2"
return "SSE2-CLANG"
elif exec_compiler_cmd([cc, CPPFLAGS, 'tstsse.cpp', LDFLAGS, '-mfpu=vfp -mfloat-abi=hard']) == 0:
--- src/util/hwf.cpp.orig 2018-10-15 13:52:38.000000000 -0600
+++ src/util/hwf.cpp 2018-10-31 19:28:42.528890124 -0600
@@ -46,9 +46,9 @@ Revision History:
// clear to the compiler what instructions should be used. E.g., for sqrt(), the Windows compiler selects
// the x87 FPU, even when /arch:SSE2 is on.
// Luckily, these are kind of standardized, at least for Windows/Linux/macOS.
-#ifdef __clang__
+//#ifdef __clang__
#undef USE_INTRINSICS
-#endif
+//#endif
#ifdef USE_INTRINSICS
#include <emmintrin.h>