mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed alarm/llvm38
This commit is contained in:
parent
078217e2c8
commit
f46e63e381
5 changed files with 0 additions and 1845 deletions
|
@ -1,322 +0,0 @@
|
|||
Index: cfe/trunk/docs/ItaniumMangleAbiTags.rst
|
||||
===================================================================
|
||||
--- cfe/trunk/docs/ItaniumMangleAbiTags.rst
|
||||
+++ cfe/trunk/docs/ItaniumMangleAbiTags.rst
|
||||
@@ -0,0 +1,101 @@
|
||||
+========
|
||||
+ABI tags
|
||||
+========
|
||||
+
|
||||
+Introduction
|
||||
+============
|
||||
+
|
||||
+This text tries to describe gcc semantic for mangling "abi_tag" attributes
|
||||
+described in https://gcc.gnu.org/onlinedocs/gcc/C_002b_002b-Attributes.html
|
||||
+
|
||||
+There is no guarantee the following rules are correct, complete or make sense
|
||||
+in any way as they were determined empirically by experiments with gcc5.
|
||||
+
|
||||
+Declaration
|
||||
+===========
|
||||
+
|
||||
+ABI tags are declared in an abi_tag attribute and can be applied to a
|
||||
+function, variable, class or inline namespace declaration. The attribute takes
|
||||
+one or more strings (called tags); the order does not matter.
|
||||
+
|
||||
+See https://gcc.gnu.org/onlinedocs/gcc/C_002b_002b-Attributes.html for
|
||||
+details.
|
||||
+
|
||||
+Tags on an inline namespace are called "implicit tags", all other tags are
|
||||
+"explicit tags".
|
||||
+
|
||||
+Mangling
|
||||
+========
|
||||
+
|
||||
+All tags that are "active" on an <unqualified-name> are emitted after the
|
||||
+<unqualified-name>, before <template-args> or <discriminator>, and are part of
|
||||
+the same <substitution> the <unqualified-name> is.
|
||||
+
|
||||
+They are mangled as:
|
||||
+
|
||||
+ <abi-tags> ::= <abi-tag>* # sort by name
|
||||
+ <abi-tag> ::= B <tag source-name>
|
||||
+
|
||||
+Example:
|
||||
+
|
||||
+ __attribute__((abi_tag("test")))
|
||||
+ void Func();
|
||||
+
|
||||
+ gets mangled as: _Z4FuncB4testv (prettified as `Func[abi:test]()`)
|
||||
+
|
||||
+Active tags
|
||||
+===========
|
||||
+
|
||||
+A namespace does not have any active tags. For types (class / struct / union /
|
||||
+enum), the explicit tags are the active tags.
|
||||
+
|
||||
+For variables and functions, the active tags are the explicit tags plus any
|
||||
+"required tags" which are not in the "available tags" set:
|
||||
+
|
||||
+ derived-tags := (required-tags - available-tags)
|
||||
+ active-tags := explicit-tags + derived-tags
|
||||
+
|
||||
+Required tags for a function
|
||||
+============================
|
||||
+
|
||||
+If a function is used as a local scope for another name, and is part of
|
||||
+another function as local scope, it doesn't have any required tags.
|
||||
+
|
||||
+If a function is used as a local scope for a guard variable name, it doesn't
|
||||
+have any required tags.
|
||||
+
|
||||
+Otherwise the function requires any implicit or explicit tag used in the name
|
||||
+for the return type.
|
||||
+
|
||||
+Example:
|
||||
+ namespace A {
|
||||
+ inline namespace B __attribute__((abi_tag)) {
|
||||
+ struct C { int x; };
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ A::C foo();
|
||||
+
|
||||
+ gets mangled as: _Z3fooB1Bv (prettified as `foo[abi:B]()`)
|
||||
+
|
||||
+Required tags for a variable
|
||||
+============================
|
||||
+
|
||||
+A variable requires any implicit or explicit tag used in its type.
|
||||
+
|
||||
+Available tags
|
||||
+==============
|
||||
+
|
||||
+All tags used in the prefix and in the template arguments for a name are
|
||||
+available. Also, for functions, all tags from the <bare-function-type>
|
||||
+(which might include the return type for template functions) are available.
|
||||
+
|
||||
+For <local-name>s all active tags used in the local part (<function-
|
||||
+encoding>) are available, but not implicit tags which were not active.
|
||||
+
|
||||
+Implicit and explicit tags used in the <unqualified-name> for a function (as
|
||||
+in the type of a cast operator) are NOT available.
|
||||
+
|
||||
+Example: a cast operator to std::string (which is
|
||||
+std::__cxx11::basic_string<...>) will use 'cxx11' as an active tag, as it is
|
||||
+required from the return type `std::string` but not available.
|
||||
Index: cfe/trunk/include/clang/Basic/Attr.td
|
||||
===================================================================
|
||||
--- cfe/trunk/include/clang/Basic/Attr.td
|
||||
+++ cfe/trunk/include/clang/Basic/Attr.td
|
||||
@@ -358,6 +358,14 @@
|
||||
// Attributes begin here
|
||||
//
|
||||
|
||||
+def AbiTag : Attr {
|
||||
+ let Spellings = [GCC<"abi_tag">];
|
||||
+ let Args = [VariadicStringArgument<"Tags">];
|
||||
+ let Subjects = SubjectList<[Struct, Var, Function, Namespace], ErrorDiag,
|
||||
+ "ExpectedStructClassVariableFunctionOrInlineNamespace">;
|
||||
+ let Documentation = [AbiTagsDocs];
|
||||
+}
|
||||
+
|
||||
def AddressSpace : TypeAttr {
|
||||
let Spellings = [GNU<"address_space">];
|
||||
let Args = [IntArgument<"AddressSpace">];
|
||||
Index: cfe/trunk/include/clang/Basic/AttrDocs.td
|
||||
===================================================================
|
||||
--- cfe/trunk/include/clang/Basic/AttrDocs.td
|
||||
+++ cfe/trunk/include/clang/Basic/AttrDocs.td
|
||||
@@ -2132,3 +2132,16 @@
|
||||
optimizations like C++'s named return value optimization (NRVO).
|
||||
}];
|
||||
}
|
||||
+
|
||||
+def AbiTagsDocs : Documentation {
|
||||
+ let Content = [{
|
||||
+The ``abi_tag`` attribute can be applied to a function, variable, class or
|
||||
+inline namespace declaration to modify the mangled name of the entity. It gives
|
||||
+the ability to distinguish between different versions of the same entity but
|
||||
+with different ABI versions supported. For example, a newer version of a class
|
||||
+could have a different set of data members and thus have a different size. Using
|
||||
+the ``abi_tag`` attribute, it is possible to have different mangled names for
|
||||
+a global variable of the class type. Therefor, the old code could keep using
|
||||
+the old manged name and the new code will use the new mangled name with tags.
|
||||
+ }];
|
||||
+}
|
||||
Index: cfe/trunk/include/clang/Basic/DiagnosticSemaKinds.td
|
||||
===================================================================
|
||||
--- cfe/trunk/include/clang/Basic/DiagnosticSemaKinds.td
|
||||
+++ cfe/trunk/include/clang/Basic/DiagnosticSemaKinds.td
|
||||
@@ -2477,7 +2477,8 @@
|
||||
"Objective-C instance methods|init methods of interface or class extension declarations|"
|
||||
"variables, functions and classes|Objective-C protocols|"
|
||||
"functions and global variables|structs, unions, and typedefs|structs and typedefs|"
|
||||
- "interface or protocol declarations|kernel functions|non-K&R-style functions}1">,
|
||||
+ "interface or protocol declarations|kernel functions|non-K&R-style functions|"
|
||||
+ "structs, classes, variables, functions, and inline namespaces}1">,
|
||||
InGroup<IgnoredAttributes>;
|
||||
def err_attribute_wrong_decl_type : Error<warn_attribute_wrong_decl_type.Text>;
|
||||
def warn_type_attribute_wrong_type : Warning<
|
||||
@@ -4195,6 +4196,13 @@
|
||||
def err_redefinition_extern_inline : Error<
|
||||
"redefinition of a 'extern inline' function %0 is not supported in "
|
||||
"%select{C99 mode|C++}1">;
|
||||
+def warn_attr_abi_tag_namespace : Warning<
|
||||
+ "'abi_tag' attribute on %select{non-inline|anonymous}0 namespace ignored">,
|
||||
+ InGroup<IgnoredAttributes>;
|
||||
+def err_abi_tag_on_redeclaration : Error<
|
||||
+ "cannot add 'abi_tag' attribute in a redeclaration">;
|
||||
+def err_new_abi_tag_on_redeclaration : Error<
|
||||
+ "'abi_tag' %0 missing in original declaration">;
|
||||
|
||||
def note_deleted_dtor_no_operator_delete : Note<
|
||||
"virtual destructor requires an unambiguous, accessible 'operator delete'">;
|
||||
Index: cfe/trunk/include/clang/Sema/AttributeList.h
|
||||
===================================================================
|
||||
--- cfe/trunk/include/clang/Sema/AttributeList.h
|
||||
+++ cfe/trunk/include/clang/Sema/AttributeList.h
|
||||
@@ -895,7 +895,8 @@
|
||||
ExpectedStructOrTypedef,
|
||||
ExpectedObjectiveCInterfaceOrProtocol,
|
||||
ExpectedKernelFunction,
|
||||
- ExpectedFunctionWithProtoType
|
||||
+ ExpectedFunctionWithProtoType,
|
||||
+ ExpectedStructClassVariableFunctionOrInlineNamespace
|
||||
};
|
||||
|
||||
} // end namespace clang
|
||||
Index: cfe/trunk/lib/Sema/SemaDecl.cpp
|
||||
===================================================================
|
||||
--- cfe/trunk/lib/Sema/SemaDecl.cpp
|
||||
+++ cfe/trunk/lib/Sema/SemaDecl.cpp
|
||||
@@ -2398,6 +2398,24 @@
|
||||
}
|
||||
}
|
||||
|
||||
+ // Re-declaration cannot add abi_tag's.
|
||||
+ if (const auto *NewAbiTagAttr = New->getAttr<AbiTagAttr>()) {
|
||||
+ if (const auto *OldAbiTagAttr = Old->getAttr<AbiTagAttr>()) {
|
||||
+ for (const auto &NewTag : NewAbiTagAttr->tags()) {
|
||||
+ if (std::find(OldAbiTagAttr->tags_begin(), OldAbiTagAttr->tags_end(),
|
||||
+ NewTag) == OldAbiTagAttr->tags_end()) {
|
||||
+ Diag(NewAbiTagAttr->getLocation(),
|
||||
+ diag::err_new_abi_tag_on_redeclaration)
|
||||
+ << NewTag;
|
||||
+ Diag(OldAbiTagAttr->getLocation(), diag::note_previous_declaration);
|
||||
+ }
|
||||
+ }
|
||||
+ } else {
|
||||
+ Diag(NewAbiTagAttr->getLocation(), diag::err_abi_tag_on_redeclaration);
|
||||
+ Diag(Old->getLocation(), diag::note_previous_declaration);
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
if (!Old->hasAttrs())
|
||||
return;
|
||||
|
||||
Index: cfe/trunk/lib/Sema/SemaDeclAttr.cpp
|
||||
===================================================================
|
||||
--- cfe/trunk/lib/Sema/SemaDeclAttr.cpp
|
||||
+++ cfe/trunk/lib/Sema/SemaDeclAttr.cpp
|
||||
@@ -4615,6 +4615,42 @@
|
||||
Attr.getRange(), S.Context, Attr.getAttributeSpellingListIndex()));
|
||||
}
|
||||
|
||||
+static void handleAbiTagAttr(Sema &S, Decl *D, const AttributeList &Attr) {
|
||||
+ SmallVector<std::string, 4> Tags;
|
||||
+ for (unsigned I = 0, E = Attr.getNumArgs(); I != E; ++I) {
|
||||
+ StringRef Tag;
|
||||
+ if (!S.checkStringLiteralArgumentAttr(Attr, I, Tag))
|
||||
+ return;
|
||||
+ Tags.push_back(Tag);
|
||||
+ }
|
||||
+
|
||||
+ if (const auto *NS = dyn_cast<NamespaceDecl>(D)) {
|
||||
+ if (!NS->isInline()) {
|
||||
+ S.Diag(Attr.getLoc(), diag::warn_attr_abi_tag_namespace) << 0;
|
||||
+ return;
|
||||
+ }
|
||||
+ if (NS->isAnonymousNamespace()) {
|
||||
+ S.Diag(Attr.getLoc(), diag::warn_attr_abi_tag_namespace) << 1;
|
||||
+ return;
|
||||
+ }
|
||||
+ if (Attr.getNumArgs() == 0)
|
||||
+ Tags.push_back(NS->getName());
|
||||
+ } else if (!checkAttributeAtLeastNumArgs(S, Attr, 1))
|
||||
+ return;
|
||||
+
|
||||
+ // Store tags sorted and without duplicates.
|
||||
+ std::sort(Tags.begin(), Tags.end());
|
||||
+ Tags.erase(std::unique(Tags.begin(), Tags.end()), Tags.end());
|
||||
+
|
||||
+ D->addAttr(::new (S.Context)
|
||||
+ AbiTagAttr(Attr.getRange(), S.Context, Tags.data(), Tags.size(),
|
||||
+ Attr.getAttributeSpellingListIndex()));
|
||||
+
|
||||
+ // FIXME: remove this warning as soon as mangled part is ready.
|
||||
+ S.Diag(Attr.getRange().getBegin(), diag::warn_attribute_ignored)
|
||||
+ << Attr.getName();
|
||||
+}
|
||||
+
|
||||
static void handleARMInterruptAttr(Sema &S, Decl *D,
|
||||
const AttributeList &Attr) {
|
||||
// Check the attribute arguments.
|
||||
@@ -5637,6 +5673,9 @@
|
||||
case AttributeList::AT_Thread:
|
||||
handleDeclspecThreadAttr(S, D, Attr);
|
||||
break;
|
||||
+ case AttributeList::AT_AbiTag:
|
||||
+ handleAbiTagAttr(S, D, Attr);
|
||||
+ break;
|
||||
|
||||
// Thread safety attributes:
|
||||
case AttributeList::AT_AssertExclusiveLock:
|
||||
Index: cfe/trunk/test/SemaCXX/attr-abi-tag-syntax.cpp
|
||||
===================================================================
|
||||
--- cfe/trunk/test/SemaCXX/attr-abi-tag-syntax.cpp
|
||||
+++ cfe/trunk/test/SemaCXX/attr-abi-tag-syntax.cpp
|
||||
@@ -0,0 +1,43 @@
|
||||
+// RUN: %clang_cc1 -std=c++11 -fsyntax-only -verify %s
|
||||
+
|
||||
+namespace N1 {
|
||||
+
|
||||
+namespace __attribute__((__abi_tag__)) {}
|
||||
+// expected-warning@-1 {{'abi_tag' attribute on non-inline namespace ignored}}
|
||||
+
|
||||
+namespace N __attribute__((__abi_tag__)) {}
|
||||
+// expected-warning@-1 {{'abi_tag' attribute on non-inline namespace ignored}}
|
||||
+
|
||||
+} // namespace N1
|
||||
+
|
||||
+namespace N2 {
|
||||
+
|
||||
+inline namespace __attribute__((__abi_tag__)) {}
|
||||
+// expected-warning@-1 {{'abi_tag' attribute on anonymous namespace ignored}}
|
||||
+
|
||||
+inline namespace N __attribute__((__abi_tag__)) {}
|
||||
+// FIXME: remove this warning as soon as attribute fully supported.
|
||||
+// expected-warning@-2 {{'__abi_tag__' attribute ignored}}
|
||||
+
|
||||
+} // namespcace N2
|
||||
+
|
||||
+__attribute__((abi_tag("B", "A"))) extern int a1;
|
||||
+// FIXME: remove this warning as soon as attribute fully supported.
|
||||
+// expected-warning@-2 {{'abi_tag' attribute ignored}}
|
||||
+
|
||||
+__attribute__((abi_tag("A", "B"))) extern int a1;
|
||||
+// expected-note@-1 {{previous declaration is here}}
|
||||
+// FIXME: remove this warning as soon as attribute fully supported.
|
||||
+// expected-warning@-3 {{'abi_tag' attribute ignored}}
|
||||
+
|
||||
+__attribute__((abi_tag("A", "C"))) extern int a1;
|
||||
+// expected-error@-1 {{'abi_tag' C missing in original declaration}}
|
||||
+// FIXME: remove this warning as soon as attribute fully supported.
|
||||
+// expected-warning@-3 {{'abi_tag' attribute ignored}}
|
||||
+
|
||||
+extern int a2;
|
||||
+// expected-note@-1 {{previous declaration is here}}
|
||||
+__attribute__((abi_tag("A")))extern int a2;
|
||||
+// expected-error@-1 {{cannot add 'abi_tag' attribute in a redeclaration}}
|
||||
+// FIXME: remove this warning as soon as attribute fully supported.
|
||||
+// expected-warning@-3 {{'abi_tag' attribute ignored}}
|
File diff suppressed because it is too large
Load diff
|
@ -1,255 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
|
||||
# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
|
||||
# Contributor: Sebastian Nowicki <sebnow@gmail.com>
|
||||
# Contributor: Devin Cofer <ranguvar{AT]archlinux[DOT}us>
|
||||
# Contributor: Tobias Kieslich <tobias@justdreams.de>
|
||||
# Contributor: Geoffroy Carrier <geoffroy.carrier@aur.archlinux.org>
|
||||
# Contributor: Tomas Lindquist Olsen <tomas@famolsen.dk>
|
||||
# Contributor: Roberto Alsina <ralsina@kde.org>
|
||||
# Contributor: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - separate package for ARMv5; latest version doesn't build for it
|
||||
# - v5: disable compiler-rt, don't install in clang package
|
||||
# - v5: patch to remove ThreadPool: unsupported c++ usage
|
||||
# - v5: disable lldb, unsupported c++ usage
|
||||
# - v8: disable lldb, unsupported architecture
|
||||
|
||||
buildarch=2
|
||||
|
||||
pkgname=('llvm38' 'llvm38-libs' 'llvm38-ocaml' 'clang38' 'clang38-tools-extra')
|
||||
pkgver=3.8.1
|
||||
pkgrel=1
|
||||
_ocaml_ver=4.03.0
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://llvm.org/"
|
||||
license=('custom:University of Illinois/NCSA Open Source License')
|
||||
makedepends=('cmake' 'libffi' 'python2' "ocaml=$_ocaml_ver" 'python-sphinx'
|
||||
'ocaml-ctypes' 'ocaml-findlib' 'libedit' 'swig')
|
||||
# Use gcc-multilib to build 32-bit compiler-rt libraries on x86_64 (FS#41911)
|
||||
makedepends_x86_64=('gcc-multilib')
|
||||
options=('staticlibs')
|
||||
source=(http://llvm.org/releases/$pkgver/llvm-$pkgver.src.tar.xz{,.sig}
|
||||
http://llvm.org/releases/$pkgver/cfe-$pkgver.src.tar.xz{,.sig}
|
||||
http://llvm.org/releases/$pkgver/clang-tools-extra-$pkgver.src.tar.xz{,.sig}
|
||||
http://llvm.org/releases/$pkgver/compiler-rt-$pkgver.src.tar.xz{,.sig}
|
||||
http://llvm.org/releases/$pkgver/lldb-$pkgver.src.tar.xz{,.sig}
|
||||
D17567-PR23529-Sema-part-of-attrbute-abi_tag-support.patch
|
||||
D18035-PR23529-Mangler-part-of-attrbute-abi_tag-support.patch
|
||||
llvm-Config-llvm-config.h
|
||||
remove-threadpool.patch)
|
||||
sha256sums=('6e82ce4adb54ff3afc18053d6981b6aed1406751b8742582ed50f04b5ab475f9'
|
||||
'SKIP'
|
||||
'4cd3836dfb4b88b597e075341cae86d61c63ce3963e45c7fe6a8bf59bb382cdf'
|
||||
'SKIP'
|
||||
'664a5c60220de9c290bf2a5b03d902ab731a4f95fe73a00856175ead494ec396'
|
||||
'SKIP'
|
||||
'0df011dae14d8700499dfc961602ee0a9572fef926202ade5dcdfe7858411e5c'
|
||||
'SKIP'
|
||||
'349148116a47e39dcb5d5042f10d8a6357d2c865034563283ca512f81cdce8a3'
|
||||
'SKIP'
|
||||
'406754764e83d58bc3b859ab4b7893abd48c760278c4619cf4341ef9b9b75c85'
|
||||
'd71f8677882c86accddb8a5b720f298a4d7a2ad3bce6091951a46396b8f14da1'
|
||||
'597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48'
|
||||
'ea686a21076aeefdb81af22ab7e5d786e4f6d490507320275f443d8bcf663040')
|
||||
validpgpkeys=('B6C8F98282B944E3B0D5C2530FC3042E345AD05D'
|
||||
'11E521D646982372EB577A1F8F0871F202119294')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/llvm-$pkgver.src"
|
||||
|
||||
# At the present, clang must reside inside the LLVM source code tree to build
|
||||
# See http://llvm.org/bugs/show_bug.cgi?id=4840
|
||||
mv "$srcdir/cfe-$pkgver.src" tools/clang
|
||||
|
||||
mv "$srcdir/clang-tools-extra-$pkgver.src" tools/clang/tools/extra
|
||||
|
||||
mv "$srcdir/compiler-rt-$pkgver.src" projects/compiler-rt
|
||||
|
||||
[[ $CARCH != 'aarch64' && $CARCH != 'arm' ]] && mv "$srcdir/lldb-$pkgver.src" tools/lldb
|
||||
|
||||
# https://llvm.org/bugs/show_bug.cgi?id=23529
|
||||
patch -d tools/clang -Np2 <../D17567-PR23529-Sema-part-of-attrbute-abi_tag-support.patch
|
||||
patch -d tools/clang -Np0 <../D18035-PR23529-Mangler-part-of-attrbute-abi_tag-support.patch
|
||||
|
||||
if [[ $CARCH == "arm" ]]; then
|
||||
patch -p1 -i ../remove-threadpool.patch
|
||||
rm lib/Support/ThreadPool.cpp
|
||||
rm include/llvm/Support/ThreadPool.h
|
||||
rm unittests/Support/ThreadPool.cpp
|
||||
fi
|
||||
|
||||
mkdir build
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/llvm-$pkgver.src/build"
|
||||
|
||||
[[ $CARCH == "arm" ]] && CONFIG="-DLLVM_BUILD_EXTERNAL_COMPILER_RT=ON"
|
||||
|
||||
cmake \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DLLVM_BUILD_LLVM_DYLIB=ON \
|
||||
-DLLVM_DYLIB_EXPORT_ALL=ON \
|
||||
-DLLVM_LINK_LLVM_DYLIB=ON \
|
||||
-DLLVM_ENABLE_RTTI=ON \
|
||||
-DLLVM_ENABLE_FFI=ON \
|
||||
-DLLVM_BUILD_TESTS=ON \
|
||||
-DLLVM_BUILD_DOCS=ON \
|
||||
-DLLVM_ENABLE_SPHINX=ON \
|
||||
-DLLVM_ENABLE_DOXYGEN=OFF \
|
||||
-DSPHINX_WARNINGS_AS_ERRORS=OFF \
|
||||
-DFFI_INCLUDE_DIR=$(pkg-config --variable=includedir libffi) \
|
||||
-DLLVM_BINUTILS_INCDIR=/usr/include \
|
||||
$CONFIG ..
|
||||
|
||||
make
|
||||
make ocaml_doc
|
||||
|
||||
# Disable automatic installation of components that go into subpackages
|
||||
sed -i '/\(clang\|lldb\)\/cmake_install.cmake/d' tools/cmake_install.cmake
|
||||
sed -i '/extra\/cmake_install.cmake/d' tools/clang/tools/cmake_install.cmake
|
||||
sed -i '/compiler-rt\/cmake_install.cmake/d' projects/cmake_install.cmake
|
||||
}
|
||||
|
||||
check() {
|
||||
cd "$srcdir/llvm-$pkgver.src/build"
|
||||
make check
|
||||
make check-clang
|
||||
}
|
||||
|
||||
package_llvm38() {
|
||||
pkgdesc="Low Level Virtual Machine"
|
||||
depends=("llvm-libs=$pkgver-$pkgrel" 'perl')
|
||||
replaces=('llvm')
|
||||
provides=("llvm=$pkgver-$pkgrel")
|
||||
|
||||
cd "$srcdir/llvm-$pkgver.src"
|
||||
|
||||
make -C build DESTDIR="$pkgdir" install
|
||||
|
||||
# Remove documentation sources
|
||||
rm -r "$pkgdir"/usr/share/doc/llvm/html/{_sources,.buildinfo}
|
||||
|
||||
# The runtime libraries go into llvm-libs
|
||||
mv -f "$pkgdir"/usr/lib/lib{LLVM,LTO}*.so "$srcdir"
|
||||
mv -f "$pkgdir"/usr/lib/LLVMgold.so "$srcdir"
|
||||
|
||||
# OCaml bindings go to a separate package
|
||||
rm -rf "$srcdir"/ocaml.{lib,doc}
|
||||
mv "$pkgdir/usr/lib/ocaml" "$srcdir/ocaml.lib"
|
||||
mv "$pkgdir/usr/docs/ocaml/html" "$srcdir/ocaml.doc"
|
||||
rm -r "$pkgdir/usr/docs"
|
||||
|
||||
if [[ $CARCH == x86_64 ]]; then
|
||||
# Needed for multilib (https://bugs.archlinux.org/task/29951)
|
||||
# Header stub is taken from Fedora
|
||||
mv "$pkgdir/usr/include/llvm/Config/llvm-config"{,-64}.h
|
||||
cp "$srcdir/llvm-Config-llvm-config.h" \
|
||||
"$pkgdir/usr/include/llvm/Config/llvm-config.h"
|
||||
fi
|
||||
|
||||
install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/llvm/LICENSE"
|
||||
}
|
||||
|
||||
package_llvm38-libs() {
|
||||
pkgdesc="Low Level Virtual Machine (runtime libraries)"
|
||||
depends=('gcc-libs' 'zlib' 'libffi' 'libedit' 'ncurses')
|
||||
replaces=('llvm-libs')
|
||||
provides=("llvm-libs=$pkgver-$pkgrel")
|
||||
|
||||
install -d "$pkgdir/usr/lib"
|
||||
cp -P \
|
||||
"$srcdir"/lib{LLVM,LTO}*.so \
|
||||
"$srcdir"/LLVMgold.so \
|
||||
"$pkgdir/usr/lib/"
|
||||
|
||||
# Symlink LLVMgold.so from /usr/lib/bfd-plugins
|
||||
# https://bugs.archlinux.org/task/28479
|
||||
install -d "$pkgdir/usr/lib/bfd-plugins"
|
||||
ln -s ../LLVMgold.so "$pkgdir/usr/lib/bfd-plugins/LLVMgold.so"
|
||||
|
||||
install -Dm644 "$srcdir/llvm-$pkgver.src/LICENSE.TXT" \
|
||||
"$pkgdir/usr/share/licenses/llvm-libs/LICENSE"
|
||||
}
|
||||
|
||||
package_llvm38-ocaml() {
|
||||
pkgdesc="OCaml bindings for LLVM"
|
||||
depends=("llvm=$pkgver-$pkgrel" "ocaml=$_ocaml_ver" 'ocaml-ctypes')
|
||||
replaces=('llvm-ocaml')
|
||||
provides=("llvm-ocaml=$pkgver-$pkgrel")
|
||||
|
||||
cd "$srcdir/llvm-$pkgver.src"
|
||||
|
||||
install -d "$pkgdir"/{usr/lib,usr/share/doc}
|
||||
cp -a "$srcdir/ocaml.lib" "$pkgdir/usr/lib/ocaml"
|
||||
cp -a "$srcdir/ocaml.doc" "$pkgdir/usr/share/doc/llvm-ocaml"
|
||||
|
||||
install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/llvm-ocaml/LICENSE"
|
||||
}
|
||||
|
||||
package_clang38() {
|
||||
pkgdesc="C language family frontend for LLVM"
|
||||
url="http://clang.llvm.org/"
|
||||
depends=("llvm-libs=$pkgver-$pkgrel" 'gcc' 'libxml2')
|
||||
optdepends=('openmp: OpenMP support in clang with -fopenmp'
|
||||
'python2: for scan-view and git-clang-format')
|
||||
provides=("clang-analyzer=$pkgver" "clang=$pkgver-$pkgrel")
|
||||
conflicts=('clang-analyzer')
|
||||
replaces=('clang-analyzer' 'clang')
|
||||
|
||||
cd "$srcdir/llvm-$pkgver.src"
|
||||
|
||||
make -C build/tools/clang DESTDIR="$pkgdir" install
|
||||
[[ $CARCH != "arm" ]] && make -C build/projects/compiler-rt DESTDIR="$pkgdir" install
|
||||
|
||||
# Remove documentation sources
|
||||
rm -r "$pkgdir"/usr/share/doc/clang/html/{_sources,.buildinfo}
|
||||
|
||||
# Move analyzer scripts out of /usr/libexec
|
||||
mv "$pkgdir"/usr/libexec/{ccc,c++}-analyzer "$pkgdir/usr/lib/clang/"
|
||||
rmdir "$pkgdir/usr/libexec"
|
||||
sed -i 's|libexec|lib/clang|' "$pkgdir/usr/bin/scan-build"
|
||||
|
||||
# Install Python bindings
|
||||
install -d "$pkgdir/usr/lib/python2.7/site-packages"
|
||||
cp -a tools/clang/bindings/python/clang "$pkgdir/usr/lib/python2.7/site-packages/"
|
||||
|
||||
# Use Python 2
|
||||
sed -i 's|/usr/bin/env python|&2|' \
|
||||
"$pkgdir/usr/bin/scan-view" \
|
||||
"$pkgdir/usr/bin/git-clang-format" \
|
||||
"$pkgdir/usr/share/clang/clang-format-diff.py"
|
||||
|
||||
# Compile Python scripts
|
||||
python2 -m compileall "$pkgdir"
|
||||
python2 -O -m compileall "$pkgdir"
|
||||
|
||||
install -Dm644 tools/clang/LICENSE.TXT \
|
||||
"$pkgdir/usr/share/licenses/clang/LICENSE"
|
||||
}
|
||||
|
||||
package_clang38-tools-extra() {
|
||||
pkgdesc="Extra tools built using clang's tooling APIs"
|
||||
url="http://clang.llvm.org/"
|
||||
depends=("clang=$pkgver-$pkgrel")
|
||||
provides=("clang-tools-extra=$pkgver-$pkgrel")
|
||||
replaces=('clang-tools-extra')
|
||||
|
||||
cd "$srcdir/llvm-$pkgver.src"
|
||||
|
||||
make -C build/tools/clang/tools/extra DESTDIR="$pkgdir" install
|
||||
|
||||
# Use Python 2
|
||||
sed -i \
|
||||
-e 's|env python$|&2|' \
|
||||
-e 's|/usr/bin/python$|&2|' \
|
||||
"$pkgdir"/usr/share/clang/{clang-tidy-diff,run-clang-tidy}.py
|
||||
|
||||
install -Dm644 tools/clang/tools/extra/LICENSE.TXT \
|
||||
"$pkgdir/usr/share/licenses/clang-tools-extra/LICENSE"
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
|
@ -1,9 +0,0 @@
|
|||
#include <bits/wordsize.h>
|
||||
|
||||
#if __WORDSIZE == 32
|
||||
#include "llvm-config-32.h"
|
||||
#elif __WORDSIZE == 64
|
||||
#include "llvm-config-64.h"
|
||||
#else
|
||||
#error "Unknown word size"
|
||||
#endif
|
|
@ -1,22 +0,0 @@
|
|||
diff -urN a/lib/Support/CMakeLists.txt b/lib/Support/CMakeLists.txt
|
||||
--- a/lib/Support/CMakeLists.txt 2015-12-14 17:59:19.000000000 -0700
|
||||
+++ b/lib/Support/CMakeLists.txt 2016-05-12 20:11:40.042874505 -0600
|
||||
@@ -89,7 +89,6 @@
|
||||
StringRef.cpp
|
||||
SystemUtils.cpp
|
||||
TargetParser.cpp
|
||||
- ThreadPool.cpp
|
||||
Timer.cpp
|
||||
ToolOutputFile.cpp
|
||||
Triple.cpp
|
||||
diff -urN a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
|
||||
--- a/unittests/Support/CMakeLists.txt 2015-12-22 10:36:17.000000000 -0700
|
||||
+++ b/unittests/Support/CMakeLists.txt 2016-05-12 21:31:22.669908242 -0600
|
||||
@@ -41,7 +41,6 @@
|
||||
SwapByteOrderTest.cpp
|
||||
TargetRegistry.cpp
|
||||
ThreadLocalTest.cpp
|
||||
- ThreadPool.cpp
|
||||
TimerTest.cpp
|
||||
TimeValueTest.cpp
|
||||
TrailingObjectsTest.cpp
|
Loading…
Reference in a new issue