mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
alarm/kodi-rpi-git to 20.x.60881.9a61029e54-1
Update to latest and remove unneeded patches
This commit is contained in:
parent
5d45a99467
commit
f4889db027
3 changed files with 4 additions and 83 deletions
|
@ -1,26 +0,0 @@
|
|||
From ff40de29a49bc212a0cdc4ef640effc2bad3cdfe Mon Sep 17 00:00:00 2001
|
||||
From: graysky <therealgraysky@proton.me>
|
||||
Date: Thu, 14 Jul 2022 11:19:30 -0400
|
||||
Subject: [PATCH] mcpu=cortex-xxx application to ffmpeg
|
||||
|
||||
Get build system to patch ffmpeg source removing the -march= flag
|
||||
|
||||
---
|
||||
cmake/modules/FindFFMPEG.cmake | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
|
||||
index 2ad78aa..5a81750 100644
|
||||
--- a/cmake/modules/FindFFMPEG.cmake
|
||||
+++ b/cmake/modules/FindFFMPEG.cmake
|
||||
@@ -98,6 +98,7 @@ macro(buildFFMPEG)
|
||||
${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/CMakeLists.txt
|
||||
<SOURCE_DIR> &&
|
||||
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
|
||||
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
|
||||
echo "########################################## patched ffmpeg ##############################"
|
||||
)
|
||||
|
||||
--
|
||||
2.37.1
|
||||
|
|
@ -13,8 +13,8 @@ pkgname=(
|
|||
'kodi-rpi-git-eventclients' 'kodi-rpi-git-tools-texturepacker' 'kodi-rpi-git-dev'
|
||||
)
|
||||
|
||||
_commitnumber=60860
|
||||
_commit=3df6637aef54aab668986be8108b1a5146c65709
|
||||
_commitnumber=60881
|
||||
_commit=9a61029e54224c730378629ee1d81b6d193484f0
|
||||
|
||||
# set this to anything to build with clang
|
||||
# recommend manually setting -DUSE_LTO=OFF to -DUSE_LTO=$(nproc) in build()
|
||||
|
@ -63,8 +63,6 @@ source=(
|
|||
"http://mirrors.kodi.tv/build-deps/sources/libudfread-$_libudfread_version.tar.gz"
|
||||
"ArchARM-kodi-init-v$_init_version.tar.gz::https://github.com/graysky2/kodi-standalone-service/archive/v$_init_version.tar.gz"
|
||||
kodi.config.txt
|
||||
use-mcpu-avoiding-march-and-mtune.patch
|
||||
0001-mcpu-cortex-application-to-ffmpeg.patch
|
||||
)
|
||||
backup=(boot/kodi.config.txt etc/conf.d/kodi-standalone)
|
||||
noextract=(
|
||||
|
@ -78,7 +76,7 @@ noextract=(
|
|||
"fstrcmp-$_fstrcmp_version.tar.gz"
|
||||
"libudfread-$_libudfread_version.tar.gz"
|
||||
)
|
||||
sha256sums=('5d18d7c5117d92daef49b936a278286ac14e08ddb90a69ee0161c4444b701c7f'
|
||||
sha256sums=('25daeafd5aed373757e9d0f66a285006cf2ec0c1c049832bd1ac81414caabbef'
|
||||
'f38c4a4e7a4f4da6d8e83b8852489aa3bb6588a915dc41f5ee89d9aad305a06e'
|
||||
'584f62a3896794408d46368e2ecf2c6217ab9c676ce85921b2d68b8961f49dfc'
|
||||
'719130091e3adc9725ba72df808f24a14737a009dca5a4c38c601c0c76449b62'
|
||||
|
@ -89,22 +87,11 @@ sha256sums=('5d18d7c5117d92daef49b936a278286ac14e08ddb90a69ee0161c4444b701c7f'
|
|||
'6fff9215f5cb81760be4cc16d033526d1080427d236e86d70bb02994f85e3d38'
|
||||
'2bf16726ac98d093156195bb049a663e07d3323e079c26912546f4e05c77bac5'
|
||||
'b94c70baa45e30346224ceecfab031dd183e09303b1f97d6522f9941da9b0067'
|
||||
'92d063169017bf9e1770d8a7cce77c0c55d197692d10820a7e4aecad9e58178c'
|
||||
'16d6c79ff3a3d3653f21d77a36326a0335c8cec49a9c06dbc2de0ed143e50a9f'
|
||||
'9c58877a1622d582e72f76940848dd19a6999c3e1d814abb79c6d35b6acad908')
|
||||
'92d063169017bf9e1770d8a7cce77c0c55d197692d10820a7e4aecad9e58178c')
|
||||
|
||||
prepare() {
|
||||
[[ -d kodi-build ]] && rm -rf kodi-build
|
||||
mkdir "$srcdir/kodi-build"
|
||||
|
||||
cd "xbmc-$_commit"
|
||||
|
||||
# put patch in source tree so kodi build system can pick it up
|
||||
cp ../use-mcpu-avoiding-march-and-mtune.patch \
|
||||
tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch
|
||||
|
||||
# patch kodi build system to apply the patch we just copied over
|
||||
patch -p1 -i ../0001-mcpu-cortex-application-to-ffmpeg.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
From 2e2417894ac5d35bc3d93b86c18f4df299f4d933 Mon Sep 17 00:00:00 2001
|
||||
From: graysky <graysky@archlinux.us>
|
||||
Date: Sat, 12 Dec 2020 09:10:28 -0500
|
||||
Subject: [PATCH] use -mcpu= avoiding -march and -mtune for armv7h
|
||||
|
||||
From what I understand, when building on ARM, it's best to avoid the -march=
|
||||
flag and rather use -mcpu= flag due to differences in meaning on ARM vs x86[1].
|
||||
Additionally, this patch avoids thousands of warns like the following when
|
||||
building for armv7h:
|
||||
cc1: warning: switch '-mcpu=cortex-a72' conflicts with '-march=armv8-a'
|
||||
|
||||
This is due to the way ffmpeg's configure script defines -march=armv8-a when it
|
||||
encounters any cortex-a* passed to it.
|
||||
|
||||
for reference and to experiment:
|
||||
untar ffmpeg, run ./configure, then inspect the output of ffbuild/config.mak and adjust:
|
||||
kodi-build/build/ffmpeg/src/ffmpeg-build/ffmpeg-prefix/src/ffmpeg-build/ffbuild/config.mak
|
||||
|
||||
1. https://community.arm.com/developer/tools-software/tools/b/tools-software-ides-blog/posts/compiler-flags-across-architectures-march-mtune-and-mcpu
|
||||
|
||||
---
|
||||
configure | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 8569a60..0d3aafb 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -4948,7 +4948,7 @@ elif enabled arm; then
|
||||
|
||||
case $cpu in
|
||||
armv*)
|
||||
- cpuflags="-march=$cpu"
|
||||
+ cpuflags="-mcpu=cortex-a53"
|
||||
subarch=$(echo $cpu | sed 's/[^a-z0-9]//g')
|
||||
;;
|
||||
*)
|
||||
--
|
||||
2.29.2
|
||||
|
Loading…
Reference in a new issue