mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
Removed znc, added uboot-iconnect source
This commit is contained in:
parent
8ed2a164d6
commit
f4d65b51f0
5 changed files with 42 additions and 29 deletions
|
@ -1,20 +0,0 @@
|
|||
# Contributor: mickael9 <mickael9 at gmail dot com>
|
||||
|
||||
pkgname=znc
|
||||
pkgver=0.094
|
||||
pkgrel=1
|
||||
pkgdesc='An IRC proxy (bouncer) with modules & scripts support'
|
||||
arch=(i686 x86_64 arm)
|
||||
url=http://en.znc.in/wiki/index.php/ZNC
|
||||
license=(GPL)
|
||||
depends=(gcc-libs perl openssl c-ares)
|
||||
makedepends=(perl openssl gcc pkgconfig)
|
||||
source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
|
||||
md5sums=('db101f7a7756285d824b59e3b33e3ad5')
|
||||
|
||||
build() {
|
||||
cd $srcdir/$pkgname-$pkgver
|
||||
./configure --prefix=/usr --enable-extra || return 1
|
||||
make || return 1
|
||||
make install DESTDIR=$pkgdir
|
||||
}
|
|
@ -1,4 +0,0 @@
|
|||
This package is very compiling-intensive, there are a few things to note:
|
||||
1. It took ~30 minutes to compile, distributed across 2 Dockstars.
|
||||
2. It will eat through all physical RAM on a Dockstar, you must have swap space to compile.
|
||||
3. I wouldn't bother cross-compiling on qemu unless you have proven your setup to be faster than the plugs.
|
|
@ -1,5 +0,0 @@
|
|||
TODO for ZNC package:
|
||||
|
||||
* Possibly start configuration after install? Or give a [y/N] prompt to start it.
|
||||
* Create some standard rc.d daemon scripts, dropping root privileges.
|
||||
* Automatically create a new 'znc' user to drop root to?
|
32
uboot-iconnect/PKGBUILD
Normal file
32
uboot-iconnect/PKGBUILD
Normal file
|
@ -0,0 +1,32 @@
|
|||
# Maintainer: Mike Staszel <mikestaszel@plugapps.com>
|
||||
|
||||
pkgname=u-boot-iconnect
|
||||
pkgver=2010.11
|
||||
pkgrel=1
|
||||
pkgdesc="u-Boot for the iConnect"
|
||||
arch=('arm')
|
||||
url="ftp://ftp.denx.de/pub/u-boot/"
|
||||
license=('GPL')
|
||||
source=(http://plugapps.com/os/iconnect/uboot/$pkgname-$pkgver.tar.gz
|
||||
iconnect.patch
|
||||
)
|
||||
md5sums=('d597f7d5ac6ea41f49e667dd08f08a34'
|
||||
'c4a24f13c3693eb59250d791efad3320')
|
||||
LDFLAGS=""
|
||||
|
||||
build() {
|
||||
cd $srcdir/u-boot
|
||||
patch -p1 -i $srcdir/iconnect.patch || return 1
|
||||
|
||||
make iconnect_config || return 1
|
||||
make u-boot.kwb || return 1
|
||||
# echo "Building u-boot.bin.pagesize"
|
||||
# # Slow but does the trick
|
||||
# bytes=$(stat --format='%s' u-boot.bin)
|
||||
# fillbytes=$[262144-$bytes]
|
||||
# cp u-boot.bin u-boot.bin.pagesize
|
||||
# while [ $fillbytes -ne 0 ]; do
|
||||
# printf "\xff" >>u-boot.bin.pagesize
|
||||
# fillbytes=$[$fillbytes-1]
|
||||
# done
|
||||
}
|
10
uboot-iconnect/iconnect.patch
Normal file
10
uboot-iconnect/iconnect.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/boards.cfg 2010-11-07 21:03:05.000000000 -0600
|
||||
+++ b/boards.cfg 2010-11-07 21:11:49.000000000 -0600
|
||||
@@ -376,6 +376,7 @@
|
||||
mv88f6281gtw_ge arm arm926ejs - Marvell kirkwood
|
||||
openrd_base arm arm926ejs - Marvell kirkwood
|
||||
sheevaplug arm arm926ejs - Marvell kirkwood
|
||||
+iconnect arm arm926ejs - Marvell kirkwood
|
||||
imx27lite arm arm926ejs imx27lite logicpd mx27
|
||||
magnesium arm arm926ejs imx27lite logicpd mx27
|
||||
omap5912osk arm arm926ejs - ti omap
|
Loading…
Reference in a new issue