community/powerdns-recursor to 4.4.2-1

This commit is contained in:
Kevin Mihelich 2021-02-12 13:43:30 +00:00
parent 2b473eab91
commit f5a8ab08f0
2 changed files with 4 additions and 64 deletions

View file

@ -1,16 +1,16 @@
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Maintainer: Remi Gacogne <rgacogne[at]archlinux[dot]org>
# Contributor: Alexander Rødseth <rodseth@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
# Contributor: Jan Steffens <heftig@archlinux.org>
# Contributor: Remi Gacogne <rgacogne[at]archlinux[dot]org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - explicitly link v5/v6 with libatomic
# - remove makedepend on pandoc
pkgname=powerdns-recursor
pkgver=4.3.5
pkgrel=4
pkgver=4.4.2
pkgrel=1
pkgdesc='Resolving DNS server'
url='https://www.powerdns.com/'
arch=('x86_64')
@ -22,11 +22,9 @@ provides=('pdns-recursor')
conflicts=('pdns-recursor')
backup=('etc/powerdns/recursor.conf')
source=(https://downloads.powerdns.com/releases/pdns-recursor-${pkgver}.tar.bz2{,.asc}
boost-1.73.patch
sysusers.conf)
sha512sums=('2d39e6016000951c0beca38b26c41664b57c059dee762d7499f34e599ed6c2653af73edb31ba5a8d35f749534f24c0d85b6aedf4c35dc8a05777ffebd1b25851'
sha512sums=('31fdf62d87e5ee8f9570c6b738339bc8cc65c43800f18c7fb49aa5c53fc9ad76a1ddf02cc44f7129e06b41700b5cb3768ff8f81cc521c28147ea6538c73f8781'
'SKIP'
'5000bcb3e58c559d4e59105cedc7befb037bca3ef62730718ee6113c940fdb462d0ff7b47b8881d30139d7dfd1e5832a33dbe7f57b48e385f5359406486de7fe'
'63b3f0664d38fbbcb6b1c914cee050a27eca0a15550962973743580dd5d3ace2e68272ca2d856d53cc74001fe9246d61207ebbc74524c096736777ed08c88e72')
validpgpkeys=('B76CD4671C0968BAA87DE61C5E50715BF2FFE1A7' # Pieter Lexis <pieter.lexis@powerdns.com>
'FBAE0323821C7706A5CA151BDCF513FA7EED19F3' # Peter van Dijk <peter.van.dijk@powerdns.com>
@ -34,7 +32,6 @@ validpgpkeys=('B76CD4671C0968BAA87DE61C5E50715BF2FFE1A7' # Pieter Lexis <pieter
prepare() {
cd pdns-recursor-${pkgver}
patch -Np1 -i ../boost-1.73.patch
autoreconf -i
}

View file

@ -1,57 +0,0 @@
diff --git a/webserver.cc b/webserver.cc
index eafd305..b47cc6d 100644
--- a/webserver.cc
+++ b/webserver.cc
@@ -107,7 +107,7 @@ static void bareHandlerWrapper(WebServer::HandlerFunction handler, YaHTTP::Reque
void WebServer::registerBareHandler(const string& url, HandlerFunction handler)
{
- YaHTTP::THandlerFunction f = boost::bind(&bareHandlerWrapper, handler, _1, _2);
+ YaHTTP::THandlerFunction f = std::bind(&bareHandlerWrapper, handler, std::placeholders::_1, std::placeholders::_2);
YaHTTP::Router::Any(url, f);
}
@@ -179,7 +179,7 @@ void WebServer::apiWrapper(WebServer::HandlerFunction handler, HttpRequest* req,
}
void WebServer::registerApiHandler(const string& url, HandlerFunction handler, bool allowPassword) {
- HandlerFunction f = boost::bind(&WebServer::apiWrapper, this, handler, _1, _2, allowPassword);
+ HandlerFunction f = std::bind(&WebServer::apiWrapper, this, handler, std::placeholders::_1, std::placeholders::_2, allowPassword);
registerBareHandler(url, f);
}
@@ -196,7 +196,7 @@ void WebServer::webWrapper(WebServer::HandlerFunction handler, HttpRequest* req,
}
void WebServer::registerWebHandler(const string& url, HandlerFunction handler) {
- HandlerFunction f = boost::bind(&WebServer::webWrapper, this, handler, _1, _2);
+ HandlerFunction f = std::bind(&WebServer::webWrapper, this, handler, std::placeholders::_1, std::placeholders::_2);
registerBareHandler(url, f);
}
diff --git a/ws-recursor.cc b/ws-recursor.cc
index 26f992f..21946e8 100644
--- a/ws-recursor.cc
+++ b/ws-recursor.cc
@@ -382,9 +382,9 @@ static void apiServerCacheFlush(HttpRequest* req, HttpResponse* resp) {
DNSName canon = apiNameToDNSName(req->getvars["domain"]);
bool subtree = (req->getvars.count("subtree") > 0 && req->getvars["subtree"].compare("true") == 0);
- int count = broadcastAccFunction<uint64_t>(boost::bind(pleaseWipeCache, canon, subtree));
- count += broadcastAccFunction<uint64_t>(boost::bind(pleaseWipePacketCache, canon, subtree));
- count += broadcastAccFunction<uint64_t>(boost::bind(pleaseWipeAndCountNegCache, canon, subtree));
+ int count = broadcastAccFunction<uint64_t>(std::bind(pleaseWipeCache, canon, subtree));
+ count += broadcastAccFunction<uint64_t>(std::bind(pleaseWipePacketCache, canon, subtree));
+ count += broadcastAccFunction<uint64_t>(std::bind(pleaseWipeAndCountNegCache, canon, subtree));
resp->setBody(Json::object {
{ "count", count },
{ "result", "Flushed cache." }
@@ -664,7 +664,7 @@ void AsyncServerNewConnectionMT(void *p) {
void AsyncServer::asyncWaitForConnections(FDMultiplexer* fdm, const newconnectioncb_t& callback)
{
d_asyncNewConnectionCallback = callback;
- fdm->addReadFD(d_server_socket.getHandle(), boost::bind(&AsyncServer::newConnection, this));
+ fdm->addReadFD(d_server_socket.getHandle(), std::bind(&AsyncServer::newConnection, this));
}
void AsyncServer::newConnection()