extra/gperftools to 2.9.1-1.1

This commit is contained in:
Kevin Mihelich 2022-04-26 02:25:31 +00:00
parent 5c63bbd59c
commit f5ad4c6b51
2 changed files with 4 additions and 28 deletions

View file

@ -5,19 +5,16 @@
# Contributor: Joaquim Pedro <osmano807@gmail.com>
# Contributor: Jan Rüegg <rggjan@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - hack to skip using v7 assembly on v6
# - depend on libunwind for AArch64
# remove when bumped upstream
pkgname=gperftools
pkgver=2.9.1
pkgrel=1
pkgrel=1.1
pkgdesc="Fast, multi-threaded malloc and nifty performance analysis tools"
arch=('x86_64')
url="https://github.com/gperftools/gperftools"
license=('BSD')
depends=('perl')
depends_aarch64=('libunwind')
provides=('libtcmalloc.so'
'libprofiler.so'
'libtcmalloc_debug.so'
@ -26,16 +23,8 @@ provides=('libtcmalloc.so'
'libtcmalloc_minimal_debug.so')
optdepends=('graphviz: pprof graph generation'
'gv: pprof postscript generation')
source=(https://github.com/gperftools/gperftools/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz
"armv6.patch")
sha256sums=('ea566e528605befb830671e359118c2da718f721c27225cbbc93858c7520fee3'
'5a6b7c43ef4c916df930a6a59bef3285d19faffcdb6107a29a96552e53d243ee')
prepare() {
cd $pkgname-$pkgver
patch -p1 -i ../armv6.patch
}
source=(https://github.com/gperftools/gperftools/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz)
sha256sums=('ea566e528605befb830671e359118c2da718f721c27225cbbc93858c7520fee3')
build() {
cd $pkgname-$pkgver

View file

@ -1,13 +0,0 @@
diff --git a/src/base/atomicops.h b/src/base/atomicops.h
index dac95be..554d0a1 100644
--- a/src/base/atomicops.h
+++ b/src/base/atomicops.h
@@ -112,7 +112,7 @@
#include "base/atomicops-internals-gcc.h"
#elif defined(__MACH__) && defined(__APPLE__)
#include "base/atomicops-internals-macosx.h"
-#elif defined(__GNUC__) && defined(ARMV6)
+#elif defined(__GNUC__) && defined(ARMV7)
#include "base/atomicops-internals-arm-v6plus.h"
#elif defined(ARMV3)
#include "base/atomicops-internals-arm-generic.h"