extra/vlc to 3.0.3-2

This commit is contained in:
Kevin Mihelich 2018-07-11 19:50:12 +00:00
parent 4099632315
commit f5b3e8b612
2 changed files with 42 additions and 2 deletions

View file

@ -8,7 +8,7 @@
pkgname=vlc
pkgver=3.0.3
pkgrel=1
pkgrel=2
pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player'
url='https://www.videolan.org/vlc/'
arch=('x86_64')
@ -95,11 +95,13 @@ replaces=('vlc-plugin')
options=('!emptydirs')
source=(https://download.videolan.org/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz{,.asc}
update-vlc-plugin-cache.hook
aom-remove-unsupported-pixel-formats.patch
lua53_compat.patch
vlc-qt5.11.patch)
sha512sums=('1569cefa6623b2631a832679bc9a63ebeba222901e5221d254e896a68d2ee467054da8de9eda566924e80a11bb29a673a9f0c4243793845547d8027b58a238ab'
'SKIP'
'80357bae69e32b353d3784932d854e294906798e14faffb87c3383c3b6f6bdc57cbabb9c6e3f3c1adf0f8ddbb24153e72104c963cf1934970c2983c96daef9df'
'5757a6f35e106883072c31d137fd247c65a544f730cf736ca2e81a31357305b5c002b52349337d8e1667fbe68628bc253ec69eee727f268aee7902a5bef82dce'
'33cda373aa1fb3ee19a78748e2687f2b93c8662c9fda62ecd122a2e649df8edaceb54dda3991bc38c80737945a143a9e65baa2743a483bb737bb94cd590dc25f'
'66aad0ec32d1a96f65566b04eb9c0b4574824e281940fe5c0de54ac5f92189693a9f2576203d2c8562d7174ec5315cbbd683d93c481d16119d3038e30a58cbf5')
validpgpkeys=('65F7C6B4206BD057A7EB73787180713BE58D1ADC') # VideoLAN Release Signing Key
@ -108,9 +110,10 @@ prepare() {
cd ${pkgname}-${pkgver}
sed -e 's:truetype/ttf-dejavu:TTF:g' -i modules/visualization/projectm.cpp
sed -e 's|-Werror-implicit-function-declaration||g' -i configure
patch -Np1 < "${srcdir}/lua53_compat.patch"
sed 's|whoami|echo builduser|g' -i configure
sed 's|hostname -f|echo arch|g' -i configure
patch -Np1 < "${srcdir}/aom-remove-unsupported-pixel-formats.patch"
patch -Np1 < "${srcdir}/lua53_compat.patch"
patch -Np1 < "${srcdir}/vlc-qt5.11.patch"
}

View file

@ -0,0 +1,37 @@
From 622360c2c4335fff793f81f5e673326a581f5c0c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Martin=20Storsj=C3=B6?= <martin@martin.st>
Date: Thu, 19 Apr 2018 18:25:07 +0300
Subject: [PATCH] aom: Remove unsupported pixel formats
Support for these was apparently never in the codebase, and the enum
values were recently removed from the public headers [1].
This fixes build with latest libaom build.
[1] https://aomedia.googlesource.com/aom/+/3f29cc20e3a4c348cb41a797c68de856ddb84e12
---
modules/codec/aom.c | 11 -----------
1 file changed, 11 deletions(-)
diff --git a/modules/codec/aom.c b/modules/codec/aom.c
index 5bb442b5d50..60034158c47 100644
--- a/modules/codec/aom.c
+++ b/modules/codec/aom.c
@@ -116,17 +116,6 @@ static const struct
{ VLC_CODEC_YV12, AOM_IMG_FMT_YV12, 8, 0 },
{ VLC_CODEC_YUVA, AOM_IMG_FMT_444A, 8, 0 },
- { VLC_CODEC_YUYV, AOM_IMG_FMT_YUY2, 8, 0 },
- { VLC_CODEC_UYVY, AOM_IMG_FMT_UYVY, 8, 0 },
- { VLC_CODEC_YVYU, AOM_IMG_FMT_YVYU, 8, 0 },
-
- { VLC_CODEC_RGB15, AOM_IMG_FMT_RGB555, 8, 0 },
- { VLC_CODEC_RGB16, AOM_IMG_FMT_RGB565, 8, 0 },
- { VLC_CODEC_RGB24, AOM_IMG_FMT_RGB24, 8, 0 },
- { VLC_CODEC_RGB32, AOM_IMG_FMT_RGB32, 8, 0 },
-
- { VLC_CODEC_ARGB, AOM_IMG_FMT_ARGB, 8, 0 },
- { VLC_CODEC_BGRA, AOM_IMG_FMT_ARGB_LE, 8, 0 },
{ VLC_CODEC_GBR_PLANAR, AOM_IMG_FMT_I444, 8, 1 },
{ VLC_CODEC_GBR_PLANAR_10L, AOM_IMG_FMT_I44416, 10, 1 },