removed extra/texmacs

This commit is contained in:
Kevin Mihelich 2020-11-13 15:10:45 +00:00
parent ad92dae3ae
commit f5b400c451
3 changed files with 0 additions and 115 deletions

View file

@ -1,57 +0,0 @@
# Maintainer: Ronald van Haren <ronald.archlinux.org>
# Contributor: Damir Perisa <damir.perisa@bluewin.ch> # Contributor: Christopher Reimer <c.reimer1993@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix size_t check on ARM
pkgname=texmacs
pkgver=1.99.13
pkgrel=1
pkgdesc="Free scientific text editor, inspired by TeX and GNU Emacs. WYSIWYG editor TeX-fonts and CAS-interface (Giac, GTybalt, Macaulay 2, Maxima, Octave, Pari, Qcl, R and Yacas) in one."
arch=('x86_64')
url="http://www.texmacs.org/"
license=('GPL')
depends=('perl' 'guile1.8' 'texlive-core' 'python' 'libxext' 'freetype2' 'qt5-base')
# do not remove texlive-core dependency, as it is needed!
optdepends=('transfig: convert images using fig2ps'
'gawk: conversion of some files'
'ghostscript: rendering ps files'
'imagemagick: convert images'
'aspell: spell checking')
makedepends=('ghostscript' 'cmake')
source=(http://www.texmacs.org/Download/ftp/tmftp/source/TeXmacs-${pkgver}-src.tar.gz
texmacs-qt-5.15.patch
fix-size_t-check.patch)
options=('!emptydirs')
sha256sums=('02ad1c4b8ed0aa61501de97146300d7899605c25da827611ca4a40abbc07a9b4'
'0e8555ce855977858565c7eedd415a22e640eea0f1ce69adce1be0396542200d'
'09de18741b6a3b8590e76be52c571b2799b906cc3ecdd0eb6594c2ffdef3ad83')
prepare() {
cd TeXmacs-${pkgver}
patch -p1 -i ../texmacs-qt-5.15.patch # Fix build with Qt 5.15
patch -p1 -i ../fix-size_t-check.patch
}
build() {
cd TeXmacs-${pkgver}
mkdir -p build
cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DGUILECONFIG_EXECUTABLE=/usr/bin/guile-config1.8
make
}
package() {
cd TeXmacs-${pkgver}/build
make DESTDIR=${pkgdir} install
# fix fig2ps script
sed -i 's|${prefix}|/usr|' "${pkgdir}/usr/bin/fig2ps"
# fix launch script
sed -e 's|\@CONFIG_LIB_PATH\@|LD_LIBRARY_PATH|g' -i "$pkgdir"/usr/bin/texmacs
}

View file

@ -1,24 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 942b5adfd..f7e14ec08 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -291,16 +291,16 @@ check_c_source_compiles ("
#include <guile/gh.h>
#include <libguile.h>
void print_string (SCM s) {
- int len_r;
+ size_t len_r;
char* r= gh_scm2newstr (s, &len_r);
}
int main() { return 0; }
" _guile_str_size_test)
if (_guile_str_size_test)
- set (guile_str_size_t int)
-else (_guile_str_size_test)
set (guile_str_size_t size_t)
+else (_guile_str_size_test)
+ set (guile_str_size_t int)
endif (_guile_str_size_test)
message (STATUS "Checking whether ... arguments behave correctly")

View file

@ -1,34 +0,0 @@
From 3cf56af92326b74538f5e943928199ba6e963d0b Mon Sep 17 00:00:00 2001
From: rezso <rezso@rezso.net>
Date: Wed, 3 Jun 2020 19:33:29 +0200
Subject: [PATCH] Fix build with Qt 5.15
---
src/Plugins/Qt/QTMStyle.cpp | 1 +
src/Plugins/Qt/qt_renderer.cpp | 1 +
2 files changed, 2 insertions(+)
diff --git a/src/Plugins/Qt/QTMStyle.cpp b/src/Plugins/Qt/QTMStyle.cpp
index e1c05ece3..2bc819fac 100644
--- a/src/Plugins/Qt/QTMStyle.cpp
+++ b/src/Plugins/Qt/QTMStyle.cpp
@@ -18,6 +18,7 @@
#include <QStyleOptionMenuItem>
#include <qdrawutil.h>
#include <QPainter>
+#include <QPainterPath>
#include <QMainWindow>
int
diff --git a/src/Plugins/Qt/qt_renderer.cpp b/src/Plugins/Qt/qt_renderer.cpp
index ceba13939..776759bcf 100644
--- a/src/Plugins/Qt/qt_renderer.cpp
+++ b/src/Plugins/Qt/qt_renderer.cpp
@@ -21,6 +21,7 @@
#include <QObject>
#include <QWidget>
#include <QPaintDevice>
+#include <QPainterPath>
#include <QPixmap>
/******************************************************************************