removed extra/claws-mail

This commit is contained in:
David Beauchamp 2022-04-04 18:37:44 -04:00
parent b4fbcc534d
commit f629f80ed0
5 changed files with 0 additions and 194 deletions

View file

@ -1,43 +0,0 @@
From: paul <paul@claws-mail.org>
Date: Mon, 12 Jul 2021 09:08:33 +0000 (+0100)
Subject: move OAuth2 to last place in auto auth selection
X-Git-Url: http://git.claws-mail.org/?p=claws.git;a=commitdiff_plain;h=9c2585c58b49815a0eab8d683f0a94f75cbbe64e;hp=fae6b35be779b37270e76ef319128e3bb5251e51
move OAuth2 to last place in auto auth selection
IMAP: when using 'automatic' auth type, if the server offers LOGIN, GSSAPI or plaintext in addition to OAUTH2, yet OAUTH2 is unconfigured, authentication will fail. This broke previously working config
---
diff --git a/src/imap.c b/src/imap.c
index c486c471a..b72ceea76 100644
--- a/src/imap.c
+++ b/src/imap.c
@@ -951,14 +951,14 @@ static gint imap_auth(IMAPSession *session, const gchar *user, const gchar *pass
ok = imap_cmd_login(session, user, pass, "SCRAM-SHA-1");
if (ok == MAILIMAP_ERROR_LOGIN && imap_has_capability(session, "PLAIN"))
ok = imap_cmd_login(session, user, pass, "PLAIN");
- if (ok == MAILIMAP_ERROR_LOGIN && imap_has_capability(session, "XOAUTH2"))
- ok = imap_cmd_login(session, user, pass, "XOAUTH2");
if (ok == MAILIMAP_ERROR_LOGIN && imap_has_capability(session, "LOGIN"))
ok = imap_cmd_login(session, user, pass, "LOGIN");
if (ok == MAILIMAP_ERROR_LOGIN && imap_has_capability(session, "GSSAPI"))
ok = imap_cmd_login(session, user, pass, "GSSAPI");
if (ok == MAILIMAP_ERROR_LOGIN) /* we always try plaintext login before giving up */
ok = imap_cmd_login(session, user, pass, "plaintext");
+ if (ok == MAILIMAP_ERROR_LOGIN && imap_has_capability(session, "XOAUTH2"))
+ ok = imap_cmd_login(session, user, pass, "XOAUTH2");
}
if (ok == MAILIMAP_NO_ERROR)
@@ -994,6 +994,11 @@ static gint imap_auth(IMAPSession *session, const gchar *user, const gchar *pass
"LOGIN SASL plugin is installed.");
}
+ if (type == IMAP_AUTH_OAUTH2) {
+ ext_info = _("\n\nOAuth2 error. Check and correct your OAuth2 "
+ "account preferences.");
+ }
+
if (time(NULL) - last_login_err > 10) {
if (!prefs_common.no_recv_err_panel) {
alertpanel_error_log(_("Connection to %s failed: "

View file

@ -1,23 +0,0 @@
From: paul <paul@claws-mail.org>
Date: Mon, 12 Jul 2021 09:20:21 +0000 (+0100)
Subject: fix bug 4496 'Fancy crashes when opening an email'
X-Git-Url: http://git.claws-mail.org/?p=claws.git;a=commitdiff_plain;h=f459d1c27426a10af90f8ef73aef78ec846ebffb;hp=9c2585c58b49815a0eab8d683f0a94f75cbbe64e
fix bug 4496 'Fancy crashes when opening an email'
Patch by Jonathan Boeing
---
diff --git a/src/plugins/fancy/fancy_viewer.c b/src/plugins/fancy/fancy_viewer.c
index 6ff5f1244..d57d33aa7 100644
--- a/src/plugins/fancy/fancy_viewer.c
+++ b/src/plugins/fancy/fancy_viewer.c
@@ -96,7 +96,7 @@ static void fancy_apply_prefs(FancyViewer *viewer)
#endif
NULL);
if (fancy_prefs.stylesheet == NULL || strlen(fancy_prefs.stylesheet) == 0) {
- gchar **msg_font_params = g_strsplit(prefs_common.textfont, " ", 0);
+ gchar **msg_font_params = g_strsplit(prefs_common_get_prefs()->textfont, " ", 0);
guint params_len = g_strv_length(msg_font_params);
if (params_len > 0) {

View file

@ -1,88 +0,0 @@
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - drop valgrind makedepend
pkgname=claws-mail
pkgver=4.0.0
pkgrel=3
pkgdesc="A GTK+ based e-mail client"
arch=('x86_64')
license=('GPL3')
url="https://www.claws-mail.org"
depends=('gtk3' 'gnutls' 'startup-notification' 'enchant' 'gpgme'
'libetpan' 'compface' 'libsm' 'dbus-glib')
makedepends=('spamassassin' 'bogofilter' 'networkmanager'
# dependencies for plugins
'libgdata' 'libnotify' 'libcanberra' 'poppler-glib' 'libytnef' 'libical'
'dillo' 'python' 'gumbo-parser'
# deps to build the docs
'docbook-utils' 'texlive-formatsextra')
optdepends=('python: needed for some tools'
'perl: needed for some tools and perl plugin'
'spamassassin: adds support for spamfiltering'
'bogofilter: adds support for spamfiltering'
'libnotify: for notification plugin'
'libcanberra: for notification plugin'
'dbus: for notification plugin'
'libxml2: for rssyl plugins'
'curl: for vcalendar, rssyl and spamreport plugins'
'libarchive: for archive plugin and various other plugins'
'libytnef: for tnef_parse plugin'
'libgdata: for gdata plugin'
'poppler-glib: for pdf viewer plugin'
'ghostscript: for pdf viewer plugin'
'libical: for vcalendar plugin'
'dillo: for dillo html viewer plugin'
'webkit2gtk: for fancy webkit html viewer plugin'
'gumbo-parser: for litehtml plugin')
provides=('claws')
install=$pkgname.install
source=(https://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
0001_move_OAuth2_to_last_place_in_auto_auth_selection.diff
0002_Fancy_crashes_when_opening_an_email.diff
bash_completion)
sha256sums=('4af2bd26a5d91eacb2a9c09f67a6a46c2222b40817c1f525dc050bdc7b0ee475'
'SKIP'
'ffd5dfe8929a86667218512095a794263a2ae56fae4add83d3ad987f94e7f786'
'f56256a9535958063b966ab52abdf787422ff71ed2a5c41b3d9fea8716defe85'
'3f6c248b8658cd7a62186bff572cce2525712a498f363cbbda1ed459021c28cb')
validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
prepare() {
cd "${pkgname}"-${pkgver}
# upstream fixes
patch -Np1 -i ../0001_move_OAuth2_to_last_place_in_auto_auth_selection.diff
patch -Np1 -i ../0002_Fancy_crashes_when_opening_an_email.diff
}
build() {
cd "${pkgname}"-${pkgver}
./configure --prefix=/usr --disable-static \
--enable-enchant \
--enable-gnutls \
--enable-ldap \
--enable-crash-dialog \
--enable-pgpmime-plugin \
--enable-spamassassin-plugin \
--enable-bogofilter-plugin \
--enable-fancy-plugin \
--enable-manual
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
cd "${pkgname}"-${pkgver}
make DESTDIR="${pkgdir}" install
install -Dm 644 "$srcdir"/bash_completion "${pkgdir}"/usr/share/bash-completion/completions/claws-mail
# install extra tools
cd tools
install -m755 -d "${pkgdir}"/usr/lib/claws-mail/tools
for files in *.pl *.py *.sh *.conf tb2claws-mail update-po uudec uuooffice README; do
cp -arv $files "${pkgdir}"/usr/lib/claws-mail/tools/
done
}

View file

@ -1,30 +0,0 @@
# claws-mail(1) completion
_claws-mail()
{
local cur prev words cword
_init_completion || return
case $prev in
--help|-h|--version|-v|--version-full|-V)
return
;;
--alternate-config-dir)
COMPREPLY=( $( find . -maxdepth 2 -name clawsrc | sed 's,/clawsrc,,' ) )
return
;;
--select|--status|--status-full)
_filedir -d
return
;;
--compose-from-file|--attach)
_filedir
return
;;
esac
if [[ $cur == -* ]]; then
COMPREPLY=( $( compgen -W '$( _parse_help "$1" )' -- "$cur" ) )
return
fi
} &&
complete -F _claws-mail claws-mail

View file

@ -1,10 +0,0 @@
post_upgrade() {
if [ "`vercmp $2 4.0.0`" -lt 0 ]; then
cat << _EOF
>>> If you are upgrading from the GTK+ 2 version to the GTK+ 3 version
>>> of Claws Mail, you will need to reload any plugins that you want to use.
_EOF
fi
}