extra/qt5-base to 5.15.2-5

This commit is contained in:
Kevin Mihelich 2021-02-10 22:30:40 +00:00
parent a01b16213c
commit f631888800
2 changed files with 18 additions and 2 deletions

View file

@ -10,7 +10,7 @@ pkgbase=qt5-base
pkgname=(qt5-base qt5-xcb-private-headers)
_qtver=5.15.2
pkgver=${_qtver/-/}
pkgrel=3
pkgrel=5
arch=('x86_64')
url='https://www.qt.io'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
@ -35,15 +35,18 @@ groups=('qt' 'qt5')
_pkgfqn="${pkgbase/5-/}-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
qt5-base-cflags.patch
qt5-base-nostrip.patch
kdebug-428095.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch?id=c5336057")
sha256sums=('909fad2591ee367993a75d7e2ea50ad4db332f05e1c38dd7a5a274e156a4e0f8'
'cf707cd970650f8b60f8897692b36708ded9ba116723ec8fcd885576783fe85c'
'4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094'
'25b1059e92ae135b1b5031c5b1dde32d03906f17c9245ac1c2f9e1248917e7b0')
prepare() {
cd ${_pkgfqn}
patch -p1 -i ../qt5-base-cflags.patch # Use system CFLAGS
patch -p1 -i ../qt5-base-cflags.patch # Use system CFLAGS in qmake
patch -p1 -i ../qt5-base-nostrip.patch # Don't strip binaries with qmake
patch -p1 -i ../kdebug-428095.patch # Fix black border on some menus with Breeze
}

View file

@ -0,0 +1,13 @@
diff --git a/mkspecs/common/gcc-base.conf b/mkspecs/common/gcc-base.conf
index 99d77156fd..fc840fe9f6 100644
--- a/mkspecs/common/gcc-base.conf
+++ b/mkspecs/common/gcc-base.conf
@@ -31,6 +31,8 @@
# you can use the manual test in tests/manual/mkspecs.
#
+CONFIG += nostrip
+
QMAKE_CFLAGS_OPTIMIZE = -O2
QMAKE_CFLAGS_OPTIMIZE_FULL = -O3
QMAKE_CFLAGS_OPTIMIZE_DEBUG = -Og