mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
alarm/kodi-rbp4-git to 19.0a1.55799.18e29eee7e-1
This commit is contained in:
parent
b2a49e6833
commit
f66620a150
2 changed files with 19 additions and 63 deletions
|
@ -1,34 +0,0 @@
|
||||||
Upstream bug report, https://github.com/xbmc/xbmc/issues/16560
|
|
||||||
Patch by asavah, https://forum.kodi.tv/showthread.php?tid=349548
|
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index 2fb6bf5bed..52be5b649d 100644
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -163,7 +163,7 @@ find_package(JsonSchemaBuilder REQUIRED)
|
|
||||||
core_optional_dep(${optional_deps})
|
|
||||||
core_require_dep(${required_deps})
|
|
||||||
|
|
||||||
-SET(PYTHON_VERSION 3.7)
|
|
||||||
+SET(PYTHON_VERSION 3.8)
|
|
||||||
|
|
||||||
if(ENABLE_MARIADBCLIENT AND NOT ENABLE_MARIADBCLIENT STREQUAL AUTO AND ENABLE_MYSQLCLIENT AND NOT ENABLE_MYSQLCLIENT STREQUAL AUTO)
|
|
||||||
MESSAGE(FATAL_ERROR "You can not use MySql and MariaDB at the same time. Disable one by adding -DENABLE_MYSQLCLIENT=OFF or -DENABLE_MARIADBCLIENT=OFF.")
|
|
||||||
diff --git a/xbmc/interfaces/python/PythonInvoker.cpp b/xbmc/interfaces/python/PythonInvoker.cpp
|
|
||||||
index 4342e05dcd..660e82c254 100644
|
|
||||||
--- a/xbmc/interfaces/python/PythonInvoker.cpp
|
|
||||||
+++ b/xbmc/interfaces/python/PythonInvoker.cpp
|
|
||||||
@@ -8,6 +8,14 @@
|
|
||||||
|
|
||||||
// python.h should always be included first before any other includes
|
|
||||||
#include <Python.h>
|
|
||||||
+#if PY_VERSION_HEX >= 0x03080000
|
|
||||||
+# define Py_BUILD_CORE
|
|
||||||
+# undef HAVE_STD_ATOMIC
|
|
||||||
+/* for access to the fields of PyInterpreterState */
|
|
||||||
+# include "internal/pycore_pystate.h"
|
|
||||||
+# undef Py_BUILD_CORE
|
|
||||||
+# define HAVE_STD_ATOMIC
|
|
||||||
+#endif
|
|
||||||
#include <iterator>
|
|
||||||
#include <osdefs.h>
|
|
|
@ -14,22 +14,11 @@ pkgbase=kodi-rbp4-git
|
||||||
_suffix=rbp4-git
|
_suffix=rbp4-git
|
||||||
pkgname=("kodi-$_suffix" "kodi-eventclients-$_suffix" "kodi-tools-texturepacker-$_suffix" "kodi-dev-$_suffix")
|
pkgname=("kodi-$_suffix" "kodi-eventclients-$_suffix" "kodi-tools-texturepacker-$_suffix" "kodi-dev-$_suffix")
|
||||||
|
|
||||||
# which source to pull
|
|
||||||
# xbmc is vanilla upstream which currently lacks HEVC decoding in ffmpeg
|
|
||||||
# here as popcornmix has this code which is under review by ffmpeg for
|
|
||||||
# inclusion in some form
|
|
||||||
_source=popcornmix
|
|
||||||
#_source=xbmc
|
|
||||||
|
|
||||||
# vanilla kodi 19.0a1-Matrix
|
|
||||||
#_commitnumber=55510
|
|
||||||
#_commithash=db40b2ade4b6e13d6fead7004e819325e2ea0f0b
|
|
||||||
|
|
||||||
# popcornmix's gbm branch
|
# popcornmix's gbm branch
|
||||||
_commitnumber=55628
|
_commit=18e29eee7ee436fd574c9fddd810eb286488ff6f
|
||||||
_commithash=229a3c595bc20a7e76c8bb1665a9519adfdf0f84
|
_commitnumber=55799
|
||||||
|
|
||||||
pkgver="19.0a1.$_commitnumber"
|
pkgver="19.0a1.$_commitnumber.${_commit:0:10}"
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url="http://kodi.tv"
|
url="http://kodi.tv"
|
||||||
|
@ -40,7 +29,7 @@ makedepends=(
|
||||||
'libbluray' 'libcdio' 'libcec-rpi' 'libgl' 'mariadb-libs' 'libmicrohttpd'
|
'libbluray' 'libcdio' 'libcec-rpi' 'libgl' 'mariadb-libs' 'libmicrohttpd'
|
||||||
'libmodplug' 'libmpeg2' 'libnfs' 'libplist' 'libpulse' 'libva'
|
'libmodplug' 'libmpeg2' 'libnfs' 'libplist' 'libpulse' 'libva'
|
||||||
'libvdpau' 'libxrandr' 'libxslt' 'lirc' 'lzo' 'mesa' 'nasm'
|
'libvdpau' 'libxrandr' 'libxslt' 'lirc' 'lzo' 'mesa' 'nasm'
|
||||||
'python-pycryptodomex' 'python-pillow6' 'python-pybluez' 'python-simplejson'
|
'python-pycryptodomex' 'python-pillow' 'python-pybluez' 'python-simplejson'
|
||||||
'shairplay' 'smbclient' 'taglib' 'tinyxml' 'swig'
|
'shairplay' 'smbclient' 'taglib' 'tinyxml' 'swig'
|
||||||
'upower' 'giflib' 'rapidjson' 'ghostscript' 'git' 'meson' 'gtest'
|
'upower' 'giflib' 'rapidjson' 'ghostscript' 'git' 'meson' 'gtest'
|
||||||
'libinput' 'libxkbcommon' 'linux-raspberrypi4-headers'
|
'libinput' 'libxkbcommon' 'linux-raspberrypi4-headers'
|
||||||
|
@ -60,15 +49,14 @@ _codename=Leia
|
||||||
_libdvdcss_version="1.4.2-$_codename-Beta-5"
|
_libdvdcss_version="1.4.2-$_codename-Beta-5"
|
||||||
_libdvdnav_version="6.0.0-$_codename-Alpha-3"
|
_libdvdnav_version="6.0.0-$_codename-Alpha-3"
|
||||||
_libdvdread_version="6.0.0-$_codename-Alpha-3"
|
_libdvdread_version="6.0.0-$_codename-Alpha-3"
|
||||||
#_ffmpeg_version="4.3.1-Matrix-Alpha1-1"
|
_ffmpeg_version="4.3.1-Matrix-Alpha1-1"
|
||||||
_ffmpeg_version="4.3-Matrix-Alpha1"
|
|
||||||
_fmt_version="6.1.2"
|
_fmt_version="6.1.2"
|
||||||
_crossguid_version="8f399e8bd4"
|
_crossguid_version="8f399e8bd4"
|
||||||
_fstrcmp_version="0.7.D001"
|
_fstrcmp_version="0.7.D001"
|
||||||
_flatbuffers_version="1.11.0"
|
_flatbuffers_version="1.11.0"
|
||||||
_spdlog_version="1.5.0"
|
_spdlog_version="1.5.0"
|
||||||
source=(
|
source=(
|
||||||
"xbmc-$pkgver.tar.gz::https://github.com/$_source/xbmc/archive/$_commithash.tar.gz"
|
"xbmc-$pkgver.tar.gz::https://github.com/popcornmix/xbmc/archive/$_commit.tar.gz"
|
||||||
kodi.service
|
kodi.service
|
||||||
99-kodi.rules
|
99-kodi.rules
|
||||||
polkit.rules
|
polkit.rules
|
||||||
|
@ -82,9 +70,9 @@ source=(
|
||||||
"http://mirrors.kodi.tv/build-deps/sources/fstrcmp-$_fstrcmp_version.tar.gz"
|
"http://mirrors.kodi.tv/build-deps/sources/fstrcmp-$_fstrcmp_version.tar.gz"
|
||||||
"http://mirrors.kodi.tv/build-deps/sources/flatbuffers-$_flatbuffers_version.tar.gz"
|
"http://mirrors.kodi.tv/build-deps/sources/flatbuffers-$_flatbuffers_version.tar.gz"
|
||||||
"http://mirrors.kodi.tv/build-deps/sources/spdlog-$_spdlog_version.tar.gz"
|
"http://mirrors.kodi.tv/build-deps/sources/spdlog-$_spdlog_version.tar.gz"
|
||||||
000-python3.8.patch
|
|
||||||
sysusers.conf
|
sysusers.conf
|
||||||
tmpfiles.conf
|
tmpfiles.conf
|
||||||
|
00-fix.fmt.build.patch::https://github.com/xbmc/xbmc/commit/d73573ccb062f23039ef83465807792a76e455a9.patch
|
||||||
)
|
)
|
||||||
backup=(boot/kodi-gbm.config.txt)
|
backup=(boot/kodi-gbm.config.txt)
|
||||||
noextract=(
|
noextract=(
|
||||||
|
@ -98,7 +86,7 @@ noextract=(
|
||||||
"flatbuffers-$_flatbuffers_version.tar.gz"
|
"flatbuffers-$_flatbuffers_version.tar.gz"
|
||||||
"spdlog-$_spdlog_version.tar.gz"
|
"spdlog-$_spdlog_version.tar.gz"
|
||||||
)
|
)
|
||||||
sha256sums=('c4a38f33d14760e9b22f97521864dc9f6093f461f605d4f6d077ab045716b5f9'
|
sha256sums=('6456a5eb587ca652a0c10e9c7a32cb9bec2b19c922872be2f53020e3aef7d758'
|
||||||
'84ee6e1f7872fb249799f1428d5ab79930912ab7e064122c5c008fbecd0b547a'
|
'84ee6e1f7872fb249799f1428d5ab79930912ab7e064122c5c008fbecd0b547a'
|
||||||
'61a0648d4a5086f560ceb4e020f82472d00b99398f2cacba94fad3e96c4c362a'
|
'61a0648d4a5086f560ceb4e020f82472d00b99398f2cacba94fad3e96c4c362a'
|
||||||
'5d38a895ee7b93689fab79124a3aad23a5e3e643abd08878d778d04066c8d26f'
|
'5d38a895ee7b93689fab79124a3aad23a5e3e643abd08878d778d04066c8d26f'
|
||||||
|
@ -106,29 +94,30 @@ sha256sums=('c4a38f33d14760e9b22f97521864dc9f6093f461f605d4f6d077ab045716b5f9'
|
||||||
'38816f8373e243bc5950449b4f3b18938c4e1c59348e3411e23f31db4072e40d'
|
'38816f8373e243bc5950449b4f3b18938c4e1c59348e3411e23f31db4072e40d'
|
||||||
'071e414e61b795f2ff9015b21a85fc009dde967f27780d23092643916538a57a'
|
'071e414e61b795f2ff9015b21a85fc009dde967f27780d23092643916538a57a'
|
||||||
'a30b6aa0aad0f2c505bc77948af2d5531a80b6e68112addb4c123fca24d5d3bf'
|
'a30b6aa0aad0f2c505bc77948af2d5531a80b6e68112addb4c123fca24d5d3bf'
|
||||||
'8e159cdf1dfd3de2ac838fdaecb1fbb315e47f2ee2c542cd9d6efeb545c2b916'
|
'a7d956dbbe3c2036a8a78976efaf43792e1c7c152a04182024f231f4ee2e7d7e'
|
||||||
'1cafc80701b746085dddf41bd9193e6d35089e1c6ec1940e037fcb9c98f62365'
|
'1cafc80701b746085dddf41bd9193e6d35089e1c6ec1940e037fcb9c98f62365'
|
||||||
'3d77d09a5df0de510aeeb940df4cb534787ddff3bb1828779753f5dfa1229d10'
|
'3d77d09a5df0de510aeeb940df4cb534787ddff3bb1828779753f5dfa1229d10'
|
||||||
'e4018e850f80700acee8da296e56e15b1eef711ab15157e542e7d7e1237c3476'
|
'e4018e850f80700acee8da296e56e15b1eef711ab15157e542e7d7e1237c3476'
|
||||||
'1789b97e790da8f2cb5ff827d15580878c8629fd889f5f038d7524dca43eacc9'
|
'1789b97e790da8f2cb5ff827d15580878c8629fd889f5f038d7524dca43eacc9'
|
||||||
'b38e0bbef7faac2b82fed550a0c19b0d4e7f6737d5321d4fd8f216b80f8aee8a'
|
'b38e0bbef7faac2b82fed550a0c19b0d4e7f6737d5321d4fd8f216b80f8aee8a'
|
||||||
'edff38cea510817c3682c7c6086054ac49adaa478285093ea294d83db065b83f'
|
|
||||||
'f521b98232e5035b7cada46cf03975b8d753e93d0802bf22913fceed769f9d96'
|
'f521b98232e5035b7cada46cf03975b8d753e93d0802bf22913fceed769f9d96'
|
||||||
'9c5e79ed8719cd032a3b17dac585aeff28a198e37af1da9af68ef1b86bab4d18')
|
'9c5e79ed8719cd032a3b17dac585aeff28a198e37af1da9af68ef1b86bab4d18'
|
||||||
|
'cb082a95045f4861be632fd727b4f3d4dad707c6e9353086a2b0afe10247dce8')
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "xbmc-$_commithash"
|
cd "xbmc-$_commit"
|
||||||
|
|
||||||
[[ -d kodi-build ]] && rm -rf kodi-build
|
[[ -d kodi-build ]] && rm -rf kodi-build
|
||||||
mkdir $srcdir/kodi-build
|
mkdir "$srcdir"/kodi-build
|
||||||
|
|
||||||
patch -Np1 -i ../000-python3.8.patch
|
# https://github.com/xbmc/xbmc/pull/18395
|
||||||
|
patch -Np1 -i ../00-fix.fmt.build.patch
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd kodi-build
|
cd kodi-build
|
||||||
|
|
||||||
# the build system expects to find /usr/include/drm/drm_fourcc.h however we provide this
|
# the build system expects to find /usr/include/drm/drm_fourcc.h however we provide this
|
||||||
# in /usr/lib/modules/5.4.51-1-ARCH/build/include/uapi/drm/drm_fourcc.h
|
# in /usr/lib/modules/x.y.z-1-ARCH/build/include/uapi/drm/drm_fourcc.h
|
||||||
#
|
#
|
||||||
# credit to Kevin for the following hack:
|
# credit to Kevin for the following hack:
|
||||||
|
|
||||||
|
@ -169,16 +158,17 @@ build() {
|
||||||
-DSPDLOG_URL="$srcdir/spdlog-$_spdlog_version.tar.gz" \
|
-DSPDLOG_URL="$srcdir/spdlog-$_spdlog_version.tar.gz" \
|
||||||
-DCORE_PLATFORM_NAME=gbm \
|
-DCORE_PLATFORM_NAME=gbm \
|
||||||
-DGBM_RENDER_SYSTEM=gles \
|
-DGBM_RENDER_SYSTEM=gles \
|
||||||
../"xbmc-$_commithash"
|
../"xbmc-$_commit"
|
||||||
make
|
make
|
||||||
make preinstall
|
make preinstall
|
||||||
|
|
||||||
}
|
}
|
||||||
|
|
||||||
package_kodi-rbp4-git() {
|
package_kodi-rbp4-git() {
|
||||||
pkgdesc="A software media player and entertainment hub for digital media (Raspberry Pi4/gbm only)"
|
pkgdesc="A software media player and entertainment hub for digital media (Raspberry Pi4/gbm only)"
|
||||||
depends=(
|
depends=(
|
||||||
'desktop-file-utils' 'hicolor-icon-theme' 'mesa' 'python-pycryptodomex'
|
'desktop-file-utils' 'hicolor-icon-theme' 'mesa' 'python-pycryptodomex'
|
||||||
'python-pillow6' 'python-simplejson' 'xorg-xdpyinfo'
|
'python-pillow' 'python-simplejson' 'xorg-xdpyinfo'
|
||||||
'bluez-libs' 'curl' 'lcms2' 'libass' 'libbluray' 'libcdio' 'libcec-rpi'
|
'bluez-libs' 'curl' 'lcms2' 'libass' 'libbluray' 'libcdio' 'libcec-rpi'
|
||||||
'libinput' 'libmicrohttpd' 'libnfs' 'libpulse' 'libva' 'libxkbcommon'
|
'libinput' 'libmicrohttpd' 'libnfs' 'libpulse' 'libva' 'libxkbcommon'
|
||||||
'libxslt' 'lirc' 'mariadb-libs' 'python2' 'smbclient' 'taglib'
|
'libxslt' 'lirc' 'mariadb-libs' 'python2' 'smbclient' 'taglib'
|
||||||
|
|
Loading…
Reference in a new issue