extra/qtcreator to 4.0.0-1

This commit is contained in:
Kevin Mihelich 2016-05-13 01:00:15 +00:00
parent 31c10b78e0
commit f6ebe8e3e4
2 changed files with 22 additions and 10 deletions

View file

@ -11,9 +11,9 @@
# - drop valgrind optdepend
pkgname=qtcreator
pkgver=3.6.1
_pkgver=v3.6.1
pkgrel=2
pkgver=4.0.0
_pkgver=v4.0.0
pkgrel=1
pkgdesc='Lightweight, cross-platform integrated development environment'
arch=('i686' 'x86_64')
url='http://qt-project.org'
@ -33,10 +33,12 @@ optdepends=('qt5-doc: integrated Qt documentation'
install=qtcreator.install
source=("git://code.qt.io/qt-creator/qt-creator.git#tag=${_pkgver}"
"git://code.qt.io/qt-labs/qbs.git"
'qt-creator_llvmincdir.patch'
'qtcreator.desktop'
'0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch')
md5sums=('SKIP'
'SKIP'
'ab50147c509e8043c69625afa7cca7fe'
'800c94165c547b64012a207d9830250a'
'49924cb71a664d079b8283a7173bc14f')
@ -44,14 +46,12 @@ prepare() {
cd qt-creator
git submodule init
git config submodule.qbs.url $srcdir/qbs
# Debugger: Allow LLDB-MI to be used as debugger
# https://bugreports.qt.io/browse/QTCREATORBUG-15131
# https://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=97e9f113879c
# https://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=e57b0db0f959
git cherry-pick -n 97e9f113879c e57b0db0f959
git submodule update
# Fix build with GCC 6 (patch from Fedora)
# https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/Q5SWCUUMWQ4EMS7CU2CBOZHV3WZYOOTT/
patch -Np1 -i ../qt-creator_llvmincdir.patch
git apply ../0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch
}
@ -77,5 +77,5 @@ package() {
chmod +x "${pkgdir}"/usr/bin/qtcreator
install -Dm644 ${srcdir}/qtcreator.desktop ${pkgdir}/usr/share/applications/qtcreator.desktop
install -Dm644 ${srcdir}/qt-creator/LGPL_EXCEPTION.TXT ${pkgdir}/usr/share/licenses/qtcreator/LGPL_EXCEPTION.TXT
install -Dm644 ${srcdir}/qt-creator/LICENSE.GPL3-EXCEPT ${pkgdir}/usr/share/licenses/qtcreator/LICENSE.GPL3-EXCEPT
}

View file

@ -0,0 +1,12 @@
diff -rupN qt-creator-opensource-src-3.6.0/src/tools/clangbackend/clangbackend.pro qt-creator-opensource-src-3.6.0-new/src/tools/clangbackend/clangbackend.pro
--- qt-creator-opensource-src-3.6.0/src/tools/clangbackend/clangbackend.pro 2015-12-11 13:45:01.000000000 +0100
+++ qt-creator-opensource-src-3.6.0-new/src/tools/clangbackend/clangbackend.pro 2016-02-08 23:04:03.654903983 +0100
@@ -10,7 +10,7 @@ QT += core network
QT -= gui
LIBS += $$LLVM_LIBS
-INCLUDEPATH += $$LLVM_INCLUDEPATH
+#INCLUDEPATH += $$LLVM_INCLUDEPATH
SOURCES += clangbackendmain.cpp