core/linux-armv7-rc to 4.12.rc1-1

This commit is contained in:
Kevin Mihelich 2017-05-16 01:39:23 +00:00
parent 0f3db99547
commit f700d8f01c
12 changed files with 258 additions and 156 deletions

View file

@ -1,4 +1,4 @@
From e043ee82e371ded84d2940af53f0f3b0e549236d Mon Sep 17 00:00:00 2001
From 81e89a314fb1e70274c2ec72013ba0a076de55dd Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/9] ARM: atags: add support for Marvell's u-boot
@ -47,5 +47,5 @@ index 979ff4016404..d1d0c1950fa4 100644
};
--
2.12.2
2.13.0

View file

@ -1,4 +1,4 @@
From 9192225b0bee8ed45131f4c311ee2eb41d3f5327 Mon Sep 17 00:00:00 2001
From e62b74b84f4b146e0b82d6acf1c043dc599ea884 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/9] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
@ -43,5 +43,5 @@ index 9448aa0c6686..ac7b6ae6c00f 100644
}
--
2.12.2
2.13.0

View file

@ -1,4 +1,4 @@
From e028a068903ac27bff5161f13deca6012e8ee885 Mon Sep 17 00:00:00 2001
From 8a920b8030a9a677dd6d38cf0305e7bf63617a61 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 3/9] SMILE Plug device tree file
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 011808490fed..7e6330f6a4a2 100644
index 9c5e1d944d1c..342ed08ab225 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -956,6 +956,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
@@ -985,6 +985,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
armada-370-db.dtb \
armada-370-dlink-dns327l.dtb \
armada-370-mirabox.dtb \
@ -205,5 +205,5 @@ index 000000000000..d01308ab848b
+ };
+};
--
2.12.2
2.13.0

View file

@ -1,4 +1,4 @@
From 0a8ba03a102df867bb031e84c7fcf531f240cc96 Mon Sep 17 00:00:00 2001
From 9ef8feb3e1a701eacd6979653511e1b13b095697 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 4/9] fix mvsdio eMMC timing
@ -12,7 +12,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
index 42296e55b9de..e5ce6d27ec82 100644
index 58d74b8d6c79..c9715530d676 100644
--- a/drivers/mmc/host/mvsdio.c
+++ b/drivers/mmc/host/mvsdio.c
@@ -93,7 +93,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
@ -24,7 +24,7 @@ index 42296e55b9de..e5ce6d27ec82 100644
tmout_index = MVSD_HOST_CTRL_TMOUT_MAX;
dev_dbg(host->dev, "data %s at 0x%08x: blocks=%d blksz=%d tmout=%u (%d)\n",
@@ -615,6 +615,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
@@ -614,6 +614,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
u32 m = DIV_ROUND_UP(host->base_clock, ios->clock) - 1;
if (m > MVSD_BASE_DIV_MAX)
m = MVSD_BASE_DIV_MAX;
@ -34,5 +34,5 @@ index 42296e55b9de..e5ce6d27ec82 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.12.2
2.13.0

View file

@ -1,4 +1,4 @@
From 7c54d4049580474d6860f2f9d8cd53513ec48289 Mon Sep 17 00:00:00 2001
From d52a089f2564db419f6a9b4109ccda69e847793d Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
@ -8,7 +8,7 @@ Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index 5f19fb0f025d..89579abc1959 100644
index 765400b62168..ee3212f887e3 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -60,6 +60,7 @@
@ -91,5 +91,5 @@ index 5f19fb0f025d..89579abc1959 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.12.2
2.13.0

View file

@ -1,49 +0,0 @@
From 7b10094b018ea22ae0e933098a961987b326252a Mon Sep 17 00:00:00 2001
From: dobatog <dobatog@gmail.com>
Date: Thu, 26 Feb 2015 12:32:27 +0100
Subject: [PATCH 6/9] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
related to input routing signals.
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
tlv320aic23-codec 1-001a: Control not supported for path LLINEIN -> [NULL] -> Line Input
tlv320aic23-codec 1-001a: ASoC: no dapm match for LLINEIN --> NULL --> Line Input
tlv320aic23-codec 1-001a: ASoC: Failed to add route LLINEIN -> NULL -> Line Input
tlv320aic23-codec 1-001a: Control not supported for path RLINEIN -> [NULL] -> Line Input
tlv320aic23-codec 1-001a: ASoC: no dapm match for RLINEIN --> NULL --> Line Input
tlv320aic23-codec 1-001a: ASoC: Failed to add route RLINEIN -> NULL -> Line Input
tlv320aic23-codec 1-001a: Control not supported for path MICIN -> [NULL] -> Mic Input
tlv320aic23-codec 1-001a: ASoC: no dapm match for MICIN --> NULL --> Mic Input
tlv320aic23-codec 1-001a: ASoC: Failed to add route MICIN -> NULL -> Mic Input
I am trying to set the sound system in a CM-510 (Compulab - SoM) based board with DT, using Simple-Card-Audio and the TLV320AIC23 audio codec included in the SoM . I faced this problem and thanks to the help of Sebastian Hesselbarth who noticed the possible error located in the structure snd_soc_dapm_route tlv320aic23_intercon[] , now errors are not reported.
Tested on CM-510 (Compulab SoM Board).
Signed-off-by: dobatog <dobatog@gmail.com>
Tested-by: Max Filippov <jcmvbkbc@gmail.com>
---
sound/soc/codecs/tlv320aic23.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/sound/soc/codecs/tlv320aic23.c b/sound/soc/codecs/tlv320aic23.c
index 410cae0f2060..0bb8e2602d8e 100644
--- a/sound/soc/codecs/tlv320aic23.c
+++ b/sound/soc/codecs/tlv320aic23.c
@@ -174,10 +174,10 @@ static const struct snd_soc_dapm_route tlv320aic23_intercon[] = {
{"ROUT", NULL, "Output Mixer"},
/* Inputs */
- {"Line Input", "NULL", "LLINEIN"},
- {"Line Input", "NULL", "RLINEIN"},
+ {"Line Input", NULL, "LLINEIN"},
+ {"Line Input", NULL, "RLINEIN"},
- {"Mic Input", "NULL", "MICIN"},
+ {"Mic Input", NULL, "MICIN"},
/* input mux */
{"Capture Source", "Line", "Line Input"},
--
2.12.2

View file

@ -1,7 +1,7 @@
From c9e324cee27e70fac2dd77adffd33445eae9ced5 Mon Sep 17 00:00:00 2001
From 6a5a573951f166fdda2d2daa235207f32d9bec92 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 7/9] set default cubietruck led triggers
Subject: [PATCH 6/9] set default cubietruck led triggers
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -9,10 +9,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 2 insertions(+)
diff --git a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
index f019aa3fe96d..76053e03cc7a 100644
index 102903e83bd2..40ce78704e8f 100644
--- a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
+++ b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
@@ -70,6 +70,7 @@
@@ -69,6 +69,7 @@
blue {
label = "cubietruck:blue:usr";
gpios = <&pio 7 21 GPIO_ACTIVE_HIGH>;
@ -20,7 +20,7 @@ index f019aa3fe96d..76053e03cc7a 100644
};
orange {
@@ -85,6 +86,7 @@
@@ -84,6 +85,7 @@
green {
label = "cubietruck:green:usr";
gpios = <&pio 7 7 GPIO_ACTIVE_HIGH>;
@ -29,5 +29,5 @@ index f019aa3fe96d..76053e03cc7a 100644
};
--
2.12.2
2.13.0

View file

@ -1,7 +1,7 @@
From 45353496c9a480c745fda93f552e6e0ffb417d51 Mon Sep 17 00:00:00 2001
From 65265b8379903a8dd95489616fde0126d10bd4ef Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 8/9] exynos4412-odroid: set higher minimum buck2 regulator
Subject: [PATCH 7/9] exynos4412-odroid: set higher minimum buck2 regulator
voltage
Set a higher minimum voltage to help reboot issue.
@ -13,7 +13,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
index 78f118cb73d4..169bd8fdaf41 100644
index 0f1ff792fe44..a6fc2a53522f 100644
--- a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
+++ b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
@@ -423,7 +423,7 @@
@ -26,5 +26,5 @@ index 78f118cb73d4..169bd8fdaf41 100644
regulator-always-on;
regulator-boot-on;
--
2.12.2
2.13.0

View file

@ -1,7 +1,7 @@
From f0527d9a7d142e36dedeea473c996bd53eef00a1 Mon Sep 17 00:00:00 2001
From 800ac49ce45ca2500e2455194d155d5d20f633e0 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 25 Feb 2017 19:39:51 -0700
Subject: [PATCH 9/9] disable USB3 port on ODROID-XU
Subject: [PATCH 8/9] disable USB3 port on ODROID-XU
Ports report over-current condition and are non-operable.
@ -23,5 +23,5 @@ index c4de1353e5df..f80fa58995c5 100644
&usbdrd_dwc3_1 {
--
2.12.2
2.13.0

View file

@ -0,0 +1,31 @@
From 04cbef0366837832994a3dd25661d28afe0d65a4 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 May 2017 13:32:25 -0600
Subject: [PATCH 9/9] ARM: dove: enable ethernet on D3Plug
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
arch/arm/boot/dts/dove-d3plug.dts | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/arch/arm/boot/dts/dove-d3plug.dts b/arch/arm/boot/dts/dove-d3plug.dts
index f5f59bb5a534..b0ad0bbf6818 100644
--- a/arch/arm/boot/dts/dove-d3plug.dts
+++ b/arch/arm/boot/dts/dove-d3plug.dts
@@ -60,6 +60,13 @@
&uart0 { status = "okay"; };
&sata0 { status = "okay"; };
&i2c0 { status = "okay"; };
+&mdio { status = "okay"; };
+&eth { status = "okay"; };
+
+&ethphy {
+ compatible = "marvell,88e1310";
+ reg = <1>;
+};
/* Samsung M8G2F eMMC */
&sdio0 {
--
2.13.0

View file

@ -3,8 +3,8 @@
buildarch=4
_rcver=4.11
_rcrel=8
_rcver=4.12
_rcrel=1
_rcnrel=armv7-x0
pkgbase=linux-armv7-rc
@ -18,35 +18,35 @@ url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools' 'vboot-utils' 'dtc')
options=('!strip')
source=("https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_srcname}.tar.xz"
source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
"http://rcn-ee.com/deb/sid-armhf/v${_rcver}.0-rc${_rcrel}-${_rcnrel}/patch-${_rcver}-rc${_rcrel}-${_rcnrel}.diff.gz"
'0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch'
'0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch'
'0003-SMILE-Plug-device-tree-file.patch'
'0004-fix-mvsdio-eMMC-timing.patch'
'0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch'
'0007-set-default-cubietruck-led-triggers.patch'
'0008-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch'
'0009-disable-USB3-port-on-ODROID-XU.patch'
'0006-set-default-cubietruck-led-triggers.patch'
'0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch'
'0008-disable-USB3-port-on-ODROID-XU.patch'
'0009-ARM-dove-enable-ethernet-on-D3Plug.patch'
'config'
'kernel.its'
'kernel.keyblock'
'kernel_data_key.vbprivk'
'linux.preset'
'99-linux.hook')
md5sums=('6eb1b94743f781f0dab2a6c6f673908c'
'318dd7b5a8247cfabcf7db61226c1326'
'35050d4086083976228b1aad40eb9685'
'b1f82c5ab2c1f49839a55f3bfd79e3b4'
'7d2eb3a79013bbcc9eac8aae14ec95ed'
'887172b2dbca6a024d2fc7dd2865ca17'
'cc15319d42d3dac4225523ee319f0b4e'
'5be4c09f985310ec1c157621a1e0bb8e'
'7902ffb9e4e48cd3426777d6fb3f2e9b'
'3cd8942f980b0e85eb832168d086988b'
'9f62b9c953a01b64b7dcf2e90aac6e37'
'd4a3f20ff5211f68f8d4822bfc2ef1eb'
md5sums=('08606cfcf5792a0b20456e3ae51ed7ac'
'9dbee363eb3d89dfe330d1240104ef53'
'722bc867ef5285e2719ce3e526425a65'
'c2e8438c4e7a93bb8fbf1576f23773f7'
'def3e95ff11cffe49d4624f4e00b59a2'
'bfe387475c4c42551dadd6d4aeb724ee'
'bd455ff6f763350f2f7c723141d90803'
'125c70a670250e1db8771a828daaef61'
'ff5f4ca7f97b8ebfbb09ec76363e71ec'
'f9282ee13ad2c393c462ef20b143ae22'
'9fb6cef04dd98e38094803c56e9c453b'
'72bf494e6ce5cbc9f2673605f4cfe6c1'
'4f2379ed84258050edb858ee8d281678'
'61c5ff73c136ed07a7aadbf58db3d96a'
'584777ae88bce2c5659960151b64c7d8'
@ -66,10 +66,10 @@ prepare() {
git apply ../0003-SMILE-Plug-device-tree-file.patch
git apply ../0004-fix-mvsdio-eMMC-timing.patch
git apply ../0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
git apply ../0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch
git apply ../0007-set-default-cubietruck-led-triggers.patch
git apply ../0008-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
git apply ../0009-disable-USB3-port-on-ODROID-XU.patch
git apply ../0006-set-default-cubietruck-led-triggers.patch
git apply ../0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
git apply ../0008-disable-USB3-port-on-ODROID-XU.patch
git apply ../0009-ARM-dove-enable-ethernet-on-D3Plug.patch
cat "${srcdir}/config" > ./.config

File diff suppressed because it is too large Load diff