mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed community/ruby2.5
This commit is contained in:
parent
a29ecab2bd
commit
f701307966
2 changed files with 0 additions and 96 deletions
|
@ -1,24 +0,0 @@
|
|||
diff --git a/internal.h b/internal.h
|
||||
index 40916a5..785be49 100644
|
||||
--- a/internal.h
|
||||
+++ b/internal.h
|
||||
@@ -250,16 +250,8 @@ struct rb_subclass_entry {
|
||||
rb_subclass_entry_t *next;
|
||||
};
|
||||
|
||||
-#if defined(HAVE_LONG_LONG)
|
||||
-typedef unsigned LONG_LONG rb_serial_t;
|
||||
-#define SERIALT2NUM ULL2NUM
|
||||
-#elif defined(HAVE_UINT64_T)
|
||||
-typedef uint64_t rb_serial_t;
|
||||
-#define SERIALT2NUM SIZET2NUM
|
||||
-#else
|
||||
typedef unsigned long rb_serial_t;
|
||||
#define SERIALT2NUM ULONG2NUM
|
||||
-#endif
|
||||
|
||||
struct rb_classext_struct {
|
||||
struct st_table *iv_index_tbl;
|
||||
--
|
||||
1.9.0
|
||||
|
|
@ -1,72 +0,0 @@
|
|||
# Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
|
||||
# Contributor: Thomas Dziedzic <gostrc@gmail.com>
|
||||
# Contributor: Allan McRae <allan@archlinux.org>
|
||||
# Contributor: John Proctor <jproctor@prium.net>
|
||||
# Contributor: Jeramy Rutley <jrutley@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix running ruby on 32-bit ARM
|
||||
|
||||
_rubyver=2.5
|
||||
pkgname=ruby2.5
|
||||
pkgver=2.5.7
|
||||
pkgdesc='An object-oriented language for quick and easy programming (version 2.5)'
|
||||
pkgrel=1.1
|
||||
arch=(x86_64)
|
||||
url='http://www.ruby-lang.org/en/'
|
||||
license=(BSD custom)
|
||||
depends=(gdbm openssl libffi libyaml gmp zlib)
|
||||
optdepends=('tk: for Ruby/TK')
|
||||
makedepends=(gdbm openssl libffi doxygen graphviz libyaml ttf-dejavu tk)
|
||||
options=(!emptydirs)
|
||||
source=(https://cache.ruby-lang.org/pub/ruby/${pkgver:0:3}/ruby-${pkgver}.tar.xz
|
||||
0002-Use-only-unsigned-long-for-rb_serial_t.patch)
|
||||
sha512sums=('63b7c75fab44cd1bd22f22ddec00c740cf379ac7240da0dfafcec54347766695faef47428ce1c433fd77fa96992e976c984697067fa526236d383b12adc9ce75')
|
||||
|
||||
prepare() {
|
||||
cd ruby-${pkgver}
|
||||
# fixes https://bugs.ruby-lang.org/issues/9507
|
||||
[[ $CARCH == 'arm' ]] && patch -Np1 -i ../0002-Use-only-unsigned-long-for-rb_serial_t.patch || true
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ruby-${pkgver}
|
||||
|
||||
./configure \
|
||||
--prefix=/opt/ruby${_rubyver} \
|
||||
--program-suffix=-${_rubyver} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--sharedstatedir=/var/lib \
|
||||
--libexecdir=/usr/lib/ruby \
|
||||
--enable-shared \
|
||||
--disable-rpath \
|
||||
--with-dbm-type=gdbm_compat
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd ruby-${pkgver}
|
||||
|
||||
make test
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ruby-${pkgver}
|
||||
|
||||
make DESTDIR="${pkgdir}" install-nodoc
|
||||
|
||||
install -dm755 $pkgdir/usr/bin
|
||||
install -dm755 $pkgdir/usr/lib
|
||||
|
||||
for i in erb irb rdoc ri ruby testrb rake gem; do
|
||||
ln -s /opt/$pkgname/bin/$i-${_rubyver} $pkgdir/usr/bin/$i-${_rubyver}
|
||||
ln -s /opt/$pkgname/bin/$i-${_rubyver} $pkgdir/opt/$pkgname/bin/$i
|
||||
done
|
||||
|
||||
ln -s /opt/$pkgname/lib/libruby.so.${_rubyver} $pkgdir/usr/lib/libruby.so.${_rubyver}
|
||||
|
||||
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
|
||||
install -D -m644 BSDL "${pkgdir}/usr/share/licenses/$pkgname/BSDL"
|
||||
}
|
Loading…
Reference in a new issue