core/gpgme to 1.24.1-3

This commit is contained in:
Kevin Mihelich 2024-12-22 18:26:26 +00:00
parent 6a2fe29ad7
commit f71ad75dd2
3 changed files with 74 additions and 4 deletions

View file

@ -1,7 +1,7 @@
pkgbase = gpgme
pkgdesc = A C wrapper library for GnuPG
pkgver = 1.24.1
pkgrel = 1
pkgrel = 3
url = https://www.gnupg.org/related_software/gpgme/
arch = x86_64
license = GPL-2.0-or-later
@ -19,10 +19,12 @@ pkgbase = gpgme
makedepends = swig
source = https://www.gnupg.org/ftp/gcrypt/gpgme/gpgme-1.24.1.tar.bz2
source = https://www.gnupg.org/ftp/gcrypt/gpgme/gpgme-1.24.1.tar.bz2.sig
source = 0001-python-3-13.patch
validpgpkeys = 6DAA6E64A76D2840571B4902528897B826403ADA
validpgpkeys = AC8E115BF73E2D8D47FA9908E98E9B2D19C6C8BD
sha256sums = ea05d0258e71061d61716584ec34cef59330a91340571edc46b78374973ba85f
sha256sums = SKIP
sha256sums = fa5e1a24e90bb6e4df8787cb14900c046fb6dc97f2a27c2d8b7474938261a413
pkgname = gpgme
license = GPL-2.0-or-later

View file

@ -0,0 +1,64 @@
From 27da4ec6350d803354d691c06a31c47176ec1064 Mon Sep 17 00:00:00 2001
From: Ingo Klöcker <dev@ingo-kloecker.de>
Date: Wed, 4 Dec 2024 14:15:06 +0100
Subject: build,python: Add Python 3.13 and remove Python 3.8
* configure.ac: Look for Python 3.13. Don't look for Python 3.8 anymore.
* lang/python/setup.py.in: Update Python versions in classifiers.
* m4/python.m4: Add python3.13 as valid interpreter. Remove python3.8.
--
---
configure.ac | 2 +-
lang/python/setup.py.in | 2 +-
m4/python.m4 | 4 ++--
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/configure.ac b/configure.ac
index 1aa68e95..97ba5688 100644
--- a/configure.ac
+++ b/configure.ac
@@ -614,7 +614,7 @@ if test "$found_py" = "1"; then
if test "$found_py" = "1" -o "$found_py3" = "1"; then
# Reset everything, so that we can look for another Python.
m4_foreach([mym4pythonver],
- [[2.7],[3.6],[3.8],[3.9],[3.10],[3.11],[3.12],[all]],
+ [[2.7],[3.6],[3.9],[3.10],[3.11],[3.12],[3.13],[all]],
[unset PYTHON
unset PYTHON_VERSION
unset PYTHON_CPPFLAGS
diff --git a/lang/python/setup.py.in b/lang/python/setup.py.in
index d6f537e0..1ddfbe7d 100755
--- a/lang/python/setup.py.in
+++ b/lang/python/setup.py.in
@@ -286,11 +286,11 @@ GPGME and these bindings is available here:
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
'Programming Language :: Python :: 3.11',
'Programming Language :: Python :: 3.12',
+ 'Programming Language :: Python :: 3.13',
'Operating System :: POSIX',
'Operating System :: Microsoft :: Windows',
'Topic :: Communications :: Email',
diff --git a/m4/python.m4 b/m4/python.m4
index a9ace09b..20dc6e81 100644
--- a/m4/python.m4
+++ b/m4/python.m4
@@ -36,12 +36,12 @@
# numbers and dots only.
AC_DEFUN([AM_PATH_PYTHON],
[
- dnl Find a Python interpreter. Python versions prior to 3.8 are
+ dnl Find a Python interpreter. Python versions prior to 3.9 are
dnl end-of-life and not supported, with the exception of 2.7 and 3.6.
m4_define_default([_AM_PYTHON_INTERPRETER_LIST],
[python2 python2.7 dnl
python dnl
- python3 python3.12 python3.11 python3.10 python3.9 python3.8 python3.6
+ python3 python3.13 python3.12 python3.11 python3.10 python3.9 python3.6
])
AC_ARG_VAR([PYTHON], [the Python interpreter])

View file

@ -8,7 +8,7 @@
pkgbase=gpgme
pkgname=(gpgme qgpgme-qt6 python-gpgme)
pkgver=1.24.1
pkgrel=1
pkgrel=3
pkgdesc='A C wrapper library for GnuPG'
arch=('x86_64')
url='https://www.gnupg.org/related_software/gpgme/'
@ -31,13 +31,17 @@ makedepends=(
)
validpgpkeys=('6DAA6E64A76D2840571B4902528897B826403ADA' # Werner Koch (dist signing 2020)
'AC8E115BF73E2D8D47FA9908E98E9B2D19C6C8BD') # Niibe Yutaka (GnuPG Release Key)
source=("https://www.gnupg.org/ftp/gcrypt/${pkgbase}/${pkgbase}-${pkgver}.tar.bz2"{,.sig})
source=("https://www.gnupg.org/ftp/gcrypt/${pkgbase}/${pkgbase}-${pkgver}.tar.bz2"{,.sig}
'0001-python-3-13.patch')
sha256sums=('ea05d0258e71061d61716584ec34cef59330a91340571edc46b78374973ba85f'
'SKIP')
'SKIP'
'fa5e1a24e90bb6e4df8787cb14900c046fb6dc97f2a27c2d8b7474938261a413')
prepare() {
cd ${pkgbase}-${pkgver}/
patch -Np1 < ../0001-python-3-13.patch
sed -i 's/-unknown//' autogen.sh
autoreconf -fi
}