mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
Update aur/asterisk to 11.2.1 and add dependencies
This commit is contained in:
parent
4f73bbbd4e
commit
f7260c4f94
8 changed files with 160 additions and 84 deletions
|
@ -1,64 +1,62 @@
|
|||
# Contributor: Alessio Biancalana <dottorblaster@gmail.com>
|
||||
# Maintainer: Xavier Devlamynck <magicrhesus@ouranos.be>
|
||||
|
||||
# ALARM: pepedog
|
||||
# - added --build option to configure
|
||||
# - added arm.patch
|
||||
|
||||
plugrel=1
|
||||
#ALARM: moonman
|
||||
# -based on asterisk-ltr in aur
|
||||
# -added makeflags =-j1, otherwise it fails
|
||||
# -added asterisk.service for systemd
|
||||
# -removed dahdi, libpri from deps
|
||||
# -changed default pid file location to
|
||||
# /var/run/asterisk (as in asterisk (non ltr) in aur)
|
||||
# -asterisk.logrotated was forgotten to be included in package - fixed
|
||||
|
||||
pkgname=asterisk
|
||||
pkgver=1.8.2.3
|
||||
pkgrel=2
|
||||
pkgdesc="A complete PBX solution"
|
||||
arch=('i686' 'x86_64')
|
||||
pkgver=11.2.1
|
||||
pkgrel=0
|
||||
pkgdesc="A complete PBX solution (Long Term Support)"
|
||||
arch=('arm')
|
||||
groups=()
|
||||
url="http://www.asterisk.org"
|
||||
license=('GPL')
|
||||
depends=('alsa-lib' 'curl' 'gmime' 'iksemel' 'libcap' 'libldap' 'libnewt' 'libusb' \
|
||||
'libvorbis' 'libxml2' 'net-snmp' 'openssl' 'popt' 'postgresql-libs' 'speex' 'sqlite3' \
|
||||
'unixodbc' 'python-pip' 'apache' 'php-pear')
|
||||
makedepends=('postgresql' 'unixodbc' 'sqlite3')
|
||||
backup=(etc/asterisk/{adsi,agents,ais,alarmreceiver,alsa,amd,app_mysql,asterisk,calendar}.conf
|
||||
etc/asterisk/{ccss,cdr_adaptive_odbc,cdr,cdr_custom,cdr_manager,cdr_mysql,cdr_odbc,cdr_pgsql,cdr_sqlite3_custom,cdr_syslog}.conf
|
||||
etc/asterisk/{cdr_tds,cel,cel_custom,cel_odbc,cel_pgsql,cel_sqlite3_custom,cel_tds,chan_dahdi,chan_mobile,chan_ooh323}.conf
|
||||
etc/asterisk/{cli_aliases,cli,cli_permissions,codecs,console,dbsep,dnsmgr,dsp,dundi,enum}.conf
|
||||
etc/asterisk/{extconfig,extensions,extensions_minivm,features,followme,func_odbc,gtalk,h323,http,iax,iaxprov}.conf
|
||||
etc/asterisk/{indications,jabber,jingle,logger,manager,meetme,mgcp,minivm,misdn,modules}.conf
|
||||
etc/asterisk/{musiconhold,muted,osp,oss,phone,phoneprov,queuerules,queues,res_config_mysql,res_config_sqlite,res_curl}.conf
|
||||
etc/asterisk/{res_fax,res_ldap,res_odbc,res_pgsql,res_pktccops,res_snmp,res_stun_monitor,rpt,rtp,say,sip,sip_notify}.conf
|
||||
etc/asterisk/{skinny,sla,smdi,udptl,unistim,usbradio,users,voicemail,vpb}.conf
|
||||
etc/asterisk/extensions.lua
|
||||
etc/asterisk/extensions.ael
|
||||
etc/asterisk/telcordia-1.adsi)
|
||||
source=(http://downloads.digium.com/pub/asterisk/releases/asterisk-$pkgver.tar.gz
|
||||
asterisk
|
||||
asterisk.logrotated
|
||||
arm.patch)
|
||||
install=$pkgname.install
|
||||
md5sums=('e394b63dd71c07497620dc12883e0b80'
|
||||
'59146273738605f1e011d8e7bed3561a'
|
||||
'486e07a0a1405ea25ec5b1736034653e'
|
||||
'28c31f22bd82e15c934e1a704e0d2066')
|
||||
|
||||
license=('GPL2')
|
||||
depends=('libusb' 'libxml2' 'openssl' 'curl' 'gmime' 'iksemel' 'libldap' 'net-snmp' 'postgresql-libs' 'speex' 'sqlite' 'libcap' 'libvorbis' 'unixodbc' 'libnewt' 'libresample' 'alsa-lib' 'popt' 'lua' 'neon' 'jack' 'sdl' 'gsm')
|
||||
optdepends=('radiusclient-ng' 'libpri' 'dahdi' 'dahdi-tools')
|
||||
makedepends=('linux-headers')
|
||||
conflicts=('asterisk' 'asterisk16' 'asterisk18' 'asterisk10' 'asterisk-svn')
|
||||
provides=('asterisk')
|
||||
options=(makeflags)
|
||||
MAKEFLAGS="-j1"
|
||||
install=${pkgname}.install
|
||||
source=(http://downloads.asterisk.org/pub/telephony/asterisk/asterisk-${pkgver}.tar.gz
|
||||
asterisk
|
||||
asterisk.logrotated
|
||||
asterisk.service)
|
||||
sha1sums=('54959f247d7c881507eb08a0d16ffd0f86eef536'
|
||||
'19ca30d5dde7ba90e56c21abfe4fb9fcf2529e98'
|
||||
'38a772e20c9a1987faf433ca38c8536012fbada0'
|
||||
'b4f62266f61dc6f3eef702b8cac548bfc9029a6e')
|
||||
build() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
patch -Np1 -i ../arm.patch || return 1
|
||||
|
||||
[[ $CARCH == "arm" ]] && CONFIGFLAG="--build=arm-unknown-linux-gnueabi"
|
||||
[[ $CARCH == "armv7h" ]] && CONFIGFLAG="--build=armv7l-unknown-linux-gnueabi"
|
||||
cd $srcdir/asterisk-${pkgver}
|
||||
|
||||
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var $CONFIGFLAG
|
||||
make || return 1
|
||||
msg "Configuring..."
|
||||
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
|
||||
|
||||
msg "Building..."
|
||||
make
|
||||
}
|
||||
|
||||
package(){
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
make DESTDIR=${pkgdir} install || return 1
|
||||
make DESTDIR=${pkgdir} samples || return 1
|
||||
package() {
|
||||
cd ${srcdir}/asterisk-${pkgver}
|
||||
make DESTDIR=${pkgdir} install
|
||||
make DESTDIR=${pkgdir} samples
|
||||
|
||||
cd ${pkgdir}/etc/asterisk
|
||||
# cp ${srcdir}/modules.conf modules.conf
|
||||
(cd ${pkgdir}/etc/asterisk
|
||||
# for i in `ls`; do [ $i = "asterisk.conf" ] || mv $i $i.default; done
|
||||
ls -I asterisk.conf | xargs -I '{}' mv '{}' '{}.default')
|
||||
# cp ${srcdir}/modules.conf modules.conf
|
||||
sed -i -e "s/\/var\/run/\/var\/run\/asterisk/" $startdir/pkg/etc/asterisk/asterisk.conf
|
||||
|
||||
install -D -m 755 ${srcdir}/asterisk ${pkgdir}/etc/rc.d/asterisk
|
||||
install -D -m 644 ${srcdir}/asterisk.logrotated ${pkgdir}/etc/logrotate.d/asterisk
|
||||
|
||||
install -D "$srcdir/asterisk" "$pkgdir/etc/rc.d/asterisk"
|
||||
install -Dm644 "$srcdir/$pkgname.service" "$pkgdir/usr/lib/systemd/system/$pkgname.service"
|
||||
install -Dm644 "$srcdir/asterisk.logrotated" "$pkgdir/etc/logrotate.d/asterisk"
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
diff -urN asterisk-1.8.2.3/main/utils.c asterisk-1.8.2.3-2/main/utils.c
|
||||
--- asterisk-1.8.2.3/main/utils.c 2011-01-20 19:47:11.000000000 +0000
|
||||
+++ asterisk-1.8.2.3-2/main/utils.c 2011-04-24 20:34:55.000000000 +0100
|
||||
@@ -24,6 +24,8 @@
|
||||
*/
|
||||
|
||||
#include "asterisk.h"
|
||||
+/* Temporary declaration for ARM cpus ONLY (this belongs in the make environment) */
|
||||
+#define __arm__ 1
|
||||
|
||||
ASTERISK_FILE_VERSION(__FILE__, "$Revision: 303104 $")
|
||||
|
||||
@@ -1632,7 +1634,7 @@
|
||||
}
|
||||
|
||||
result = (*pool_head)->base + (*pool_head)->used;
|
||||
-#ifdef __sparc__
|
||||
+#if defined(__sparc__) || defined(__arm__)
|
||||
/* SPARC requires that the allocation field be aligned. */
|
||||
if ((long) result % sizeof(ast_string_field_allocation)) {
|
||||
result++;
|
||||
@@ -1713,7 +1715,7 @@
|
||||
}
|
||||
} else {
|
||||
target = (*pool_head)->base + (*pool_head)->used + sizeof(ast_string_field_allocation);
|
||||
-#ifdef __sparc__
|
||||
+#if defined(__sparc__) || defined(__arm__)
|
||||
if ((long) target % sizeof(ast_string_field_allocation)) {
|
||||
target++;
|
||||
space--;
|
|
@ -13,7 +13,7 @@ post_install() {
|
|||
cat << EOF
|
||||
>>>
|
||||
>>> To get Music on Hold working do pacman -S mpg123
|
||||
>>> To get the postgresql, unixodbc or sqlite2 modules working
|
||||
>>> To get the postgresql, unixodbc or sqlite modules working
|
||||
>>> download the respective package and modify modules.conf to reflect
|
||||
>>> your changes.
|
||||
>>>
|
||||
|
|
19
aur/asterisk/asterisk.service
Normal file
19
aur/asterisk/asterisk.service
Normal file
|
@ -0,0 +1,19 @@
|
|||
[Unit]
|
||||
Description=Asterisk PBX and telephony daemon.
|
||||
After=network.target
|
||||
|
||||
[Service]
|
||||
Type=simple
|
||||
Environment=HOME=/var/lib/asterisk
|
||||
WorkingDirectory=/var/lib/asterisk
|
||||
User=asterisk
|
||||
Group=asterisk
|
||||
PIDFile=/run/asterisk/asterisk.pid
|
||||
ExecStart=/usr/sbin/asterisk -C /etc/asterisk/asterisk.conf
|
||||
ExecStop=/usr/sbin/asterisk -rx 'core stop now'
|
||||
ExecReload=/usr/sbin/asterisk -rx 'core reload'
|
||||
|
||||
PrivateTmp=true
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
31
aur/iksemel/PKGBUILD
Normal file
31
aur/iksemel/PKGBUILD
Normal file
|
@ -0,0 +1,31 @@
|
|||
# $Id: PKGBUILD 55571 2011-09-14 10:35:20Z andrea $
|
||||
# Maintainer: Mateusz Herych <heniekk@gmail.com>
|
||||
# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
|
||||
# Contributor: Guillermo Vaya driadan@willinux.net
|
||||
|
||||
pkgname=iksemel
|
||||
pkgver=1.4
|
||||
pkgrel=2
|
||||
pkgdesc="XML parser library for Jabber applications in ANSI C"
|
||||
arch=('arm')
|
||||
url="http://code.google.com/p/iksemel/"
|
||||
license=('LGPL')
|
||||
depends=('glibc')
|
||||
install=iksemel.install
|
||||
source=("http://iksemel.googlecode.com/files/${pkgname}-$pkgver.tar.gz")
|
||||
md5sums=('532e77181694f87ad5eb59435d11c1ca')
|
||||
options=('!libtool')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}"/$pkgname-$pkgver
|
||||
./configure --prefix=/usr \
|
||||
--infodir=/usr/share/info
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}"/$pkgname-$pkgver
|
||||
make DESTDIR="${pkgdir}" install
|
||||
mv "${pkgdir}"/usr/share/info/$pkgname "${pkgdir}"/usr/share/info/$pkgname.info
|
||||
rm -rf "${pkgdir}"/usr/share/info/dir
|
||||
}
|
20
aur/iksemel/iksemel.install
Normal file
20
aur/iksemel/iksemel.install
Normal file
|
@ -0,0 +1,20 @@
|
|||
infodir=usr/share/info
|
||||
filelist=(iksemel.info.gz)
|
||||
|
||||
post_install() {
|
||||
[ -x usr/bin/install-info ] || return 0
|
||||
for file in ${filelist[@]}; do
|
||||
install-info $infodir/$file $infodir/dir 2> /dev/null
|
||||
done
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install $1
|
||||
}
|
||||
|
||||
pre_remove() {
|
||||
[ -x usr/bin/install-info ] || return 0
|
||||
for file in ${filelist[@]}; do
|
||||
install-info --delete $infodir/$file $infodir/dir 2> /dev/null
|
||||
done
|
||||
}
|
14
aur/libresample/Makefile.in.patch
Normal file
14
aur/libresample/Makefile.in.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
diff -Nur libresample-0.1.3.orig/Makefile.in libresample-0.1.3/Makefile.in
|
||||
--- libresample-0.1.3.orig/Makefile.in 2003-10-12 17:05:59.000000000 +1000
|
||||
+++ libresample-0.1.3/Makefile.in 2009-08-24 08:43:16.000000000 +1000
|
||||
@@ -20,6 +20,10 @@
|
||||
TARGETS = @TARGETS@
|
||||
DIRS=tests
|
||||
|
||||
+ifeq ($(shell uname -m),x86_64)
|
||||
+ CFLAGS += -fPIC
|
||||
+endif
|
||||
+
|
||||
all: $(TARGETS)
|
||||
|
||||
libresample.a: $(OBJS) Makefile
|
24
aur/libresample/PKGBUILD
Normal file
24
aur/libresample/PKGBUILD
Normal file
|
@ -0,0 +1,24 @@
|
|||
# Contributor: Jonathan Liu <net147@gmail.com>
|
||||
pkgname=libresample
|
||||
pkgver=0.1.3
|
||||
pkgrel=2
|
||||
pkgdesc="A real-time library for audio sampling rate conversion"
|
||||
arch=('arm')
|
||||
url="http://ccrma.stanford.edu/~jos/resample/Free_Resampling_Software.html"
|
||||
license=('LGPL2')
|
||||
source=("http://ccrma.stanford.edu/~jos/gz/$pkgname-$pkgver.tgz"
|
||||
"Makefile.in.patch")
|
||||
md5sums=('99bc5ea15ef76b83e5655a10968f674b'
|
||||
'9c18aec34f5e16baac888bd0926270e7')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
patch -Np1 -i "$srcdir/Makefile.in.patch" || return 1
|
||||
./configure --prefix=/usr
|
||||
make libresample.a || return 1
|
||||
install -D -m644 include/libresample.h "$pkgdir/usr/include/libresample.h"
|
||||
install -D -m644 libresample.a "$pkgdir/usr/lib/libresample.a"
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
Loading…
Reference in a new issue