mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/uboot-raspberrypi to 2020.04-1
This commit is contained in:
parent
c63cc6b4c6
commit
f7392f64f6
2 changed files with 13 additions and 40 deletions
|
@ -1,34 +0,0 @@
|
|||
From 3203606142b15c2f4d3f2a4c55cf9b16d4e92d0c Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 6 Jul 2019 09:06:56 -0600
|
||||
Subject: [PATCH] Fix bcm2835_video_probe with newer firmware
|
||||
|
||||
https://github.com/raspberrypi/firmware/issues/1157#issuecomment-506706177
|
||||
---
|
||||
drivers/video/bcm2835.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/video/bcm2835.c b/drivers/video/bcm2835.c
|
||||
index bc41090aed..4c7962cad8 100644
|
||||
--- a/drivers/video/bcm2835.c
|
||||
+++ b/drivers/video/bcm2835.c
|
||||
@@ -19,13 +19,15 @@ static int bcm2835_video_probe(struct udevice *dev)
|
||||
|
||||
debug("bcm2835: Query resolution...\n");
|
||||
ret = bcm2835_get_video_size(&w, &h);
|
||||
- if (ret)
|
||||
+ if (ret || w == 0 || h == 0)
|
||||
return -EIO;
|
||||
|
||||
debug("bcm2835: Setting up display for %d x %d\n", w, h);
|
||||
ret = bcm2835_set_video_params(&w, &h, 32, BCM2835_MBOX_PIXEL_ORDER_RGB,
|
||||
BCM2835_MBOX_ALPHA_MODE_IGNORED,
|
||||
&fb_base, &fb_size, &pitch);
|
||||
+ if(ret)
|
||||
+ return -EIO;
|
||||
|
||||
debug("bcm2835: Final resolution is %d x %d\n", w, h);
|
||||
|
||||
--
|
||||
2.21.0
|
||||
|
|
@ -4,7 +4,7 @@
|
|||
buildarch=12
|
||||
|
||||
pkgname=uboot-raspberrypi
|
||||
pkgver=2019.04
|
||||
pkgver=2020.04
|
||||
pkgrel=1
|
||||
pkgdesc="U-Boot for Raspberry Pi"
|
||||
arch=('armv7h' 'aarch64')
|
||||
|
@ -13,13 +13,20 @@ license=('GPL')
|
|||
backup=('boot/boot.txt' 'boot/boot.scr' 'boot/config.txt')
|
||||
makedepends=('bc' 'dtc' 'git')
|
||||
conflicts_armv7h=('linux-raspberrypi')
|
||||
_commit=f4b58692fef0b9c16bd4564edb980fff73a758b3
|
||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
|
||||
'0001-Fix-bcm2835_video_probe-with-newer-firmware.patch'
|
||||
"https://github.com/raspberrypi/firmware/raw/${_commit}/boot/bcm2710-rpi-3-b.dtb"
|
||||
"https://github.com/raspberrypi/firmware/raw/${_commit}/boot/bcm2710-rpi-3-b-plus.dtb"
|
||||
"https://github.com/raspberrypi/firmware/raw/${_commit}/boot/bcm2710-rpi-cm3.dtb"
|
||||
"https://github.com/raspberrypi/firmware/raw/${_commit}/boot/bcm2711-rpi-4-b.dtb"
|
||||
'boot.txt.v2'
|
||||
'boot.txt.v3'
|
||||
'mkscr')
|
||||
md5sums=('543299cbbf0b9c0ae0c9579a006df2b7'
|
||||
'7ca52bae8504e22e3ca0300c8ccf5866'
|
||||
md5sums=('51113d2288c55110e33a895c65ab9f60'
|
||||
'0c56f6b8fde06be1415b3ff85b5b5370'
|
||||
'e4b819439961514c7441473d4733a1b4'
|
||||
'38cab92f98944f0492c5320cf8b36870'
|
||||
'04f2dd06c65cd7ad2932041cbe220a13'
|
||||
'69e883f0b8d1686b32bdf79684623f06'
|
||||
'be8abe44b86d63428d7ac3acc64ee3bf'
|
||||
'021623a04afd29ac3f368977140cfbfd')
|
||||
|
@ -27,7 +34,6 @@ md5sums=('543299cbbf0b9c0ae0c9579a006df2b7'
|
|||
prepare() {
|
||||
cd u-boot-${pkgver/rc/-rc}
|
||||
|
||||
patch -p1 -i ../0001-Fix-bcm2835_video_probe-with-newer-firmware.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -39,7 +45,7 @@ build() {
|
|||
|
||||
make distclean
|
||||
[[ $CARCH == "armv7h" ]] && make rpi_2_config
|
||||
[[ $CARCH == "aarch64" ]] && make rpi_3_config
|
||||
[[ $CARCH == "aarch64" ]] && make rpi_arm64_config
|
||||
echo 'CONFIG_IDENT_STRING=" Arch Linux ARM"' >> .config
|
||||
make EXTRAVERSION=-${pkgrel}
|
||||
}
|
||||
|
@ -54,6 +60,7 @@ package() {
|
|||
cp ../boot.txt.v2 ../boot.txt
|
||||
elif [[ $CARCH == "aarch64" ]]; then
|
||||
cp u-boot.bin ${pkgdir}/boot/kernel8.img
|
||||
cp ../*.dtb ${pkgdir}/boot
|
||||
cp ../boot.txt.v3 ../boot.txt
|
||||
echo "enable_uart=1" > ${pkgdir}/boot/config.txt
|
||||
fi
|
||||
|
|
Loading…
Reference in a new issue