mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
removed community/simutrans
This commit is contained in:
parent
37124bc64f
commit
f740d1206e
6 changed files with 0 additions and 191 deletions
|
@ -1,77 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Balló György <ballogyor+arch at gmail dot com>
|
||||
# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
|
||||
# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
|
||||
# Contributor: Gilles Gagniard <gilles@gagniard.org>
|
||||
# Contributor: JD Steffen <jd at steffennet dot org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - get rid of a bad gcc flag in Makefile
|
||||
|
||||
pkgname=simutrans
|
||||
pkgver=120.1.3
|
||||
_pkgver=120-1-3
|
||||
pkgrel=1
|
||||
pkgdesc="An open source transportation simulation game"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://simutrans.com/"
|
||||
license=('custom:Artistic')
|
||||
depends=('gcc-libs' 'zlib' 'sdl_mixer' 'bzip2' 'simutrans-pak64')
|
||||
makedepends=('imagemagick' 'dos2unix')
|
||||
optdepends=('timidity++: play MIDI music')
|
||||
source=(http://downloads.sourceforge.net/$pkgname/$pkgname-src-$_pkgver.zip
|
||||
no-optimise.patch
|
||||
settings-folder.patch
|
||||
path-for-game-data.patch
|
||||
config.patch
|
||||
simutrans.desktop)
|
||||
md5sums=('693c44eceda2bdb30249253387b838d8'
|
||||
'4ab1d787772fc279181c1bc89dd42bf9'
|
||||
'c87d9a9910bc371df5d50f7f1ec298bb'
|
||||
'e716340d372af264ca05510facfe5d2c'
|
||||
'c2f4e494168e235380373974c91a0803'
|
||||
'f41f7a08ad517ef2b60412859eb49963')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir"
|
||||
|
||||
# Some files are distributed in DOS format
|
||||
find . -type f -exec dos2unix -q '{}' \;
|
||||
|
||||
# Don't overwrite default optimization flags
|
||||
patch -Np1 -i no-optimise.patch
|
||||
|
||||
# Adjust paths
|
||||
patch -Np0 -i settings-folder.patch
|
||||
patch -Np1 -i path-for-game-data.patch
|
||||
|
||||
# Configure the build process
|
||||
cp config.template config.default
|
||||
patch -Np0 -i config.patch
|
||||
|
||||
sed -i 's/-minline-all-stringops/-O3/' Makefile
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir"
|
||||
convert simutrans.ico -alpha on simutrans.png
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir"
|
||||
|
||||
#binary
|
||||
install -Dm755 build/default/sim "$pkgdir/usr/bin/simutrans"
|
||||
|
||||
#data
|
||||
mkdir -p "$pkgdir/usr/share/games/$pkgname"
|
||||
cp -r $pkgname/{config,font,music,text,themes} "$pkgdir/usr/share/games/$pkgname"
|
||||
|
||||
#desktop file and icon
|
||||
install -Dm644 simutrans.png "$pkgdir/usr/share/pixmaps/simutrans.png"
|
||||
install -Dm644 simutrans.desktop "$pkgdir/usr/share/applications/simutrans.desktop"
|
||||
|
||||
#license
|
||||
install -Dm644 simutrans/license.txt "$pkgdir/usr/share/licenses/simutrans/license.txt"
|
||||
}
|
|
@ -1,33 +0,0 @@
|
|||
--- config.default.orig 2011-11-10 21:48:01.000000000 +0100
|
||||
+++ config.default 2011-11-10 21:51:58.383221979 +0100
|
||||
@@ -6,18 +6,18 @@
|
||||
#BACKEND = opengl
|
||||
#BACKEND = sdl
|
||||
#BACKEND = sdl2
|
||||
-#BACKEND = mixer_sdl
|
||||
+BACKEND = mixer_sdl
|
||||
#BACKEND = posix
|
||||
|
||||
#COLOUR_DEPTH = 0
|
||||
-#COLOUR_DEPTH = 16
|
||||
+COLOUR_DEPTH = 16
|
||||
|
||||
#OSTYPE = amiga
|
||||
#OSTYPE = beos
|
||||
#OSTYPE = cygwin
|
||||
#OSTYPE = freebsd
|
||||
#OSTYPE = haiku
|
||||
-#OSTYPE = linux
|
||||
+OSTYPE = linux
|
||||
#OSTYPE = mingw
|
||||
#OSTYPE = mac
|
||||
|
||||
@@ -37,6 +37,6 @@
|
||||
#SDL_CONFIG = sdl-config
|
||||
#SDL2_CONFIG = sdl2-config
|
||||
|
||||
-#VERBOSE = 1
|
||||
+VERBOSE = 1
|
||||
|
||||
# The following useful conditional compilation flags exist
|
||||
#
|
|
@ -1,42 +0,0 @@
|
|||
diff -Naur simutrans.orig/Makefile simutrans/Makefile
|
||||
--- simutrans.orig/Makefile 2014-11-20 17:50:34.948410000 +0100
|
||||
+++ simutrans/Makefile 2014-11-20 17:51:43.936577860 +0100
|
||||
@@ -76,17 +76,6 @@
|
||||
SDL_CONFIG ?= sdl-config
|
||||
SDL2_CONFIG ?= sdl2-config
|
||||
|
||||
-ifneq ($(OPTIMISE),)
|
||||
- CFLAGS += -O3
|
||||
- ifeq ($(findstring $(OSTYPE), amiga),)
|
||||
- ifneq ($(findstring $(CXX), clang),)
|
||||
- CFLAGS += -minline-all-stringops
|
||||
- endif
|
||||
- endif
|
||||
-else
|
||||
- CFLAGS += -O
|
||||
-endif
|
||||
-
|
||||
ifdef DEBUG
|
||||
ifeq ($(shell expr $(DEBUG) \>= 1), 1)
|
||||
CFLAGS += -g -DDEBUG
|
||||
diff -Naur simutrans.orig/makeobj/Makefile simutrans/makeobj/Makefile
|
||||
--- simutrans.orig/makeobj/Makefile 2014-11-20 17:50:34.945077000 +0100
|
||||
+++ simutrans/makeobj/Makefile 2014-11-20 17:51:42.553214510 +0100
|
||||
@@ -42,17 +42,6 @@
|
||||
CXXFLAGS += -DUSE_HW -DUSE_C
|
||||
endif
|
||||
|
||||
-ifneq ($(OPTIMISE),)
|
||||
- CFLAGS += -O3 -fno-schedule-insns
|
||||
- CXXFLAGS += -O3 -fno-schedule-insns
|
||||
- ifneq ($(OSTYPE),mac)
|
||||
- CFLAGS += -minline-all-stringops
|
||||
- endif
|
||||
-else
|
||||
- CFLAGS += -O
|
||||
- CXXFLAGS += -O
|
||||
-endif
|
||||
-
|
||||
ifdef DEBUG
|
||||
ifeq ($(shell expr $(DEBUG) \>= 1), 1)
|
||||
CFLAGS += -g -DDEBUG
|
|
@ -1,18 +0,0 @@
|
|||
look in /usr/share/games/simutrans for game data
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- simutrans.orig/simmain.cc
|
||||
+++ simutrans/simmain.cc
|
||||
@@ -437,8 +437,9 @@
|
||||
strcat( env_t::program_dir, path_sep );
|
||||
}
|
||||
else {
|
||||
- strcpy( env_t::program_dir, argv[0] );
|
||||
- *(strrchr( env_t::program_dir, path_sep[0] )+1) = 0;
|
||||
+ // strcpy( env_t::program_dir, argv[0] );
|
||||
+ // *(strrchr( env_t::program_dir, path_sep[0] )+1) = 0;
|
||||
+ strcpy(env_t::program_dir, "/usr/share/games/simutrans/");
|
||||
|
||||
#ifdef __APPLE__
|
||||
// change working directory from binary dir to bundle dir
|
|
@ -1,12 +0,0 @@
|
|||
--- simsys.cc.orig 2011-10-28 20:32:25.000000000 +0200
|
||||
+++ simsys.cc 2011-11-10 23:09:10.380031846 +0100
|
||||
@@ -47,7 +47,7 @@
|
||||
#elif defined __APPLE__
|
||||
sprintf(buffer, "%s/Library/Simutrans", getenv("HOME"));
|
||||
#else
|
||||
- sprintf(buffer, "%s/simutrans", getenv("HOME"));
|
||||
+ sprintf(buffer, "%s/.simutrans", getenv("HOME"));
|
||||
#endif
|
||||
|
||||
dr_mkdir(buffer);
|
||||
|
|
@ -1,9 +0,0 @@
|
|||
[Desktop Entry]
|
||||
Name=Simutrans
|
||||
Comment=Transportation simulator
|
||||
Exec=simutrans
|
||||
Icon=simutrans
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Categories=Game;Simulation;
|
||||
|
Loading…
Reference in a new issue