extra/libreoffice-fresh to 7.2.0-2

This commit is contained in:
Kevin Mihelich 2021-09-02 12:35:57 +00:00
parent 9aab93b84d
commit f747974e13
3 changed files with 56 additions and 1 deletions

View file

@ -20,7 +20,7 @@ pkgbase=libreoffice-fresh
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
_LOver=7.2.0.4
pkgver=7.2.0
pkgrel=1
pkgrel=2
arch=('x86_64')
license=('LGPL3')
url="https://www.libreoffice.org/"
@ -67,6 +67,8 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
${_additional_source_url2}/f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
make-pyuno-work-with-system-wide-module-install.diff
skia-freetype2.11.patch
pld-skia-patches.patch
soffice-template.desktop.in
libreoffice-fresh.sh libreoffice-fresh.csh)
noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
@ -114,6 +116,8 @@ sha256sums=('28aac16d3b33ed8196be5ff0b5108dec36b73f85a68b857e221850d15b715576'
'f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140'
'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
'1f9506cff0c3f3638de6d1ff76f679c301f0e9aa2ab735b26274c42f16345e8e'
'55710ab0200784c69d49c38b9be6b447502c818ca828efc825355038c8980eea'
'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
'cd1b25ff390e436c6bffa65c6e12382236e3ccbf8d3aae51b1b59bcaed79fd8a'
'de20f36d45f0fecc2d94176dd3ec7226ab07fa8ffb9b0bc73c200349a9273de1')
@ -137,6 +141,10 @@ prepare() {
# fix not upstreamable pyuno paths - FS#54250
patch -Np1 -i "${srcdir}"/make-pyuno-work-with-system-wide-module-install.diff
# fix build with FreeType 2.11 (patches from PLD Linux)
cp "${srcdir}"/skia-freetype2.11.patch external/skia
patch -Np1 -i "${srcdir}"/pld-skia-patches.patch
#use the CFLAGS but remove the LibO overridden ones
for i in $CFLAGS; do
case "$i" in

View file

@ -0,0 +1,10 @@
--- libreoffice-7.2.0.3/external/skia/UnpackedTarball_skia.mk.orig 2021-08-10 19:27:48.000000000 +0200
+++ libreoffice-7.2.0.3/external/skia/UnpackedTarball_skia.mk 2021-08-12 18:09:22.813517161 +0200
@@ -39,6 +39,7 @@
fast-png-write.patch.1 \
skia_sk_cpu_sse_level_0_by_default.patch.1 \
fix-warnings.patch.1 \
+ skia-freetype2.11.patch \
$(eval $(call gb_UnpackedTarball_set_patchlevel,skia,1))

View file

@ -0,0 +1,37 @@
--- skia/src/ports/SkFontHost_FreeType_common.cpp.orig 2021-03-01 15:53:09.178606791 +0100
+++ skia/src/ports/SkFontHost_FreeType_common.cpp 2021-08-12 17:48:32.358901987 +0200
@@ -665,8 +665,13 @@
canvas->drawPaint(paint);
break;
}
+#if FREETYPE_MAJOR == 2 && FREETYPE_MINOR >= 11
+ case FT_COLR_PAINTFORMAT_TRANSFORM: {
+ SkMatrix transform = ToSkMatrix(colrv1_paint.u.transform.affine);
+#else
case FT_COLR_PAINTFORMAT_TRANSFORMED: {
SkMatrix transform = ToSkMatrix(colrv1_paint.u.transformed.affine);
+#endif
canvas->concat(transform);
break;
@@ -760,12 +765,20 @@
traverse_result = colrv1_start_glyph(canvas, palette, face, paint.u.colr_glyph.glyphID,
FT_COLOR_NO_ROOT_TRANSFORM);
break;
+#if FREETYPE_MAJOR == 2 && FREETYPE_MINOR >= 11
+ case FT_COLR_PAINTFORMAT_TRANSFORM:
+#else
case FT_COLR_PAINTFORMAT_TRANSFORMED:
+#endif
canvas->saveLayer(nullptr, nullptr);
// Traverse / draw operation will apply transform.
colrv1_draw_paint(canvas, palette, face, paint);
traverse_result =
+#if FREETYPE_MAJOR == 2 && FREETYPE_MINOR >= 11
+ colrv1_traverse_paint(canvas, palette, face, paint.u.transform.paint);
+#else
colrv1_traverse_paint(canvas, palette, face, paint.u.transformed.paint);
+#endif
canvas->restore();
break;
case FT_COLR_PAINTFORMAT_ROTATE: