mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
Merge branch 'master' of github.com:archlinuxarm/PKGBUILDs
This commit is contained in:
commit
f76262231d
26 changed files with 392 additions and 130 deletions
|
@ -1,26 +1,26 @@
|
|||
# Maintainer: Nathan Owe <ndowens.aur at gmail dot com>
|
||||
|
||||
plugrel=3
|
||||
plugrel=1
|
||||
|
||||
pkgname=flexget
|
||||
_pkgname=FlexGet
|
||||
pkgver=1.0r2495
|
||||
pkgrel=1
|
||||
pkgver=1.0r2782
|
||||
pkgrel=2
|
||||
pkgdesc="Automate downloading or processing content (torrents, podcasts, etc.)"
|
||||
arch=(any)
|
||||
url="http://flexget.com/"
|
||||
depends=('python2' 'python2-cherrypy' 'python2-flask' 'python-progressbar' \
|
||||
'python2-pynzb' 'pyrss2gen' 'python2-sqlalchemy' 'python-html5lib' \
|
||||
'python-beautifulsoup' 'python2-yaml' 'python2-feedparser')
|
||||
depends=('python2' 'python2-cherrypy' 'python2-flask' 'python2-progressbar' \
|
||||
'python2-pynzb' 'pyrss2gen' 'python2-sqlalchemy' 'python-html5lib' \
|
||||
'python-beautifulsoup' 'python2-yaml' 'python2-feedparser' \
|
||||
'python2-requests-0.10.0' 'python2-certifi>=0.0.7' 'python2-chardet>=1.0.0')
|
||||
makedepends=('python2-distribute')
|
||||
license=('MIT')
|
||||
install=('flexget.install')
|
||||
source=("http://download.flexget.com/unstable/${_pkgname}-${pkgver}.tar.gz")
|
||||
md5sums=('5c2f882720e8f7fbea535c51631babf0')
|
||||
md5sums=('e2091b19f3cc3bc205c32ea5d44a9e9d')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${_pkgname}-${pkgver}"
|
||||
python2 setup.py build
|
||||
python2 setup.py build
|
||||
|
||||
}
|
||||
package() {
|
||||
|
@ -28,5 +28,3 @@ package() {
|
|||
python2 setup.py install --root=${pkgdir}/ optimize=1
|
||||
install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
|
||||
}
|
||||
|
||||
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
# arg 1: the new package version
|
||||
post_install() {
|
||||
echo "You need to place your config.yml in /opt/flexget/ see dir for examples."
|
||||
echo "Configuration details can be found at http://flexget.com/wiki/Configuration."
|
||||
}
|
||||
|
||||
# arg 1: the new package version
|
||||
# arg 2: the old package version
|
||||
post_upgrade() {
|
||||
echo "You need to place your config.yml in /opt/flexget/ see dir for examples."
|
||||
echo "Configuration details can be found at http://flexget.com/wiki/Configuration."
|
||||
}
|
||||
|
||||
# arg 1: the old package version
|
||||
pre_remove() {
|
||||
/bin/true
|
||||
}
|
||||
|
||||
op=$1
|
||||
shift
|
||||
|
||||
$op $*
|
24
aur/python2-certifi/PKGBUILD
Normal file
24
aur/python2-certifi/PKGBUILD
Normal file
|
@ -0,0 +1,24 @@
|
|||
# Maintainer: William J Bowman <bluephoenix47@gmail.com>
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgname=python2-certifi
|
||||
_pkgname=certifi
|
||||
pkgver=0.0.8
|
||||
pkgrel=1
|
||||
pkgdesc="Mozilla's SSL Certs"
|
||||
arch=(any)
|
||||
url="http://pypi.python.org/pypi/${_pkgname}/${pkgver}"
|
||||
license=('GPL')
|
||||
depends=('python2')
|
||||
makedepends=('python2-distribute')
|
||||
source=("http://pypi.python.org/packages/source/c/certifi/${_pkgname}-${pkgver}.tar.gz")
|
||||
md5sums=('dc5f5e7f0b5fc08d27654b17daa6ecec')
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${_pkgname}-${pkgver}"
|
||||
python2 setup.py install --root=${pkgdir}/ --optimize=1
|
||||
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
25
aur/python2-requests-0.10.0/PKGBUILD
Normal file
25
aur/python2-requests-0.10.0/PKGBUILD
Normal file
|
@ -0,0 +1,25 @@
|
|||
pkgname=python2-requests-0.10.0
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgver=0.10.0
|
||||
pkgrel=2
|
||||
pkgdesc="Python HTTP for Humans."
|
||||
url="http://python-requests.org"
|
||||
depends=('python2' )
|
||||
makedepends=('python2-distribute' )
|
||||
optdepends=('python2-certifi: SSL support')
|
||||
license=('custom: ISC')
|
||||
arch=('any')
|
||||
source=("http://pypi.python.org/packages/source/r/requests/requests-$pkgver.tar.gz")
|
||||
conflicts=('python2-requests')
|
||||
build() {
|
||||
cd $srcdir/requests-$pkgver
|
||||
python2 setup.py build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $srcdir/requests-$pkgver
|
||||
python2 setup.py install --root="$pkgdir" --optimize=1
|
||||
}
|
||||
md5sums=('c90a48af18eb4170dbe4832c1104440c')
|
|
@ -7,7 +7,7 @@
|
|||
# Contributor: Jason Plum <max@warheads.net>
|
||||
|
||||
pkgname=nodejs
|
||||
pkgver=0.6.11
|
||||
pkgver=0.6.12
|
||||
pkgrel=1
|
||||
plugrel=3
|
||||
pkgdesc='Evented I/O for V8 javascript'
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
# Contributor: tocer <tocer.deng@gmail.com>
|
||||
|
||||
pkgname=v8
|
||||
pkgver=3.6.6.20
|
||||
pkgver=3.6.6.24
|
||||
pkgrel=1
|
||||
plugrel=1
|
||||
pkgdesc='A fast and modern javascript engine'
|
||||
|
|
|
@ -10,7 +10,8 @@ pkgname=('linux' 'linux-headers')
|
|||
_kernelname=${pkgname#linux}
|
||||
_basekernel=3.1
|
||||
pkgver=${_basekernel}.10
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
cryptover=1.2
|
||||
arch=('arm')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
|
@ -27,7 +28,8 @@ source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.x/linux-${_basekernel}.tar.bz2
|
|||
'config'
|
||||
'mach-types::http://www.arm.linux.org.uk/developer/machines/download.php'
|
||||
'change-default-console-loglevel.patch'
|
||||
'usb-add-reset-resume-quirk-for-several-webcams.patch')
|
||||
'usb-add-reset-resume-quirk-for-several-webcams.patch'
|
||||
"http://download.gna.org/cryptodev-linux/cryptodev-linux-${cryptover}.tar.gz")
|
||||
md5sums=('8d43453f8159b2332ad410b19d86a931'
|
||||
'a8e1c25a93a685ec2a1c3a808715fe9d'
|
||||
'7f2c10e9e8ab4decaaf1dd5437a775a3'
|
||||
|
@ -39,7 +41,8 @@ md5sums=('8d43453f8159b2332ad410b19d86a931'
|
|||
'e9c48e4c43e1044122bc4832dcbe065c'
|
||||
'ca6fec585152e0488ee04bc0b311ecf3'
|
||||
'9d3c56a4b999c8bfbd4018089a62f662'
|
||||
'd00814b57448895e65fbbc800e8a58ba')
|
||||
'd00814b57448895e65fbbc800e8a58ba'
|
||||
'372a5f22a11848c621f186f71249b523')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/linux-${_basekernel}"
|
||||
|
@ -100,6 +103,10 @@ build() {
|
|||
|
||||
# build!
|
||||
make ${MAKEFLAGS} uImage modules
|
||||
|
||||
# build cryptodev module
|
||||
cd "${srcdir}/cryptodev-linux-${cryptover}"
|
||||
make KERNEL_DIR="${srcdir}/linux-${_basekernel}"
|
||||
}
|
||||
|
||||
package_linux() {
|
||||
|
@ -107,7 +114,7 @@ package_linux() {
|
|||
groups=('base')
|
||||
depends=('coreutils' 'linux-firmware' 'module-init-tools>=3.16' 'mkinitcpio>=0.7')
|
||||
optdepends=('crda: to set the correct wireless channels of your country')
|
||||
provides=('kernel26' 'aufs_friendly')
|
||||
provides=('kernel26' 'aufs_friendly' 'cryptodev_friendly')
|
||||
conflicts=('kernel26')
|
||||
replaces=('kernel26')
|
||||
install=${pkgname}.install
|
||||
|
@ -140,6 +147,10 @@ package_linux() {
|
|||
# add real version for building modules and running depmod from post_install/upgrade
|
||||
mkdir -p "${pkgdir}/lib/modules/extramodules-${_basekernel}-${_kernelname:-ARCH}"
|
||||
echo "${_kernver}" > "${pkgdir}/lib/modules/extramodules-${_basekernel}-${_kernelname:-ARCH}/version"
|
||||
|
||||
# install cryptodev module
|
||||
cd "${srcdir}/cryptodev-linux-${cryptover}"
|
||||
make -C "${srcdir}/linux-${_basekernel}" INSTALL_MOD_PATH="${pkgdir}" SUBDIRS=`pwd` modules_install
|
||||
}
|
||||
|
||||
package_linux-headers() {
|
||||
|
@ -273,4 +284,8 @@ package_linux-headers() {
|
|||
|
||||
# remove unneeded architectures
|
||||
rm -rf "${pkgdir}"/usr/src/linux-${_kernver}/arch/{alpha,arm26,avr32,blackfin,cris,frv,h8300,ia64,m32r,m68k,m68knommu,mips,microblaze,mn10300,parisc,powerpc,ppc,s390,sh,sh64,sparc,sparc64,um,v850,x86,xtensa}
|
||||
|
||||
# install cryptodev header
|
||||
cd "${srcdir}/cryptodev-linux-${cryptover}"
|
||||
install -D crypto/cryptodev.h "${pkgdir}/usr/src/linux-${_kernver}/crypto/cryptodev.h"
|
||||
}
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# arg 2: the old package version
|
||||
|
||||
KERNEL_NAME=
|
||||
KERNEL_VERSION=3.1.10-3-ARCH
|
||||
KERNEL_VERSION=3.1.10-4-ARCH
|
||||
|
||||
post_install () {
|
||||
# updating module dependencies
|
||||
|
|
|
@ -3,6 +3,7 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - use linux-armv4 target for our architectures
|
||||
# - cryptodev-enabled version
|
||||
|
||||
plugrel=1
|
||||
noautobuild=1
|
||||
|
@ -17,7 +18,8 @@ pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Se
|
|||
arch=('i686' 'x86_64')
|
||||
url='https://www.openssl.org'
|
||||
license=('custom:BSD')
|
||||
depends=('perl')
|
||||
depends=('perl' 'cryptodev_friendly')
|
||||
makedepends=('linux-headers')
|
||||
optdepends=('ca-certificates')
|
||||
options=('!makeflags')
|
||||
backup=('etc/ssl/openssl.cnf')
|
||||
|
@ -57,14 +59,14 @@ build() {
|
|||
patch -p0 -i $srcdir/no-rpath.patch
|
||||
# set ca dir to /etc/ssl by default
|
||||
patch -p0 -i $srcdir/ca-dir.patch
|
||||
# fix cryptodev digest support
|
||||
patch -p0 -i $srcdir/openssl-digests.patch
|
||||
# fix cryptodev digest support
|
||||
patch -p0 -i $srcdir/openssl-digests.patch
|
||||
# mark stack as non-executable: http://bugs.archlinux.org/task/12434
|
||||
./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
|
||||
-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS -DHASH_MAX_LEN=64 \
|
||||
shared threads zlib enable-md2 \
|
||||
"${openssltarget}" \
|
||||
-Wa,--noexecstack "${CFLAGS}"
|
||||
-Wa,--noexecstack "${CFLAGS} -I/usr/src/linux-`uname -r`"
|
||||
|
||||
make depend
|
||||
make
|
||||
|
|
|
@ -1,60 +0,0 @@
|
|||
Index: /trunk/boost/foreach_fwd.hpp
|
||||
===================================================================
|
||||
--- /trunk/boost/foreach_fwd.hpp (revision 62661)
|
||||
+++ /trunk/boost/foreach_fwd.hpp (revision 75540)
|
||||
@@ -15,4 +15,6 @@
|
||||
#define BOOST_FOREACH_FWD_HPP
|
||||
|
||||
+#include <utility> // for std::pair
|
||||
+
|
||||
// This must be at global scope, hence the uglified name
|
||||
enum boost_foreach_argument_dependent_lookup_hack
|
||||
@@ -26,4 +28,7 @@
|
||||
namespace foreach
|
||||
{
|
||||
+ template<typename T>
|
||||
+ std::pair<T, T> in_range(T begin, T end);
|
||||
+
|
||||
///////////////////////////////////////////////////////////////////////////////
|
||||
// boost::foreach::tag
|
||||
@@ -47,4 +52,22 @@
|
||||
} // namespace foreach
|
||||
|
||||
+// Workaround for unfortunate https://svn.boost.org/trac/boost/ticket/6131
|
||||
+namespace BOOST_FOREACH
|
||||
+{
|
||||
+ using foreach::in_range;
|
||||
+ using foreach::tag;
|
||||
+
|
||||
+ template<typename T>
|
||||
+ struct is_lightweight_proxy
|
||||
+ : foreach::is_lightweight_proxy<T>
|
||||
+ {};
|
||||
+
|
||||
+ template<typename T>
|
||||
+ struct is_noncopyable
|
||||
+ : foreach::is_noncopyable<T>
|
||||
+ {};
|
||||
+
|
||||
+} // namespace BOOST_FOREACH
|
||||
+
|
||||
} // namespace boost
|
||||
|
||||
Index: /trunk/boost/foreach.hpp
|
||||
===================================================================
|
||||
--- /trunk/boost/foreach.hpp (revision 75077)
|
||||
+++ /trunk/boost/foreach.hpp (revision 75540)
|
||||
@@ -166,5 +166,5 @@
|
||||
// at the global namespace for your type.
|
||||
template<typename T>
|
||||
-inline boost::foreach::is_lightweight_proxy<T> *
|
||||
+inline boost::BOOST_FOREACH::is_lightweight_proxy<T> *
|
||||
boost_foreach_is_lightweight_proxy(T *&, BOOST_FOREACH_TAG_DEFAULT) { return 0; }
|
||||
|
||||
@@ -191,5 +191,5 @@
|
||||
// at the global namespace for your type.
|
||||
template<typename T>
|
||||
-inline boost::foreach::is_noncopyable<T> *
|
||||
+inline boost::BOOST_FOREACH::is_noncopyable<T> *
|
||||
boost_foreach_is_noncopyable(T *&, BOOST_FOREACH_TAG_DEFAULT) { return 0; }
|
||||
|
|
@ -1,4 +1,4 @@
|
|||
# $Id: PKGBUILD 144044 2011-12-02 20:54:11Z ibiru $
|
||||
# $Id: PKGBUILD 152201 2012-03-05 08:55:51Z ibiru $
|
||||
# Maintainer: kevin <kevin@archlinux.org>
|
||||
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
|
||||
# Contributor: Kritoke <kritoke@gamebox.net>
|
||||
|
@ -12,19 +12,17 @@ plugrel=1
|
|||
|
||||
pkgbase=boost
|
||||
pkgname=('boost-libs' 'boost')
|
||||
pkgver=1.48.0
|
||||
pkgver=1.49.0
|
||||
_boostver=${pkgver//./_}
|
||||
pkgrel=2
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.boost.org/"
|
||||
makedepends=('icu' 'python' 'python2' 'bzip2' 'zlib')
|
||||
source=(http://downloads.sourceforge.net/${pkgbase}/${pkgbase}_${_boostver}.tar.gz
|
||||
exceptions.patch
|
||||
BOOST_FOREACH.patch)
|
||||
exceptions.patch)
|
||||
license=('custom')
|
||||
md5sums=('313a11e97eb56eb7efd18325354631be'
|
||||
'9b44c28b36303152050c8c82469569c5'
|
||||
'2db6098a1a39bced4c6162eb46418320')
|
||||
md5sums=('e0defc8c818e4f1c5bbb29d0292b76ca'
|
||||
'9b44c28b36303152050c8c82469569c5')
|
||||
|
||||
_stagedir="${srcdir}/stagedir"
|
||||
|
||||
|
@ -37,8 +35,6 @@ build() {
|
|||
cd "${srcdir}"/${pkgbase}_${_boostver}
|
||||
# https://svn.boost.org/trac/boost/ticket/5731
|
||||
patch -p0 -i "${srcdir}/exceptions.patch"
|
||||
# https://svn.boost.org/trac/boost/ticket/6131
|
||||
patch -p2 -i "${srcdir}/BOOST_FOREACH.patch"
|
||||
|
||||
|
||||
# build bjam
|
||||
|
@ -90,7 +86,8 @@ package_boost() {
|
|||
pkgdesc="Free peer-reviewed portable C++ source libraries - Development"
|
||||
depends=("boost-libs=${pkgver}")
|
||||
optdepends=('python: for python bindings'
|
||||
'python2: for python2 bindings')
|
||||
'python2: for python2 bindings'
|
||||
'boost-build: to use boost jam for building your project.')
|
||||
|
||||
install -d "${pkgdir}"/usr/{include,lib,share}
|
||||
# headers/source files
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $Id: PKGBUILD 151094 2012-02-24 20:55:22Z andyrtr $
|
||||
# $Id: PKGBUILD 151785 2012-03-02 19:31:37Z andyrtr $
|
||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
@ -7,7 +7,7 @@
|
|||
plugrel=1
|
||||
|
||||
pkgname=gnutls
|
||||
pkgver=3.0.14
|
||||
pkgver=3.0.15
|
||||
pkgrel=1
|
||||
pkgdesc="A library which provides a secure layer over a reliable transport layer"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -18,8 +18,8 @@ options=('!libtool' '!zipman')
|
|||
depends=('gcc-libs' 'libtasn1' 'readline' 'zlib' 'nettle>=2.4' 'p11-kit>=0.11')
|
||||
makedepends=('strace')
|
||||
source=(ftp://ftp.gnu.org/gnu/gnutls/${pkgname}-${pkgver}.tar.xz{,.sig})
|
||||
md5sums=('0d613985c867846ccb5cbaba8fa576ef'
|
||||
'847af57e7d4702b176d1cbf157962f6e')
|
||||
md5sums=('37bdac12b5c039c7a8738b5d85eda968'
|
||||
'594eb29cbc3147dc0b6b529ebe96bd33')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
# $Id: PKGBUILD 146519 2012-01-12 10:34:00Z giovanni $
|
||||
# $Id: PKGBUILD 151902 2012-03-03 16:12:24Z giovanni $
|
||||
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
|
||||
# Contributor: Paul Mattal <paul@mattal.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@plugapps.com>
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - make install must be run as -j1, mkdir is not thread-safe for whatever reason
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgname=help2man
|
||||
pkgver=1.40.5
|
||||
pkgver=1.40.6
|
||||
pkgrel=1
|
||||
pkgdesc="Conversion tool to create man files"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -17,7 +17,7 @@ license=('GPL')
|
|||
depends=('perl-locale-gettext')
|
||||
install=help2man.install
|
||||
source=("http://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz")
|
||||
md5sums=('75a7d2f93765cd367aab98986a75f88c')
|
||||
md5sums=('f9ff9c6e65c74a0763596a7ca2b69aa7')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
|
@ -25,7 +25,7 @@ build() {
|
|||
./configure --prefix=/usr \
|
||||
--mandir=/usr/share/man \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/lib
|
||||
--libdir=/usr/lib
|
||||
make
|
||||
}
|
||||
|
||||
|
|
|
@ -8,7 +8,7 @@ post_install() {
|
|||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install $1
|
||||
post_install
|
||||
}
|
||||
|
||||
pre_remove() {
|
||||
|
|
|
@ -10,7 +10,7 @@ plugrel=1
|
|||
pkgbase=lirc
|
||||
pkgname=('lirc' 'lirc-utils')
|
||||
pkgver=0.9.0
|
||||
pkgrel=10
|
||||
pkgrel=12
|
||||
epoch=1
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.lirc.org/"
|
||||
|
|
9
extra/p7zip/7zFM.desktop
Normal file
9
extra/p7zip/7zFM.desktop
Normal file
|
@ -0,0 +1,9 @@
|
|||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=7-Zip FM
|
||||
GenericName=7-Zip File Manager
|
||||
Type=Application
|
||||
Categories=GTK;Utility;Archiving;Compression;
|
||||
Terminal=false
|
||||
Icon=p7zip
|
||||
Exec=7zFM
|
67
extra/p7zip/PKGBUILD
Normal file
67
extra/p7zip/PKGBUILD
Normal file
|
@ -0,0 +1,67 @@
|
|||
# $Id: PKGBUILD 143960 2011-11-30 22:27:20Z andrea $
|
||||
# Contributor: Thayer Williams <thayer@archlinux.org>
|
||||
# Contributor: Hugo Doria <hugo@archlinux.org>
|
||||
# Contributor: TuxSpirit<tuxspirit@archlinux.fr> 2007/11/17 21:22:36 UTC
|
||||
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
|
||||
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - change optimization to O0 to fix ICE
|
||||
# - use makefile.linux_any_cpu
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgname=p7zip
|
||||
pkgver=9.20.1
|
||||
pkgrel=6
|
||||
pkgdesc='Command-line version of the 7zip compressed file archiver'
|
||||
url='http://p7zip.sourceforge.net/'
|
||||
license=('GPL' 'custom')
|
||||
arch=('i686' 'x86_64')
|
||||
depends=('gcc-libs' 'bash')
|
||||
optdepends=('wxgtk: GUI'
|
||||
'desktop-file-utils: desktop entries')
|
||||
makedepends=('wxgtk')
|
||||
options=('!makeflags')
|
||||
source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}_${pkgver}_src_all.tar.bz2"
|
||||
'7zFM.desktop')
|
||||
sha1sums=('1cd567e043ee054bf08244ce15f32cb3258306b7'
|
||||
'f2c370d6f1b286b7ce9a2804e22541b755616a40')
|
||||
|
||||
install=install
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}_${pkgver}"
|
||||
|
||||
CFLAGS=`echo $CFLAGS | sed -e 's/-O2/-O0/'` && CXXFLAGS="$CFLAGS"
|
||||
cp makefile.linux_any_cpu makefile.machine
|
||||
|
||||
make all4 OPTFLAGS="${CXXFLAGS}"
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${pkgname}_${pkgver}"
|
||||
|
||||
make install \
|
||||
DEST_DIR="${pkgdir}" \
|
||||
DEST_HOME="/usr" \
|
||||
DEST_MAN="/usr/share/man"
|
||||
|
||||
# Licenses
|
||||
install -d "${pkgdir}"/usr/share/licenses/p7zip
|
||||
ln -s -t "${pkgdir}"/usr/share/licenses/p7zip \
|
||||
/usr/share/doc/p7zip/DOCS/License.txt \
|
||||
/usr/share/doc/p7zip/DOCS/unRarLicense.txt
|
||||
|
||||
# Integration with stuff...
|
||||
install -D GUI/p7zip_32.png "${pkgdir}"/usr/share/icons/hicolor/32x32/apps/p7zip.png
|
||||
install -d "${pkgdir}"/usr/share/{applications,kde4/services/ServiceMenus}
|
||||
cp GUI/kde4/* "${pkgdir}"/usr/share/kde4/services/ServiceMenus/
|
||||
cp ../7zFM.desktop "${pkgdir}"/usr/share/applications/
|
||||
ln -s 7zCon.sfx "${pkgdir}"/usr/lib/p7zip/7z.sfx
|
||||
|
||||
find GUI/help -type d -exec chmod 755 {} \;
|
||||
cp -r GUI/help "${pkgdir}"/usr/lib/p7zip/
|
||||
|
||||
chmod -R u+w "${pkgdir}/usr"
|
||||
}
|
13
extra/p7zip/install
Normal file
13
extra/p7zip/install
Normal file
|
@ -0,0 +1,13 @@
|
|||
post_install() {
|
||||
[[ -x usr/bin/update-desktop-database ]] && update-desktop-database -q || true
|
||||
[[ -x usr/bin/gtk-update-icon-cache ]] && gtk-update-icon-cache -q -t -f usr/share/icons/hicolor || true
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
|
@ -14,7 +14,7 @@ plugrel=1
|
|||
pkgbase=qt
|
||||
pkgname=('qt' 'qt-private-headers')
|
||||
pkgver=4.8.0
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL')
|
||||
|
@ -27,19 +27,26 @@ _pkgfqn="${pkgbase}-everywhere-opensource-src-${pkgver}"
|
|||
source=("http://get.qt.nokia.com/qt/source/${_pkgfqn}.tar.gz"
|
||||
'assistant.desktop' 'designer.desktop' 'linguist.desktop'
|
||||
'qtconfig.desktop'
|
||||
'fix-qurl.patch')
|
||||
'fix-qgraphicsscene-regression.patch'
|
||||
'improved-filter-event.patch'
|
||||
'qurl-backward-compatibility.patch')
|
||||
md5sums=('e8a5fdbeba2927c948d9f477a6abe904'
|
||||
'fc211414130ab2764132e7370f8e5caa'
|
||||
'85179f5e0437514f8639957e1d8baf62'
|
||||
'f11852b97583610f3dbb669ebc3e21bc'
|
||||
'6b771c8a81dd90b45e8a79afa0e5bbfd'
|
||||
'c2e91fc028250a590e76effe234468e2'
|
||||
'444ebeb716d7c7379835efb8aa88e6c8'
|
||||
'7bc255a36733d0fbc80c1902ade4beca')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}"/${_pkgfqn}
|
||||
|
||||
# (FS#27757)
|
||||
patch -p1 -i "${srcdir}"/fix-qurl.patch
|
||||
# (FS#28707)
|
||||
patch -p1 -i "${srcdir}"/fix-qgraphicsscene-regression.patch
|
||||
# (FS#27757) (KDEBUG#275469)
|
||||
patch -p1 -i "${srcdir}"/improved-filter-event.patch
|
||||
patch -p1 -i "${srcdir}"/qurl-backward-compatibility.patch
|
||||
|
||||
export QT4DIR="${srcdir}"/${_pkgfqn}
|
||||
export LD_LIBRARY_PATH=${QT4DIR}/lib:${LD_LIBRARY_PATH}
|
||||
|
|
54
extra/qt/fix-qgraphicsscene-regression.patch
Normal file
54
extra/qt/fix-qgraphicsscene-regression.patch
Normal file
|
@ -0,0 +1,54 @@
|
|||
From 15c14584199dc43e4a309fc331f3144009008128 Mon Sep 17 00:00:00 2001
|
||||
From: Jonathan Liu <net147@gmail.com>
|
||||
Date: Fri, 24 Feb 2012 00:42:34 +1100
|
||||
Subject: [PATCH] Revert "Don't rely on mapFromGlobal in
|
||||
QGraphicsScenePrivate::itemsAtPosition."
|
||||
|
||||
This reverts commit 7c0d15a22266a425c9e9ac0120d6774e120fe01e.
|
||||
The commit caused a regression whereby tooltips may be shown even if the
|
||||
mouse is not over the item if it has the Qt::ItemIgnoresTransformations
|
||||
flag and the QGraphicsView had been scaled.
|
||||
|
||||
Task-number: QTBUG-17517
|
||||
Task-number: QTBUG-22663
|
||||
Change-Id: Ib7fd788d9712c5e659fe07182f9505a4eb135ab2
|
||||
Reviewed-by: Andy Shaw <andy.shaw@digia.com>
|
||||
Reviewed-by: Robin Burchell <robin+qt@viroteck.net>
|
||||
---
|
||||
src/gui/graphicsview/qgraphicsscene.cpp | 10 +++++++---
|
||||
1 files changed, 7 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/gui/graphicsview/qgraphicsscene.cpp b/src/gui/graphicsview/qgraphicsscene.cpp
|
||||
index 14c0f3c..d1cdd4f 100644
|
||||
--- a/src/gui/graphicsview/qgraphicsscene.cpp
|
||||
+++ b/src/gui/graphicsview/qgraphicsscene.cpp
|
||||
@@ -1084,7 +1084,7 @@ void QGraphicsScenePrivate::enableMouseTrackingOnViews()
|
||||
/*!
|
||||
Returns all items for the screen position in \a event.
|
||||
*/
|
||||
-QList<QGraphicsItem *> QGraphicsScenePrivate::itemsAtPosition(const QPoint &/*screenPos*/,
|
||||
+QList<QGraphicsItem *> QGraphicsScenePrivate::itemsAtPosition(const QPoint &screenPos,
|
||||
const QPointF &scenePos,
|
||||
QWidget *widget) const
|
||||
{
|
||||
@@ -1093,12 +1093,16 @@ QList<QGraphicsItem *> QGraphicsScenePrivate::itemsAtPosition(const QPoint &/*sc
|
||||
if (!view)
|
||||
return q->items(scenePos, Qt::IntersectsItemShape, Qt::DescendingOrder, QTransform());
|
||||
|
||||
- const QRectF pointRect(scenePos, QSizeF(1, 1));
|
||||
+ const QRectF pointRect(QPointF(widget->mapFromGlobal(screenPos)), QSizeF(1, 1));
|
||||
if (!view->isTransformed())
|
||||
return q->items(pointRect, Qt::IntersectsItemShape, Qt::DescendingOrder);
|
||||
|
||||
const QTransform viewTransform = view->viewportTransform();
|
||||
- return q->items(pointRect, Qt::IntersectsItemShape,
|
||||
+ if (viewTransform.type() <= QTransform::TxScale) {
|
||||
+ return q->items(viewTransform.inverted().mapRect(pointRect), Qt::IntersectsItemShape,
|
||||
+ Qt::DescendingOrder, viewTransform);
|
||||
+ }
|
||||
+ return q->items(viewTransform.inverted().map(pointRect), Qt::IntersectsItemShape,
|
||||
Qt::DescendingOrder, viewTransform);
|
||||
}
|
||||
|
||||
--
|
||||
1.7.6
|
98
extra/qt/improved-filter-event.patch
Normal file
98
extra/qt/improved-filter-event.patch
Normal file
|
@ -0,0 +1,98 @@
|
|||
--- qt-opensource-4.8.0.old/src/gui/kernel/qapplication_x11.cpp 2011-12-16 03:22:33.918428374 -0500
|
||||
+++ qt-opensource-4.8.0.new/src/gui/kernel/qapplication_x11.cpp 2012-01-07 18:18:40.258246384 -0500
|
||||
@@ -4244,7 +4205,12 @@ bool QETWidget::translateMouseEvent(cons
|
||||
&& (nextEvent.xclient.message_type == ATOM(_QT_SCROLL_DONE) ||
|
||||
(nextEvent.xclient.message_type == ATOM(WM_PROTOCOLS) &&
|
||||
(Atom)nextEvent.xclient.data.l[0] == ATOM(_NET_WM_SYNC_REQUEST))))) {
|
||||
- qApp->x11ProcessEvent(&nextEvent);
|
||||
+ // As we may run through a significant number of a large class of non-MotionNotify
|
||||
+ // events here, without returning to the event loop, first pass nextEvent to
|
||||
+ // QAbstractEventDispatcher::filterEvent() to allow applications which override
|
||||
+ // QAbstractEventDispatcher::filterEvent() to handle the event first.
|
||||
+ if (!QAbstractEventDispatcher::instance()->filterEvent(&nextEvent))
|
||||
+ qApp->x11ProcessEvent(&nextEvent);
|
||||
continue;
|
||||
} else if (nextEvent.type != MotionNotify ||
|
||||
nextEvent.xmotion.window != event->xmotion.window ||
|
||||
--- qt-opensource-4.8.0.old/src/gui/kernel/qclipboard_x11.cpp 2011-12-08 00:06:02.000000000 -0500
|
||||
+++ qt-opensource-4.8.0.new/src/gui/kernel/qclipboard_x11.cpp 2012-01-07 18:30:35.298287639 -0500
|
||||
@@ -573,7 +573,11 @@ bool QX11Data::clipboardWaitForEvent(Win
|
||||
|
||||
// process other clipboard events, since someone is probably requesting data from us
|
||||
XEvent e;
|
||||
- if (XCheckIfEvent(X11->display, &e, checkForClipboardEvents, 0))
|
||||
+ // Some applications may override QAbstractEventDispatcher::filterEvent(), so
|
||||
+ // pass event to QAbstractEventDispatcher::filterEvent() before processing in
|
||||
+ // x11ProcessEvent().
|
||||
+ if (XCheckIfEvent(X11->display, &e, checkForClipboardEvents, 0) &&
|
||||
+ !QAbstractEventDispatcher::instance()->filterEvent(&e))
|
||||
qApp->x11ProcessEvent(&e);
|
||||
|
||||
now.start();
|
||||
--- qt-opensource-4.8.0.old/src/gui/kernel/qdnd_x11.cpp 2011-12-08 00:06:02.000000000 -0500
|
||||
+++ qt-opensource-4.8.0.new/src/gui/kernel/qdnd_x11.cpp 2012-01-07 18:28:13.841279478 -0500
|
||||
@@ -42,6 +42,7 @@
|
||||
#include "qplatformdefs.h"
|
||||
|
||||
#include "qapplication.h"
|
||||
+#include "qabstracteventdispatcher.h"
|
||||
|
||||
#ifndef QT_NO_DRAGANDDROP
|
||||
|
||||
@@ -1941,7 +1942,11 @@ Qt::DropAction QDragManager::drag(QDrag
|
||||
timer.start();
|
||||
do {
|
||||
XEvent event;
|
||||
- if (XCheckTypedEvent(X11->display, ClientMessage, &event))
|
||||
+ // Some applications may override QAbstractEventDispatcher::filterEvent(), so
|
||||
+ // pass event to QAbstractEventDispatcher::filterEvent() before processing in
|
||||
+ // x11ProcessEvent().
|
||||
+ if (XCheckTypedEvent(X11->display, ClientMessage, &event) &&
|
||||
+ !QAbstractEventDispatcher::instance()->filterEvent(&event))
|
||||
qApp->x11ProcessEvent(&event);
|
||||
|
||||
// sleep 50 ms, so we don't use up CPU cycles all the time.
|
||||
--- qt-opensource-4.8.0.old/src/gui/kernel/qwidget_x11.cpp 2011-12-08 00:06:02.000000000 -0500
|
||||
+++ qt-opensource-4.8.0.new/src/gui/kernel/qwidget_x11.cpp 2012-01-07 18:29:26.286283657 -0500
|
||||
@@ -44,6 +44,7 @@
|
||||
#include "qdesktopwidget.h"
|
||||
#include "qapplication.h"
|
||||
#include "qapplication_p.h"
|
||||
+#include "qabstracteventdispatcher.h"
|
||||
#include "qnamespace.h"
|
||||
#include "qpainter.h"
|
||||
#include "qbitmap.h"
|
||||
@@ -376,17 +377,22 @@ void qt_x11_wait_for_window_manager(QWid
|
||||
do {
|
||||
if (XEventsQueued(X11->display, QueuedAlready)) {
|
||||
XNextEvent(X11->display, &ev);
|
||||
- qApp->x11ProcessEvent(&ev);
|
||||
-
|
||||
- switch (state) {
|
||||
- case Initial:
|
||||
- if (ev.type == MapNotify && ev.xany.window == winid)
|
||||
- state = Mapped;
|
||||
- break;
|
||||
- case Mapped:
|
||||
- if (ev.type == Expose && ev.xany.window == winid)
|
||||
- return;
|
||||
- break;
|
||||
+ // Some applications may override QAbstractEventDispatcher::filterEvent(), so
|
||||
+ // pass event to QAbstractEventDispatcher::filterEvent() before processing in
|
||||
+ // x11ProcessEvent().
|
||||
+ if (!QAbstractEventDispatcher::instance()->filterEvent(&ev)) {
|
||||
+ qApp->x11ProcessEvent(&ev);
|
||||
+
|
||||
+ switch (state) {
|
||||
+ case Initial:
|
||||
+ if (ev.type == MapNotify && ev.xany.window == winid)
|
||||
+ state = Mapped;
|
||||
+ break;
|
||||
+ case Mapped:
|
||||
+ if (ev.type == Expose && ev.xany.window == winid)
|
||||
+ return;
|
||||
+ break;
|
||||
+ }
|
||||
}
|
||||
} else {
|
||||
if (!XEventsQueued(X11->display, QueuedAfterFlush))
|
35
extra/speex/PKGBUILD
Normal file
35
extra/speex/PKGBUILD
Normal file
|
@ -0,0 +1,35 @@
|
|||
# $Id: PKGBUILD 137583 2011-09-09 22:58:20Z allan $
|
||||
# Maintainer:
|
||||
# Contributer: Jason Chu <jason@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - enhancements for armv5
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgname=speex
|
||||
pkgver=1.2rc1
|
||||
pkgrel=2.1
|
||||
pkgdesc="A free codec for free speech"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.speex.org/"
|
||||
license=('BSD')
|
||||
depends=('libogg')
|
||||
options=('!libtool')
|
||||
source=(http://downloads.us.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz)
|
||||
md5sums=('c4438b22c08e5811ff10e2b06ee9b9ae')
|
||||
|
||||
build() {
|
||||
cd $srcdir/speex-$pkgver
|
||||
|
||||
[[ "$CARCH" == "arm" ]] && CONFIG="--enable-arm5e-asm --enable-fixed-point"
|
||||
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var $CONFIG
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $srcdir/speex-$pkgver
|
||||
make DESTDIR=$startdir/pkg install
|
||||
|
||||
install -D -m644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/LICENSE
|
||||
}
|
Loading…
Reference in a new issue