mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
alarm/kodi-c1: patch update
This commit is contained in:
parent
37281794c2
commit
f784275cf8
2 changed files with 8 additions and 8 deletions
|
@ -1,14 +1,14 @@
|
|||
From 7c4de312553d2da770be015b645bcdc841f1886e Mon Sep 17 00:00:00 2001
|
||||
From dbbbf5c4a207d51727b341b6768f76dbe99cb769 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 22 Jan 2015 16:17:02 -0700
|
||||
Subject: [PATCH] Fixes for using giflib 5 in GifHelper.cpp
|
||||
Subject: [PATCH] Fixes for using giflib 5.1 in GifHelper.cpp
|
||||
|
||||
---
|
||||
.../native/TexturePacker/src/decoder/GifHelper.cpp | 19 ++++++++++++++-----
|
||||
1 file changed, 14 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/tools/depends/native/TexturePacker/src/decoder/GifHelper.cpp b/tools/depends/native/TexturePacker/src/decoder/GifHelper.cpp
|
||||
index 8b65cf6..f52ec8a 100644
|
||||
index 8b65cf6..5529160 100644
|
||||
--- a/tools/depends/native/TexturePacker/src/decoder/GifHelper.cpp
|
||||
+++ b/tools/depends/native/TexturePacker/src/decoder/GifHelper.cpp
|
||||
@@ -82,7 +82,12 @@ GifHelper::GifHelper() :
|
||||
|
@ -17,7 +17,7 @@ index 8b65cf6..f52ec8a 100644
|
|||
{
|
||||
- int err = DGifCloseFile(m_gif);
|
||||
+ int err;
|
||||
+#if GIFLIB_MAJOR >= 5
|
||||
+#if GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
|
||||
+ DGifCloseFile(m_gif, &err);
|
||||
+#else
|
||||
+ err = DGifCloseFile(m_gif);
|
||||
|
@ -47,7 +47,7 @@ index 8b65cf6..f52ec8a 100644
|
|||
{
|
||||
if (DGifSlurp(gif) && gif->ImageCount > 1)
|
||||
m_isAnimated = 1;
|
||||
+#if GIFLIB_MAJOR >= 5
|
||||
+#if GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
|
||||
+ DGifCloseFile(gif, NULL);
|
||||
+#else
|
||||
DGifCloseFile(gif);
|
|
@ -31,14 +31,14 @@ makedepends=(
|
|||
'shairplay' 'smbclient' 'swig' 'taglib' 'tinyxml' 'unzip' 'upower' 'yajl' 'zip'
|
||||
)
|
||||
source=("https://github.com/mdrjr/xbmc/archive/${_commit}.tar.gz"
|
||||
'0001-Fixes-for-using-giflib-5-in-GifHelper.cpp.patch')
|
||||
'0001-Fixes-for-using-giflib-5.1-in-GifHelper.cpp.patch')
|
||||
sha256sums=('b644aa417593aa6a2aacee61b856e3419a7bef20a93f5adb0c4b2102c3f5e31d'
|
||||
'47ed17dd5d5a6127a88c2c0076760c6a7a5bb0cb33d50cf1ee55978cec26ad94')
|
||||
'54831a777aa6d5f0ca376e4bc0fc52ba0a7cbc074a24793cc0d2c0b02fac551d')
|
||||
|
||||
prepare() {
|
||||
cd xbmc-${_commit}
|
||||
|
||||
patch -p1 -i ../0001-Fixes-for-using-giflib-5-in-GifHelper.cpp.patch
|
||||
patch -p1 -i ../0001-Fixes-for-using-giflib-5.1-in-GifHelper.cpp.patch
|
||||
|
||||
find -type f -name *.py -exec sed 's|^#!.*python$|#!/usr/bin/python2|' -i "{}" +
|
||||
sed 's|^#!.*python$|#!/usr/bin/python2|' -i tools/depends/native/rpl-native/rpl
|
||||
|
|
Loading…
Reference in a new issue