mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/csound to 6.12.0-1
This commit is contained in:
parent
bfbfed2bbb
commit
f7a4d1c452
2 changed files with 33 additions and 48 deletions
|
@ -12,66 +12,65 @@ buildarch=22
|
|||
|
||||
pkgbase=csound
|
||||
pkgname=('csound' 'csound-doc')
|
||||
pkgver=6.11.0
|
||||
pkgrel=9
|
||||
pkgver=6.12.0
|
||||
pkgrel=1
|
||||
pkgdesc="A programming language for sound rendering and signal processing."
|
||||
arch=('x86_64')
|
||||
url="http://csound.com"
|
||||
license=('LGPL')
|
||||
# wiiuse needs release before add: https://github.com/rpavlik/wiiuse/issues/92
|
||||
# libpd needs to be packaged: https://github.com/libpd/libpd/releases
|
||||
# current gmm doesn't work https://github.com/csound/csound/issues/920
|
||||
makedepends=('boost' 'cmake' 'dssi' 'eigen' 'faust' 'fltk' 'fluidsynth' 'git'
|
||||
'hdf5' 'java-environment' 'ladspa' 'libwebsockets' 'llvm' 'luajit' 'pd'
|
||||
'portmidi' 'portsmf' 'python2' 'stk' 'swig')
|
||||
source=("${pkgname[0]}-${pkgver}.tar.gz::https://github.com/csound/csound/archive/${pkgver}.tar.gz"
|
||||
"${pkgname[0]}.sh"
|
||||
"fix-compiler-flag-overrides.patch"
|
||||
makedepends=('boost' 'cmake' 'cunit' 'doxygen' 'dssi' 'eigen' 'faust' 'fltk'
|
||||
'fluidsynth' 'git' 'hdf5' 'java-environment=8' 'ladspa' 'libmusicxml'
|
||||
'libwebsockets' 'llvm' 'luajit' 'portmidi' 'portsmf' 'python2' 'stk' 'swig')
|
||||
source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/${pkgbase}/${pkgbase}/archive/${pkgver}.tar.gz"
|
||||
"${pkgbase}.sh"
|
||||
"https://github.com/${pkgbase}/${pkgbase}/releases/download/${pkgver}/Csound${pkgver}_manual_html.zip"
|
||||
"https://github.com/${pkgbase}/${pkgbase}/releases/download/${pkgver}/Csound${pkgver}_manual_pdf.zip")
|
||||
sha512sums=('0261a9ed83d1545c4a29ab1e64dfe6ee72b3c4529b8c2107b81d6753a3fd76614aca12d59fc6d59b5cc093be4f631e41fdb3d57121bc4eeb67d6ca44c3ad01ad'
|
||||
sha512sums=('7053f998782e7f07fe209f866346179514434bd51ba4caf015bac09ed3843616d1644aac54cc7b8d437a81e69c634646419d45f07a65807f4061f8568bb4d232'
|
||||
'53a8ae1e61db2a3a492930ef0f0881b613ae47108c5e8de0a6e2aa28bcf7a5c93c7fea8b7fc2bbae29ab92e1e68bf94ba406be1255ad8ab5725ea9078c1fd6dc'
|
||||
'67a67dd7718da8e88f7c92f18ce1136372044d40c3a9ef86bdaed5c8172e225aa03448ec656da22d60fe9edfc0f6b10f337b02b96505f2e8c0815ef1b8b6a084'
|
||||
'c40fe88be3c101d84c473225183ccf02978113e24ad49d67945a1113012c39f590a7d51aeba939c4c43c691763b155a8f203ea993004f9d67d887f7ddce977d5'
|
||||
'c2ed8c9e44c50df7a82c3f10d117007795a38d6d7d5b364240b3def75a5469111d2e1c0ab059825233c765fa7ceb1c876f4439045b6d88bd0060b56343fb7c81')
|
||||
'eb287b9070c16d6cfbd890532d97eda34d72d8b5e5548a1a55ed7de91b2b913e04426cd50c94d0ac84221396002421077a5d22b3b67ce634c34a9aa1ceb53d9d'
|
||||
'88f7cf0c1053d1af31f18f0f866e68ffd8fb8b5d7c1f762e8c391f8e447a178b0700b7cf05327bc6e9c35a0b6acaa3f198359786ea8b8a3a07d63b4fc7a3c316')
|
||||
|
||||
prepare() {
|
||||
cd "${pkgname[0]}-${pkgver}"
|
||||
# problems compiler flags overrides: https://github.com/csound/csound/issues/960
|
||||
patch -Np1 -i "${srcdir}/fix-compiler-flag-overrides.patch"
|
||||
cd "${pkgbase}-${pkgver}"
|
||||
# requires out-of-tree build
|
||||
mkdir bld
|
||||
mkdir build
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${pkgname[0]}-${pkgver}/bld"
|
||||
cmake .. -DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_CXX_FLAGS="-Wno-error -Wno-missing-field-initializers -DPFFFT_SIMD_DISABLE" \
|
||||
-DCMAKE_C_FLAGS="-Wno-error -Wno-missing-field-initializers -DPFFFT_SIMD_DISABLE" \
|
||||
-DBUILD_JAVA_INTERFACE=0 \
|
||||
-DBUILD_FAUST_OPCODES=1 \
|
||||
-DFAUST_LIBRARY=/usr/lib/libfaust.a \
|
||||
-DLUAJIT_LIBRARY=/usr/lib/libluajit-5.1.so \
|
||||
-DLUA_H_PATH=/usr/include/luajit-2.0/ \
|
||||
-DLUA_MODULE_INSTALL_DIR=/usr/lib/lua/5.1/ \
|
||||
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
|
||||
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
|
||||
-DPYTHON_MODULE_INSTALL_DIR=/usr/lib/python2.7/site-packages
|
||||
cd "${pkgbase}-${pkgver}/build"
|
||||
cmake -DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_CXX_FLAGS="-Wno-error -Wno-missing-field-initializers -DPFFFT_SIMD_DISABLE" \
|
||||
-DCMAKE_C_FLAGS="-Wno-error -Wno-missing-field-initializers -DPFFFT_SIMD_DISABLE" \
|
||||
-DBUILD_JAVA_INTERFACE=0 \
|
||||
-DLUA_MODULE_INSTALL_DIR=/usr/lib/lua/5.1/ \
|
||||
-DLUAJIT_LIBRARY=/usr/lib/libluajit-5.1.so \
|
||||
-DLUA_H_PATH=/usr/include/luajit-2.0/ \
|
||||
-DPYTHON_MODULE_INSTALL_DIR=/usr/lib/python2.7/site-packages \
|
||||
-DBUILD_STATIC_LIBRARY=ON \
|
||||
..
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd "${pkgbase}-${pkgver}/build"
|
||||
make test
|
||||
}
|
||||
|
||||
package_csound() {
|
||||
groups=('pro-audio')
|
||||
depends=('fluidsynth' 'git' 'hdf5' 'liblo' 'libwebsockets' 'luajit'
|
||||
'portmidi' 'portsmf' 'stk' 'tk')
|
||||
depends=('fluidsynth' 'git' 'hdf5' 'liblo' 'libmusicxml' 'libwebsockets'
|
||||
'luajit' 'portmidi' 'portsmf' 'stk' 'tk')
|
||||
optdepends=('csound-doc: The canonical Csound Reference Manual'
|
||||
'csoundqt: Qt frontend'
|
||||
'fltk: fltk GUIs'
|
||||
'faust: Embed faust'
|
||||
'java-environment: Use csound with Java'
|
||||
'java-runtime=8: Use csound with Java'
|
||||
'python2: python opcodes'
|
||||
'vim-csound: Use csound with vim')
|
||||
cd "${pkgname}-${pkgver}/bld"
|
||||
cd "${pkgname}-${pkgver}/build"
|
||||
make DESTDIR="${pkgdir}/" install
|
||||
|
||||
# export vars in profile.d
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
diff -ruN csound-6.11.0-a/CMakeLists.txt csound-6.11.0-b/CMakeLists.txt
|
||||
--- csound-6.11.0-a/CMakeLists.txt 2018-05-10 10:31:20.000000000 +0200
|
||||
+++ csound-6.11.0-b/CMakeLists.txt 2018-05-17 20:40:50.659122644 +0200
|
||||
@@ -15,8 +15,8 @@
|
||||
if(NOT MSVC AND NOT WASM)
|
||||
set(CMAKE_CXX_FLAGS_RELEASE "-O3 ")
|
||||
set(CMAKE_C_FLAGS_RELEASE "-O3 ")
|
||||
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Werror -Wno-missing-field-initializers")
|
||||
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Werror -Wno-missing-field-initializers")
|
||||
+set(CMAKE_CXX_FLAGS " -Wall -Werror -Wno-missing-field-initializers ${CMAKE_CXX_FLAGS}")
|
||||
+set(CMAKE_C_FLAGS " -Wall -Werror -Wno-missing-field-initializers ${CMAKE_C_FLAGS}")
|
||||
endif()
|
||||
|
||||
# C++11 needed
|
Loading…
Reference in a new issue