mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/qt5-webengine to 5.13.2-3
This commit is contained in:
parent
880295d5ad
commit
f81992dfe9
2 changed files with 68 additions and 1 deletions
|
@ -11,7 +11,7 @@ highmem=1
|
|||
pkgname=qt5-webengine
|
||||
_qtver=5.13.2
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
arch=('x86_64')
|
||||
url='https://www.qt.io'
|
||||
license=('LGPL3' 'LGPL2.1' 'BSD')
|
||||
|
@ -22,10 +22,12 @@ makedepends=('python2' 'gperf' 'jsoncpp' 'ninja' 'qt5-tools' 'poppler')
|
|||
groups=('qt' 'qt5')
|
||||
_pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
|
||||
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
|
||||
icu65.patch
|
||||
CVE-2019-13720.patch::"https://code.qt.io/cgit/qt/qtwebengine-chromium.git/patch/?id=d6e5fc10"
|
||||
0001-ARM-toolchain-fixes.patch
|
||||
0002-Fix-ARM-skia-ICE.patch)
|
||||
sha256sums=('adcf56b5de6f34744bba2307b696fc75611884f4270e87dfa760d6e99dd711bb'
|
||||
'1de9bdbfed482295dda45c7d4e323cee55a34e42f66b892da1c1a778682b7a41'
|
||||
'3b2ce75214e757f5d0d268fbb1009c2e0c660d19620ae27e8d92a0e492e5d9da'
|
||||
'f03455dd16275f8abb432278abb908ebdd5f8cf83db73ae63de7a105bbf47109'
|
||||
'2a363b44b8291512bb2bcbce1370b8abfb8a57961e0e5e34150da6e337155a05')
|
||||
|
@ -35,6 +37,7 @@ prepare() {
|
|||
|
||||
cd $_pkgfqn/src/3rdparty
|
||||
patch -p1 -i "$srcdir"/CVE-2019-13720.patch
|
||||
patch -p1 -d chromium -i "$srcdir"/icu65.patch
|
||||
|
||||
#cd src/3rdparty
|
||||
patch -p1 -i ${srcdir}/0001-ARM-toolchain-fixes.patch
|
||||
|
|
64
extra/qt5-webengine/icu65.patch
Normal file
64
extra/qt5-webengine/icu65.patch
Normal file
|
@ -0,0 +1,64 @@
|
|||
From 5679c3c191ed62b62d8db22f1657a296ee9bfe8e Mon Sep 17 00:00:00 2001
|
||||
From: Frank Tang <ftang@chromium.org>
|
||||
Date: Wed, 30 Oct 2019 22:49:47 +0000
|
||||
Subject: [PATCH] Update ICU to 65.1 from 64 and fix broken tests
|
||||
|
||||
ICU 65-1 release note
|
||||
http://site.icu-project.org/download/65
|
||||
|
||||
CLDR 36 release blog
|
||||
http://blog.unicode.org/2019/10/unicode-cldr-version-36-languagelocale.html
|
||||
|
||||
Most of the test expectation change is due to CLDR 36 update
|
||||
of Grapheme Cluster for Indic languages
|
||||
See the following for related changes in ICU 65.1 in this area:
|
||||
https://unicode-org.atlassian.net/browse/CLDR-10994
|
||||
https://unicode-org.atlassian.net/browse/ICU-13637
|
||||
https://github.com/unicode-org/cldr/blob/master/common/properties/segments/readme.txt
|
||||
|
||||
Bug: chromium:1014272, chromium:1017047
|
||||
Change-Id: I9fc6d4620bf2a4c189940d06d8c79893502db3dd
|
||||
Cq-Include-Trybots: luci.chromium.try:linux_layout_tests_layout_ng_disabled
|
||||
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1866059
|
||||
Reviewed-by: Jungshik Shin <jshin@chromium.org>
|
||||
Reviewed-by: Doug Turner <dougt@chromium.org>
|
||||
Reviewed-by: Michael Wasserman <msw@chromium.org>
|
||||
Reviewed-by: Kent Tamura <tkent@chromium.org>
|
||||
Reviewed-by: Trent Apted <tapted@chromium.org>
|
||||
Reviewed-by: Mason Freed <masonfreed@chromium.org>
|
||||
Commit-Queue: Frank Tang <ftang@chromium.org>
|
||||
Cr-Commit-Position: refs/heads/master@{#711027}
|
||||
---
|
||||
third_party/blink/renderer/core/dom/document.cc | 2 +-
|
||||
ui/gfx/render_text_harfbuzz.cc | 5 ++++-
|
||||
2 files changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/third_party/blink/renderer/core/dom/document.cc b/third_party/blink/renderer/core/dom/document.cc
|
||||
index 511aac29086..f188cf548a6 100644
|
||||
--- a/third_party/blink/renderer/core/dom/document.cc
|
||||
+++ b/third_party/blink/renderer/core/dom/document.cc
|
||||
@@ -6191,7 +6191,7 @@ static ParseQualifiedNameResult ParseQualifiedNameInternal(
|
||||
|
||||
for (unsigned i = 0; i < length;) {
|
||||
UChar32 c;
|
||||
- U16_NEXT(characters, i, length, c)
|
||||
+ U16_NEXT(characters, i, length, c);
|
||||
if (c == ':') {
|
||||
if (saw_colon)
|
||||
return ParseQualifiedNameResult(kQNMultipleColons);
|
||||
diff --git a/ui/gfx/render_text_harfbuzz.cc b/ui/gfx/render_text_harfbuzz.cc
|
||||
index 50e86af6b97..0339ff3ff8e 100644
|
||||
--- a/ui/gfx/render_text_harfbuzz.cc
|
||||
+++ b/ui/gfx/render_text_harfbuzz.cc
|
||||
@@ -971,7 +971,10 @@ RangeF TextRunHarfBuzz::GetGraphemeBounds(RenderTextHarfBuzz* render_text,
|
||||
++total;
|
||||
}
|
||||
}
|
||||
- DCHECK_GT(total, 0);
|
||||
+ // With ICU 65.1, DCHECK_GT() below fails.
|
||||
+ // See https://crbug.com/1017047 for more details.
|
||||
+ //
|
||||
+ // DCHECK_GT(total, 0);
|
||||
|
||||
// It's possible for |text_index| to point to a diacritical mark, at the end
|
||||
// of |chars|. In this case all the grapheme boundaries come before it. Just
|
Loading…
Reference in a new issue