mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/thunderbird to 31.6.0-2
This commit is contained in:
parent
19792fdcfc
commit
f82f327291
2 changed files with 32 additions and 2 deletions
|
@ -14,7 +14,7 @@ buildarch=20
|
|||
|
||||
pkgname=thunderbird
|
||||
pkgver=31.6.0
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="Standalone Mail/News reader"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('MPL' 'GPL')
|
||||
|
@ -28,6 +28,7 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/sou
|
|||
thunderbird.desktop
|
||||
thunderbird-install-dir.patch
|
||||
vendor.js
|
||||
thunderbird-31.6.0-libvpx-modern.patch
|
||||
no-neon.patch)
|
||||
options=(!emptydirs)
|
||||
sha256sums=('ccbf8cbb740bc1b30ecf4fe39aab226607f9a41e23a07e994c508a90e8b70508'
|
||||
|
@ -36,15 +37,19 @@ sha256sums=('ccbf8cbb740bc1b30ecf4fe39aab226607f9a41e23a07e994c508a90e8b70508'
|
|||
'3fba13d88aeb003ab0811ef739463858172ce0662a1c7d62835df3d83ddbb8fb'
|
||||
'9049ab3f9600a1592a54c41a166c76e046c393e1cfe7c4e769155b7317d197ee'
|
||||
'e4ea8e6788163d9f8db8f1f40023db3ea0a1358f9a4510169f2d4c4fe6a887ed'
|
||||
'0e67b4d46f330b0306e01d4c6876ae5a58a4de6ac50f057e23aac41dec3554ef'
|
||||
'8010bc3abff71cdaa3624ebbddbc7baaae4cda7ad093ad60d3c3e841c1141872')
|
||||
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
|
||||
|
||||
prepare() {
|
||||
cd comm-esr31
|
||||
patch -Np1 -i "$srcdir/thunderbird-install-dir.patch"
|
||||
patch -Np1 -i ../thunderbird-install-dir.patch
|
||||
|
||||
patch -Np0 -i ../no-neon.patch
|
||||
|
||||
# Fix build with libvpx 1.4.0 (patch from Fedora)
|
||||
patch -Np1 -i ../thunderbird-31.6.0-libvpx-modern.patch
|
||||
|
||||
cp "$srcdir/mozconfig" .mozconfig
|
||||
|
||||
# configure script misdetects the preprocessor without an optimization level
|
||||
|
|
25
extra/thunderbird/thunderbird-31.6.0-libvpx-modern.patch
Normal file
25
extra/thunderbird/thunderbird-31.6.0-libvpx-modern.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
diff -up comm-esr31/mozilla/media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc.modern comm-esr31/mozilla/media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc
|
||||
--- comm-esr31/mozilla/media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc.modern 2015-04-07 14:30:05.525960513 -0400
|
||||
+++ comm-esr31/mozilla/media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc 2015-04-07 14:32:22.478199058 -0400
|
||||
@@ -180,7 +180,7 @@ int VP8EncoderImpl::InitEncode(const Vid
|
||||
// Creating a wrapper to the image - setting image data to NULL. Actual
|
||||
// pointer will be set in encode. Setting align to 1, as it is meaningless
|
||||
// (actual memory is not allocated).
|
||||
- raw_ = vpx_img_wrap(NULL, IMG_FMT_I420, codec_.width, codec_.height,
|
||||
+ raw_ = vpx_img_wrap(NULL, VPX_IMG_FMT_I420, codec_.width, codec_.height,
|
||||
1, NULL);
|
||||
// populate encoder configuration with default values
|
||||
if (vpx_codec_enc_config_default(vpx_codec_vp8_cx(), config_, 0)) {
|
||||
@@ -349,9 +349,9 @@ int VP8EncoderImpl::Encode(const I420Vid
|
||||
}
|
||||
// Image in vpx_image_t format.
|
||||
// Input image is const. VP8's raw image is not defined as const.
|
||||
- raw_->planes[PLANE_Y] = const_cast<uint8_t*>(input_image.buffer(kYPlane));
|
||||
- raw_->planes[PLANE_U] = const_cast<uint8_t*>(input_image.buffer(kUPlane));
|
||||
- raw_->planes[PLANE_V] = const_cast<uint8_t*>(input_image.buffer(kVPlane));
|
||||
+ raw_->planes[VPX_PLANE_Y] = const_cast<uint8_t*>(input_image.buffer(kYPlane));
|
||||
+ raw_->planes[VPX_PLANE_U] = const_cast<uint8_t*>(input_image.buffer(kUPlane));
|
||||
+ raw_->planes[VPX_PLANE_V] = const_cast<uint8_t*>(input_image.buffer(kVPlane));
|
||||
// TODO(mikhal): Stride should be set in initialization.
|
||||
raw_->stride[VPX_PLANE_Y] = input_image.stride(kYPlane);
|
||||
raw_->stride[VPX_PLANE_U] = input_image.stride(kUPlane);
|
Loading…
Reference in a new issue