mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/xbmc to 13.0-2
This commit is contained in:
parent
9717458700
commit
f833beb1f6
2 changed files with 113 additions and 4 deletions
|
@ -16,12 +16,18 @@ _prefix=/usr
|
|||
pkgname=xbmc
|
||||
pkgver=13.0
|
||||
_codename=Gotham
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="A software media player and entertainment hub for digital media"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://xbmc.org"
|
||||
license=('GPL' 'custom')
|
||||
depends=('hicolor-icon-theme' 'fribidi' 'lzo2' 'smbclient' 'libtiff' 'libva' 'libpng' 'libcdio' 'yajl' 'libmysqlclient' 'libjpeg-turbo' 'libsamplerate' 'glew' 'libssh' 'libmicrohttpd' 'libxrandr' 'sdl_mixer' 'sdl_image' 'python2' 'libass' 'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump' 'unzip' 'mesa-demos' 'xorg-xdpyinfo' 'libbluray' 'libnfs' 'afpfs-ng' 'avahi' 'bluez-libs' 'tinyxml' 'libcap' 'swig' 'taglib' 'java-runtime-headless' 'glu' 'mesa' 'shairplay' 'libxslt' 'libpulse')
|
||||
depends=('hicolor-icon-theme' 'fribidi' 'lzo2' 'smbclient' 'libtiff' 'libva'
|
||||
'libpng' 'libcdio' 'yajl' 'libmysqlclient' 'libjpeg-turbo' 'libsamplerate'
|
||||
'glew' 'libssh' 'libmicrohttpd' 'libxrandr' 'sdl_mixer' 'sdl_image'
|
||||
'python2' 'libass' 'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump'
|
||||
'unzip' 'mesa-demos' 'xorg-xdpyinfo' 'libbluray' 'libnfs' 'afpfs-ng'
|
||||
'avahi' 'bluez-libs' 'tinyxml' 'libcap' 'swig' 'taglib' 'libpulse'
|
||||
'java-runtime-headless' 'glu' 'mesa' 'shairplay' 'libxslt' 'ffmpeg')
|
||||
makedepends=('boost' 'cmake' 'gperf' 'nasm' 'libxinerama' 'zip' 'libcec'
|
||||
'udisks' 'upower' 'mesa' 'doxygen' 'swig' 'java-environment')
|
||||
optdepends=('libcec: support for Pulse-Eight USB-CEC adapter'
|
||||
|
@ -34,14 +40,17 @@ optdepends=('libcec: support for Pulse-Eight USB-CEC adapter'
|
|||
install="${pkgname}.install"
|
||||
source=("xbmc-$pkgver.tar.gz::https://github.com/xbmc/xbmc/archive/13.0-Gotham.tar.gz"
|
||||
"xbmc.service"
|
||||
"polkit.rules")
|
||||
"polkit.rules"
|
||||
"enable-external-ffmpeg.patch")
|
||||
md5sums=('54fafd985b5209859ba6faeb50b8f142'
|
||||
'de331663cc8adc94f2fe44a262cfff58'
|
||||
'02f7951824ee13103344f36009c0ef2a')
|
||||
'02f7951824ee13103344f36009c0ef2a'
|
||||
'9f9b41cfc1e21b1e7d0bb10d6e85b3c6')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/xbmc-$pkgver-$_codename"
|
||||
|
||||
patch -p1 -i ../enable-external-ffmpeg.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
100
community/xbmc/enable-external-ffmpeg.patch
Normal file
100
community/xbmc/enable-external-ffmpeg.patch
Normal file
|
@ -0,0 +1,100 @@
|
|||
diff -rupN a/configure.in b/configure.in
|
||||
--- a/configure.in 2014-05-03 21:03:25.000000000 +0000
|
||||
+++ b/configure.in 2014-05-07 09:56:30.039177391 +0000
|
||||
@@ -600,7 +600,7 @@ PKG_PROG_PKG_CONFIG
|
||||
MAKE="${MAKE:-make}"
|
||||
OBJDUMP="${OBJDUMP:-objdump}"
|
||||
|
||||
-use_external_ffmpeg=no
|
||||
+use_external_ffmpeg=yes
|
||||
use_static_ffmpeg=no
|
||||
|
||||
# ffmpeg needs the output of uname -s (e.x. linux, darwin) for the target_os
|
||||
@@ -632,7 +632,7 @@ case $host in
|
||||
use_arch="x86"
|
||||
use_cpu="i686"
|
||||
fi
|
||||
- use_static_ffmpeg=yes
|
||||
+ use_static_ffmpeg=no
|
||||
;;
|
||||
x86_64-*-linux-gnu*|x86_64-*-linux-uclibc*)
|
||||
ARCH="x86_64-linux"
|
||||
@@ -640,7 +640,7 @@ case $host in
|
||||
use_arch="x86_64"
|
||||
use_cpu="x86_64"
|
||||
fi
|
||||
- use_static_ffmpeg=yes
|
||||
+ use_static_ffmpeg=no
|
||||
;;
|
||||
i386-*-freebsd*)
|
||||
ARCH="x86-freebsd"
|
||||
@@ -696,7 +696,7 @@ case $host in
|
||||
use_sdl=no
|
||||
use_x11=no
|
||||
use_wayland=no
|
||||
- use_static_ffmpeg=yes
|
||||
+ use_static_ffmpeg=no
|
||||
;;
|
||||
arm*-*linux-android*)
|
||||
target_platform=target_android
|
||||
diff -rupN a/lib/DllAvCodec.h b/lib/DllAvCodec.h
|
||||
--- a/lib/DllAvCodec.h 2014-05-03 21:03:25.000000000 +0000
|
||||
+++ b/lib/DllAvCodec.h 2014-05-07 10:10:06.298165915 +0000
|
||||
@@ -43,6 +43,7 @@ extern "C" {
|
||||
|
||||
#if (defined USE_EXTERNAL_FFMPEG)
|
||||
#include <libavcodec/avcodec.h>
|
||||
+ #include <libavutil/frame.h>
|
||||
#else
|
||||
#include "libavcodec/avcodec.h"
|
||||
#endif
|
||||
diff -rupN a/lib/DllAvUtil.h b/lib/DllAvUtil.h
|
||||
--- a/lib/DllAvUtil.h 2014-05-03 21:03:25.000000000 +0000
|
||||
+++ b/lib/DllAvUtil.h 2014-05-07 10:17:31.415798448 +0000
|
||||
@@ -31,33 +31,19 @@
|
||||
#endif
|
||||
|
||||
extern "C" {
|
||||
-#if (defined USE_EXTERNAL_FFMPEG)
|
||||
- #include <libavutil/avutil.h>
|
||||
- // for av_get_default_channel_layout
|
||||
- #include <libavutil/audioconvert.h>
|
||||
- #include <libavutil/crc.h>
|
||||
- #include <libavutil/fifo.h>
|
||||
- // for LIBAVCODEC_VERSION_INT:
|
||||
- #include <libavcodec/avcodec.h>
|
||||
- // for enum AVSampleFormat
|
||||
- #include <libavutil/samplefmt.h>
|
||||
- #include <libavutil/opt.h>
|
||||
- #include <libavutil/mem.h>
|
||||
- #include <libavutil/mathematics.h>
|
||||
- #if (defined USE_LIBAV_HACKS)
|
||||
- #include "xbmc-libav-hacks/libav_hacks.h"
|
||||
- #endif
|
||||
-#else
|
||||
- #include "libavutil/avutil.h"
|
||||
- //for av_get_default_channel_layout
|
||||
- #include "libavutil/audioconvert.h"
|
||||
- #include "libavutil/crc.h"
|
||||
- #include "libavutil/opt.h"
|
||||
- #include "libavutil/mem.h"
|
||||
- #include "libavutil/fifo.h"
|
||||
- // for enum AVSampleFormat
|
||||
- #include "libavutil/samplefmt.h"
|
||||
-#endif
|
||||
+#include <libavutil/avutil.h>
|
||||
+#include <libavutil/frame.h>
|
||||
+// for av_get_default_channel_layout
|
||||
+#include <libavutil/audioconvert.h>
|
||||
+#include <libavutil/crc.h>
|
||||
+#include <libavutil/fifo.h>
|
||||
+// for LIBAVCODEC_VERSION_INT:
|
||||
+#include <libavcodec/avcodec.h>
|
||||
+// for enum AVSampleFormat
|
||||
+#include <libavutil/samplefmt.h>
|
||||
+#include <libavutil/opt.h>
|
||||
+#include <libavutil/mem.h>
|
||||
+#include <libavutil/mathematics.h>
|
||||
}
|
||||
|
||||
#if LIBAVUTIL_VERSION_INT >= AV_VERSION_INT(52,29,100)
|
Loading…
Reference in a new issue