extra/calligra to 3.1.0-24

This commit is contained in:
Kevin Mihelich 2019-11-14 15:28:37 +00:00
parent 6ffbbd15fe
commit f84415cb99
2 changed files with 17 additions and 1 deletions

View file

@ -10,7 +10,7 @@
pkgname=calligra
pkgdesc="A set of applications for productivity and creative usage"
pkgver=3.1.0
pkgrel=23
pkgrel=24
arch=(x86_64)
url='https://www.calligra-suite.org/'
license=(FDL1.2 GPL2 LGPL)
@ -46,6 +46,7 @@ source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.x
calligra-poppler-0.71.patch
calligra-poppler-0.72.patch
calligra-poppler-0.73.patch
calligra-poppler-0.82.patch
'calligra-2.9.11-gcc6_arm.patch')
sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
'SKIP'
@ -55,6 +56,7 @@ sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
'052adc4ea812d7667812ff7867e703327dbe7c1ecad86094fd6772dc09782d87'
'87a09710b9e7e825a46344ddec08eb98b3454d6d067b0177d284733b2342cece'
'ef95f49f69c9f2a5b530e416003f2d6d106bb3c85e8458ae27494c64c8b474a8'
'a2f02dccd8f7748b187dba805220ded95c41bbddc084091794691164184d1b82'
'33d803c49abefc37f51f824543e889f9e369e86df9ce64d980e0a7dbca2ea27d')
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <foundation@krita.org>
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <danders@get2net.dk>
@ -75,6 +77,8 @@ prepare() {
patch -p1 -i ../calligra-poppler-0.72.patch
# Fix build with poppler 0.73
patch -p1 -i ../calligra-poppler-0.73.patch
# Fix build with poppler 0.82
patch -p1 -i ../calligra-poppler-0.82.patch
patch -p1 -i ../calligra-2.9.11-gcc6_arm.patch
}

View file

@ -0,0 +1,12 @@
diff -upr calligra-3.1.0.orig/filters/karbon/pdf/SvgOutputDev.cpp calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.cpp
--- calligra-3.1.0.orig/filters/karbon/pdf/SvgOutputDev.cpp 2019-11-12 14:55:33.418358543 +0200
+++ calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.cpp 2019-11-12 14:59:26.843199351 +0200
@@ -405,7 +405,7 @@ void SvgOutputDev::drawString(GfxState *
const char * p = s->c_str();
int len = s->getLength();
CharCode code;
- Unicode *u = nullptr;
+ const Unicode *u = nullptr;
int uLen;
double dx, dy, originX, originY;
while (len > 0) {