mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/rust to 1.66.0-1.1
This commit is contained in:
parent
b7559b9193
commit
f86e76bb34
4 changed files with 64 additions and 32 deletions
|
@ -4,15 +4,17 @@ Date: Thu, 6 May 2021 20:14:58 +0200
|
|||
Subject: [PATCH] bootstrap: Change libexec dir
|
||||
|
||||
---
|
||||
src/bootstrap/dist.rs | 4 ++--
|
||||
src/tools/rust-analyzer/crates/rust-analyzer/src/reload.rs | 2 +-
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
src/bootstrap/dist.rs | 4 ++--
|
||||
src/bootstrap/tool.rs | 2 +-
|
||||
.../crates/rust-analyzer/src/cli/load_cargo.rs | 2 +-
|
||||
src/tools/rust-analyzer/crates/rust-analyzer/src/reload.rs | 6 ++----
|
||||
4 files changed, 6 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
||||
index 1a59b3958f10..6e650d286d8f 100644
|
||||
index 12585e80e6b7..eb596be98dca 100644
|
||||
--- a/src/bootstrap/dist.rs
|
||||
+++ b/src/bootstrap/dist.rs
|
||||
@@ -372,7 +372,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
|
||||
@@ -394,7 +394,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
|
||||
target: compiler.host,
|
||||
})
|
||||
.expect("rust-analyzer-proc-macro-server always builds");
|
||||
|
@ -21,7 +23,7 @@ index 1a59b3958f10..6e650d286d8f 100644
|
|||
|
||||
let libdir_relative = builder.libdir_relative(compiler);
|
||||
|
||||
@@ -980,7 +980,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
@@ -1003,7 +1003,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
||||
let dirent = dirent.expect("read dir entry");
|
||||
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
||||
|
@ -30,16 +32,46 @@ index 1a59b3958f10..6e650d286d8f 100644
|
|||
}
|
||||
}
|
||||
|
||||
diff --git a/src/bootstrap/tool.rs b/src/bootstrap/tool.rs
|
||||
index eec74b2675a1..4bf1d7348e43 100644
|
||||
--- a/src/bootstrap/tool.rs
|
||||
+++ b/src/bootstrap/tool.rs
|
||||
@@ -781,7 +781,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> {
|
||||
|
||||
// Copy `rust-analyzer-proc-macro-srv` to `<sysroot>/libexec/`
|
||||
// so that r-a can use it.
|
||||
- let libexec_path = builder.sysroot(self.compiler).join("libexec");
|
||||
+ let libexec_path = builder.sysroot(self.compiler).join("lib");
|
||||
t!(fs::create_dir_all(&libexec_path));
|
||||
builder.copy(&path, &libexec_path.join("rust-analyzer-proc-macro-srv"));
|
||||
|
||||
diff --git a/src/tools/rust-analyzer/crates/rust-analyzer/src/cli/load_cargo.rs b/src/tools/rust-analyzer/crates/rust-analyzer/src/cli/load_cargo.rs
|
||||
index 5dba545b8718..befaeb9e70db 100644
|
||||
--- a/src/tools/rust-analyzer/crates/rust-analyzer/src/cli/load_cargo.rs
|
||||
+++ b/src/tools/rust-analyzer/crates/rust-analyzer/src/cli/load_cargo.rs
|
||||
@@ -69,7 +69,7 @@ pub fn load_workspace(
|
||||
if let Some(sysroot) = sysroot.as_ref() {
|
||||
let standalone_server_name =
|
||||
format!("rust-analyzer-proc-macro-srv{}", std::env::consts::EXE_SUFFIX);
|
||||
- let server_path = sysroot.root().join("libexec").join(&standalone_server_name);
|
||||
+ let server_path = sysroot.root().join("lib").join(&standalone_server_name);
|
||||
if std::fs::metadata(&server_path).is_ok() {
|
||||
path = server_path;
|
||||
args = vec![];
|
||||
diff --git a/src/tools/rust-analyzer/crates/rust-analyzer/src/reload.rs b/src/tools/rust-analyzer/crates/rust-analyzer/src/reload.rs
|
||||
index e47f70fff39e..78c2a65aee8b 100644
|
||||
index e1f651786dee..77d6efca231e 100644
|
||||
--- a/src/tools/rust-analyzer/crates/rust-analyzer/src/reload.rs
|
||||
+++ b/src/tools/rust-analyzer/crates/rust-analyzer/src/reload.rs
|
||||
@@ -321,7 +321,7 @@ fn eq_ignore_build_data<'a>(
|
||||
if let Some(sysroot) = sysroot.as_ref() {
|
||||
tracing::debug!("Found a cargo workspace with a sysroot...");
|
||||
let server_path =
|
||||
- sysroot.root().join("libexec").join(&standalone_server_name);
|
||||
+ sysroot.root().join("lib").join(&standalone_server_name);
|
||||
if std::fs::metadata(&server_path).is_ok() {
|
||||
tracing::debug!(
|
||||
"And the server exists at {}",
|
||||
@@ -322,10 +322,8 @@ fn eq_ignore_build_data<'a>(
|
||||
| ProjectWorkspace::Json { sysroot, .. } = ws
|
||||
{
|
||||
if let Some(sysroot) = sysroot.as_ref() {
|
||||
- let server_path = sysroot
|
||||
- .root()
|
||||
- .join("libexec")
|
||||
- .join(&standalone_server_name);
|
||||
+ let server_path =
|
||||
+ sysroot.root().join("lib").join(&standalone_server_name);
|
||||
if std::fs::metadata(&server_path).is_ok() {
|
||||
tracing::debug!(
|
||||
"Sysroot proc-macro server exists at {}",
|
||||
|
|
|
@ -24,10 +24,10 @@ targets, as things break when this is done:
|
|||
4 files changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
||||
index 8bb3878fbbb4..969247f5d4fa 100644
|
||||
index f2ee52262ade..6a813c4b8707 100644
|
||||
--- a/compiler/rustc_session/src/config.rs
|
||||
+++ b/compiler/rustc_session/src/config.rs
|
||||
@@ -1830,7 +1830,7 @@ pub fn parse_target_triple(
|
||||
@@ -1832,7 +1832,7 @@ pub fn parse_target_triple(
|
||||
early_error(error_format, &format!("target file {path:?} does not exist"))
|
||||
})
|
||||
}
|
||||
|
@ -37,11 +37,11 @@ index 8bb3878fbbb4..969247f5d4fa 100644
|
|||
}
|
||||
}
|
||||
diff --git a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||
index 765803d16928..75e6df9a8f3a 100644
|
||||
index 73e536a7e4d9..af48d437533c 100644
|
||||
--- a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||
@@ -9,7 +9,7 @@ pub fn target() -> Target {
|
||||
base.stack_probes = StackProbeType::Call;
|
||||
base.stack_probes = StackProbeType::X86;
|
||||
|
||||
Target {
|
||||
- llvm_target: "i686-unknown-linux-gnu".into(),
|
||||
|
@ -50,10 +50,10 @@ index 765803d16928..75e6df9a8f3a 100644
|
|||
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
||||
f64:32:64-f80:32-n8:16:32-S128"
|
||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||
index dc16739bd560..3d8bbc0b1ff7 100644
|
||||
index 8909cf33af91..e5b5bce4c290 100644
|
||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||
@@ -2726,6 +2726,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
@@ -2876,6 +2876,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
Ok(TargetTriple::TargetJson { path_for_rustdoc: canonicalized_path, triple, contents })
|
||||
}
|
||||
|
||||
|
@ -70,10 +70,10 @@ index dc16739bd560..3d8bbc0b1ff7 100644
|
|||
///
|
||||
/// If this target is a path, the file name (without extension) is returned.
|
||||
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
index 956be0353fa3..3f133efef343 100644
|
||||
index a91ab365b668..d605eb9ccf81 100644
|
||||
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
@@ -15,7 +15,7 @@ pub fn target() -> Target {
|
||||
@@ -14,7 +14,7 @@ pub fn target() -> Target {
|
||||
| SanitizerSet::THREAD;
|
||||
|
||||
Target {
|
||||
|
|
|
@ -9,7 +9,7 @@ We don't ship rust-lld.
|
|||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_target/src/spec/wasm_base.rs b/compiler/rustc_target/src/spec/wasm_base.rs
|
||||
index 28a07701eae7..e746fed1f0fe 100644
|
||||
index 528a84a8b37c..f8af062bc2b1 100644
|
||||
--- a/compiler/rustc_target/src/spec/wasm_base.rs
|
||||
+++ b/compiler/rustc_target/src/spec/wasm_base.rs
|
||||
@@ -89,8 +89,7 @@ macro_rules! args {
|
||||
|
@ -19,6 +19,6 @@ index 28a07701eae7..e746fed1f0fe 100644
|
|||
- // we use the LLD shipped with the Rust toolchain by default
|
||||
- linker: Some("rust-lld".into()),
|
||||
+ linker: Some("wasm-ld".into()),
|
||||
lld_flavor: LldFlavor::Wasm,
|
||||
linker_is_gnu: false,
|
||||
linker_flavor: LinkerFlavor::WasmLld(Cc::No),
|
||||
|
||||
pre_link_args,
|
||||
|
|
|
@ -17,7 +17,7 @@ highmem=1
|
|||
pkgbase=rust
|
||||
pkgname=(rust rust-src)
|
||||
epoch=1
|
||||
pkgver=1.65.0
|
||||
pkgver=1.66.0
|
||||
pkgrel=1.1
|
||||
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
||||
url=https://www.rust-lang.org/
|
||||
|
@ -35,12 +35,12 @@ source=(
|
|||
0002-compiler-Change-LLVM-targets.patch
|
||||
0003-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||
)
|
||||
sha256sums=('5828bb67f677eabf8c384020582b0ce7af884e1c84389484f7f8d00dd82c0038'
|
||||
sha256sums=('3b3cd3ea5a82a266e75d0b35f0b54c16021576d9eb78d384052175a772935a48'
|
||||
'SKIP'
|
||||
'c901a9bb036c29ca092f7dbc8b447efdd9aa1044a902a88f9d024cb22681dc19'
|
||||
'c88389c7ac2ce832c39450171af8fbd9bfe26f8e683f28b776b492c972fda359'
|
||||
'5fd1d52cb58c31fb6b0179eec41f5234523dfce799c8f895b1d2d663ca0573db'
|
||||
'27cc0fa1ef37c1ced77f62c6b0de7590b8aa88256dced3f9b87adb7c488ffa5e')
|
||||
'874c96cb43a5cc1170674771705deb1c72e95ec5f6ede860cd658111db3cda48'
|
||||
'4a4ff5c294acc0b1ca800856218770f6330a878acee72193aa456d82846a8a28'
|
||||
'c9abbbc8e3a97b0e43fa5f948ae4df51320d9cc5243b5d0c575470271932f783')
|
||||
validpgpkeys=(108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||
474E22316ABF4785A88C6E8EA2C794A986419D8A) # Tom Stellard <tstellar@redhat.com>
|
||||
|
||||
|
|
Loading…
Reference in a new issue