mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/qt5-webengine to 5.7.1-1
This commit is contained in:
parent
e5fcea5223
commit
f88b0bd1d0
4 changed files with 12 additions and 107 deletions
|
@ -9,9 +9,9 @@
|
|||
buildarch=12
|
||||
|
||||
pkgname=qt5-webengine
|
||||
_qtver=5.7.0
|
||||
_qtver=5.7.1
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=7
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL3' 'FDL' 'custom')
|
||||
|
@ -22,18 +22,13 @@ makedepends=('python2' 'git' 'gperf' 'jsoncpp')
|
|||
groups=('qt' 'qt5')
|
||||
_pkgfqn="${pkgname/5-/}-opensource-src-${_qtver}"
|
||||
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz" qt5-webengine-nss.patch
|
||||
qt5-webengine-fno-delete-null-pointer-checks.patch qt5-webengine-fno-delete-null-pointer-checks-2.patch
|
||||
qt5-webengine-glibc2.24.patch::"https://github.com/qt/qtwebengine-chromium/commit/b12ffcd4.patch"
|
||||
qtwebengine-opensource-src-5.6.0-beta-no-neon.patch
|
||||
qtwebengine-5.7.0-icu58.patch
|
||||
system-ffmpeg.patch)
|
||||
|
||||
md5sums=('937f64886fbcb038d6fa4b44ae80cbeb'
|
||||
md5sums=('c90fba515fb33c091904fe2cadbb345a'
|
||||
'2a1610b34204102938a24154a52e5571'
|
||||
'5671a16fef65152928789bffd1f7cf24'
|
||||
'8145ce05fb86e762f012ca1b56f718fe'
|
||||
'753154df82838d19a7629d56cec7b649'
|
||||
'5bf00425cacab1a6580c46b9ac8b57ac'
|
||||
'123d4d0d7db7473649ff2b5650330cc4'
|
||||
'c2ffb0073e6f67a0a77a8fe39f9e9859'
|
||||
'9f79b14f7c5ff603c1fcd87f37a8904f')
|
||||
|
||||
|
@ -51,16 +46,7 @@ prepare() {
|
|||
# Fix build with ICU 58 (gentoo)
|
||||
patch -p1 -i "$srcdir"/qtwebengine-5.7.0-icu58.patch
|
||||
|
||||
# Workaround for v8 segfaults with GCC 6
|
||||
patch -p1 -i "$srcdir"/qt5-webengine-fno-delete-null-pointer-checks.patch
|
||||
cd src/3rdparty
|
||||
patch -p1 -i "$srcdir"/qt5-webengine-fno-delete-null-pointer-checks-2.patch
|
||||
|
||||
# Fix segfault with glibc 2.24
|
||||
patch -p1 -i "$srcdir"/qt5-webengine-glibc2.24.patch
|
||||
|
||||
cd ../..
|
||||
[[ $CARCH == "armv7h" ]] && patch -p1 -i ../qtwebengine-opensource-src-5.6.0-beta-no-neon.patch
|
||||
[[ $CARCH == "armv7h" ]] && patch -p0 -i ../qtwebengine-opensource-src-5.6.0-beta-no-neon.patch
|
||||
patch -p1 -i ../system-ffmpeg.patch
|
||||
}
|
||||
|
||||
|
|
|
@ -1,50 +0,0 @@
|
|||
From ba36da6c1f59da7687f6924cc558105dcd1c44dc Mon Sep 17 00:00:00 2001
|
||||
From: Allan Sandfeld Jensen <allan.jensen@theqtcompany.com>
|
||||
Date: Fri, 10 Jun 2016 13:26:22 +0200
|
||||
Subject: [PATCH] Use -fno-delete-null-pointer-checks with gcc 6
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
V8 is not safe for removing null pointer checks. Until it is, we need
|
||||
to disable optimizations in GCC that assume it is not doing something
|
||||
wrong.
|
||||
|
||||
This patch only enables it for v8, and requires it to be activated
|
||||
by qtwebengine.
|
||||
|
||||
Change-Id: I9da15ecf85719f211ba921a620e9d195eff26178
|
||||
Task-number: QTBUG-53956
|
||||
Reviewed-by: Michael Brüning <michael.bruning@qt.io>
|
||||
---
|
||||
chromium/v8/build/toolchain.gypi | 7 +++++++
|
||||
1 file changed, 7 insertions(+)
|
||||
|
||||
diff --git a/chromium/v8/build/toolchain.gypi b/chromium/v8/build/toolchain.gypi
|
||||
index 8a26cc2..2dd4a50 100644
|
||||
--- a/chromium/v8/build/toolchain.gypi
|
||||
+++ b/chromium/v8/build/toolchain.gypi
|
||||
@@ -72,6 +72,10 @@
|
||||
# Some versions of GCC 4.5 seem to need -fno-strict-aliasing.
|
||||
'v8_no_strict_aliasing%': 0,
|
||||
|
||||
+ # V8 needs support for illegal null this pointers, and must disable
|
||||
+ # optimizations in GCC 6 that relies on correct behavior.
|
||||
+ 'v8_no_delete_null_pointer_checks%': 0,
|
||||
+
|
||||
# Chrome needs this definition unconditionally. For standalone V8 builds,
|
||||
# it's handled in build/standalone.gypi.
|
||||
'want_separate_host_toolset%': 1,
|
||||
@@ -1066,6 +1070,9 @@
|
||||
[ 'v8_no_strict_aliasing==1', {
|
||||
'cflags': [ '-fno-strict-aliasing' ],
|
||||
}],
|
||||
+ [ 'v8_no_delete_null_pointer_checks==1', {
|
||||
+ 'cflags_cc': [ '-fno-delete-null-pointer-checks' ],
|
||||
+ }],
|
||||
], # conditions
|
||||
}],
|
||||
['OS=="solaris"', {
|
||||
--
|
||||
2.8.3
|
||||
|
|
@ -1,27 +0,0 @@
|
|||
From 5133f095bea2d147e86b99eacaa48363d08db35b Mon Sep 17 00:00:00 2001
|
||||
From: Allan Sandfeld Jensen <allan.jensen@theqtcompany.com>
|
||||
Date: Fri, 10 Jun 2016 14:46:24 +0200
|
||||
Subject: [PATCH] Enable -fno_delete_null_pointer_checks on V8 for G++ 6
|
||||
|
||||
Detect g++ 6 and disable null pointer check optimizations on v8.
|
||||
|
||||
Change-Id: I5064823af3784786d455ce86592b5e65c1020f21
|
||||
Task-number: QTBUG-53956
|
||||
---
|
||||
|
||||
diff --git a/src/core/config/linux.pri b/src/core/config/linux.pri
|
||||
index 8854a4b..b579e2a 100644
|
||||
--- a/src/core/config/linux.pri
|
||||
+++ b/src/core/config/linux.pri
|
||||
@@ -29,6 +29,8 @@ use?(nss) {
|
||||
use_openssl_certs=1
|
||||
}
|
||||
|
||||
+gcc:!clang: greaterThan(QT_GCC_MAJOR_VERSION, 5): GYP_CONFIG += v8_no_delete_null_pointer_checks=1
|
||||
+
|
||||
contains(QT_CONFIG, system-zlib): use?(system_minizip): GYP_CONFIG += use_system_zlib=1
|
||||
contains(QT_CONFIG, system-png): GYP_CONFIG += use_system_libpng=1
|
||||
contains(QT_CONFIG, system-jpeg): GYP_CONFIG += use_system_libjpeg=1
|
||||
--
|
||||
2.8.3
|
||||
|
|
@ -1,15 +1,11 @@
|
|||
diff -ur qtwebengine-opensource-src-5.6.0-beta/src/core/gyp_run.pro qtwebengine-opensource-src-5.6.0-beta-no-neon/src/core/gyp_run.pro
|
||||
--- qtwebengine-opensource-src-5.6.0-beta/src/core/gyp_run.pro 2015-12-14 16:27:24.000000000 +0100
|
||||
+++ qtwebengine-opensource-src-5.6.0-beta-no-neon/src/core/gyp_run.pro 2016-01-10 17:48:45.689954050 +0100
|
||||
@@ -74,7 +74,10 @@
|
||||
--- src/core/gyp_run.pro.orig 2016-12-17 09:08:25.447058042 -0700
|
||||
+++ src/core/gyp_run.pro 2016-12-17 09:11:34.499737847 -0700
|
||||
@@ -80,7 +80,7 @@
|
||||
# we use arm_neon_optional for ARMv7 and newer and let chromium decide
|
||||
# about the mfpu option.
|
||||
contains(MFPU, "neon")|contains(MFPU, "neon-vfpv4"): GYP_CONFIG += arm_fpu=\"$$MFPU\" arm_neon=1
|
||||
contains(MFPU, ".*neon.*"): GYP_CONFIG += arm_fpu=\"$$MFPU\" arm_neon=1
|
||||
- else:!lessThan(MARMV, 7): GYP_CONFIG += arm_neon=0 arm_neon_optional=1
|
||||
+ # Disable NEON entirely for now, because it fails to build:
|
||||
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1282495
|
||||
+ # (This line was also missing the required arm_fpu flag, which I added.)
|
||||
+ # else:!lessThan(MARMV, 7): GYP_CONFIG += arm_fpu=\"$$MFPU\" arm_neon=0 arm_neon_optional=1
|
||||
+ # else:!lessThan(MARMV, 7): GYP_CONFIG += arm_neon=0 arm_neon_optional=1
|
||||
else: GYP_CONFIG += arm_fpu=\"$$MFPU\" arm_neon=0 arm_neon_optional=0
|
||||
}
|
||||
|
||||
} else {
|
||||
# Chromium defaults to arm_neon=1, Qt does not.
|
||||
|
|
Loading…
Reference in a new issue