extra/cantor to 18.08.1-1

This commit is contained in:
Kevin Mihelich 2018-09-06 12:22:42 +00:00
parent c7b6d9fff2
commit f88b7235fa
4 changed files with 5 additions and 98 deletions

View file

@ -7,8 +7,8 @@
# - drop julia make/optdepends, doesn't build on ARM
pkgname=cantor
pkgver=18.08.0
pkgrel=5
pkgver=18.08.1
pkgrel=1
pkgdesc="KDE Frontend to Mathematical Software"
url="https://kde.org/applications/education/cantor/"
arch=(x86_64)
@ -23,25 +23,14 @@ optdepends=('maxima: Maxima backend'
'python: Python 3 backend'
'python2: Python 2 backend'
'sagemath: SageMath backend')
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig}
cantor-julia.patch::"https://cgit.kde.org/cantor.git/patch/?id=90b001d1" cantor-julia-0.7.patch sage-8.3.patch cantor-julia-1.0.patch)
sha256sums=('be6167ec88504091e9fa9914e0bd1fbb13637fb2b2b228c9274225db6dc85823'
'SKIP'
'366e1a734a968c4a933e91342308e4d18108c1bc023572848747ca6a2ec656f7'
'cf031eb1891a97f964c9147a4ff4d7e69f3821eee8fb5dab0693c6483dacd4ee'
'78c90097749e53433641b3acfd637b2aaa12f04c03a304b71c2cc5a5672cb4de'
'81b6752473657318d91e748c6c1799cdd285037fa1bdfad29d401cacf9d98f7b')
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('6b6dbe616606f4160987d4eef578a2a325263a723e3c96714170d3135cf69b15'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
prepare() {
mkdir -p build
cd $pkgname-$pkgver
patch -p1 -i ../cantor-julia.patch # Fix julia backend build
patch -p1 -i ../cantor-julia-0.7.patch # support julia>=0.7
patch -p1 -i ../cantor-julia-1.0.patch # support julia>=1.0
patch -p1 -i ../sage-8.3.patch # fix sagemath backend with 8.3
}
build() {

View file

@ -1,36 +0,0 @@
diff --git a/cmake/FindJulia.cmake b/cmake/FindJulia.cmake
index 77c9f7f8..2d4e1f6a 100644
--- a/cmake/FindJulia.cmake
+++ b/cmake/FindJulia.cmake
@@ -1,7 +1,7 @@
if(JULIA_FOUND)
return()
endif()
-
+
# Find julia executable
find_program(JULIA_EXECUTABLE julia DOC "Julia executable")
@@ -31,8 +31,14 @@ endif()
#
# Julia includes
#
+if(${JULIA_VERSION_STRING} VERSION_LESS 0.7.0)
+ set(JULIA_BINDIR "JULIA_HOME")
+else()
+ set(JULIA_BINDIR "Sys.BINDIR")
+endif()
+
execute_process(
- COMMAND ${JULIA_EXECUTABLE} -E "joinpath(match(r\"(.*)(bin)\",JULIA_HOME).captures[1],\"include\",\"julia\")"
+ COMMAND ${JULIA_EXECUTABLE} -E "joinpath(match(r\"(.*)(bin)\",${JULIA_BINDIR}).captures[1],\"include\",\"julia\")"
OUTPUT_VARIABLE JULIA_INCLUDE_DIRS
# COMMAND ${JULIA_EXECUTABLE} -E "abspath(joinpath(JULIA_HOME, \"../..\", \"src\"))"
# OUTPUT_VARIABLE JULIA_INCLUDE_DIRS
@@ -80,4 +86,4 @@ find_package_handle_standard_args(
REQUIRED_VARS JULIA_LIBRARY JULIA_LIBRARY_DIR JULIA_INCLUDE_DIRS
VERSION_VAR JULIA_VERSION_STRING
FAIL_MESSAGE "Julia not found"
-)
\ No newline at end of file
+)

View file

@ -1,33 +0,0 @@
diff --git a/cmake/FindJulia.cmake b/cmake/FindJulia.cmake
index 2d4e1f6a..7f3d7a82 100644
--- a/cmake/FindJulia.cmake
+++ b/cmake/FindJulia.cmake
@@ -61,8 +61,14 @@ endif()
#
# Julia library location
#
+if(${JULIA_VERSION_STRING} VERSION_LESS 0.7.0)
+ set(JULIA_LIBDL_COMMAND "abspath(dirname(Libdl.dlpath(\"libjulia\")))")
+else()
+ set(JULIA_LIBDL_COMMAND "using Libdl; abspath(dirname(Libdl.dlpath(\"libjulia\")))")
+endif()
+
execute_process(
- COMMAND ${JULIA_EXECUTABLE} -E "abspath(dirname(Libdl.dlpath(\"libjulia\")))"
+ COMMAND ${JULIA_EXECUTABLE} -E ${JULIA_LIBDL_COMMAND}
OUTPUT_VARIABLE JULIA_LIBRARY_DIR
RESULT_VARIABLE RESULT
)
diff --git a/src/backends/julia/juliaserver/juliaserver.cpp b/src/backends/julia/juliaserver/juliaserver.cpp
index 5369fe50..0a1e8889 100644
--- a/src/backends/julia/juliaserver/juliaserver.cpp
+++ b/src/backends/julia/juliaserver/juliaserver.cpp
@@ -43,7 +43,7 @@ JuliaServer::~JuliaServer()
void JuliaServer::login(const QString &path) const
{
-#if JULIA_VERSION_MINOR > 5
+#if (JULIA_VERSION_MAJOR > 0 || JULIA_VERSION_MINOR > 5)
Q_UNUSED(path)
jl_init();
#else

View file

@ -1,13 +0,0 @@
diff --git a/src/backends/sage/sagesession.cpp b/src/backends/sage/sagesession.cpp
index c2973a8a..f23914ad 100644
--- a/src/backends/sage/sagesession.cpp
+++ b/src/backends/sage/sagesession.cpp
@@ -118,7 +118,7 @@ void SageSession::login()
m_process=new KPtyProcess(this);
updateSageVersion();
const QString& sageExecFile = SageSettings::self()->path().toLocalFile();
- if (m_sageVersion >= SageSession::VersionInfo(8, 3))
+ if (m_sageVersion >= SageSession::VersionInfo(8, 4))
m_process->setProgram(sageExecFile, QStringList() << QLatin1String("--simple-prompt"));
else
{