mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/qtractor: fix
This commit is contained in:
parent
c5db312f31
commit
f955c5c041
2 changed files with 3 additions and 77 deletions
|
@ -1,64 +0,0 @@
|
|||
Description: Definte generic atomic function to prevent FTBFS on most
|
||||
architectures.
|
||||
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=725611
|
||||
Author: Alessio Treglia <alessio@debian.org>
|
||||
---
|
||||
src/qtractorAtomic.h | 40 ++++++++++++----------------------------
|
||||
1 file changed, 12 insertions(+), 28 deletions(-)
|
||||
|
||||
--- qtractor.orig/src/qtractorAtomic.h
|
||||
+++ qtractor/src/qtractorAtomic.h
|
||||
@@ -35,33 +35,7 @@ extern "C" {
|
||||
|
||||
#if defined(__GNUC__)
|
||||
|
||||
-#if defined(powerpc) || defined(__ppc__)
|
||||
-
|
||||
-static inline int ATOMIC_CAS1 (
|
||||
- volatile int *pAddr, int iOldValue, int iNewValue )
|
||||
-{
|
||||
- register int result;
|
||||
- asm volatile (
|
||||
- "# ATOMIC_CAS1 \n"
|
||||
- " lwarx r0, 0, %1 \n"
|
||||
- " cmpw r0, %2 \n"
|
||||
- " bne- 1f \n"
|
||||
- " sync \n"
|
||||
- " stwcx. %3, 0, %1 \n"
|
||||
- " bne- 1f \n"
|
||||
- " li %0, 1 \n"
|
||||
- " b 2f \n"
|
||||
- "1: \n"
|
||||
- " li %0, 0 \n"
|
||||
- "2: \n"
|
||||
- : "=r" (result)
|
||||
- : "r" (pValue), "r" (iOldValue), "r" (iNewValue)
|
||||
- : "r0"
|
||||
- );
|
||||
- return result;
|
||||
-}
|
||||
-
|
||||
-#elif defined(__i386__) || defined(__x86_64__)
|
||||
+#if defined(__i386__) || defined(__x86_64__)
|
||||
|
||||
static inline int ATOMIC_CAS1 (
|
||||
volatile int *pValue, int iOldValue, int iNewValue )
|
||||
@@ -79,7 +53,17 @@ static inline int ATOMIC_CAS1 (
|
||||
}
|
||||
|
||||
#else
|
||||
-# error "qtractorAtomic.h: unsupported target compiler processor (GNUC)."
|
||||
+
|
||||
+#if QT_VERSION < 0x040400
|
||||
+
|
||||
+static inline int ATOMIC_CAS1 (
|
||||
+ volatile int *pAddr, int iOldValue, int iNewValue )
|
||||
+{
|
||||
+ return q_atomic_test_and_set_int(pAddr, iOldValue, iNewValue);
|
||||
+}
|
||||
+
|
||||
+#endif
|
||||
+
|
||||
#endif
|
||||
|
||||
#elif defined(WIN32) || defined(__WIN32__) || defined(_WIN32)
|
|
@ -4,7 +4,6 @@
|
|||
# Contributor: Philipp Überbacher <hollunder at gmx dot at>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix building on ARM
|
||||
# - set -DCONFIG_SSE=OFF
|
||||
|
||||
pkgname=qtractor
|
||||
|
@ -24,18 +23,9 @@ optdepends=(
|
|||
'qt6-wayland: for native wayland support'
|
||||
)
|
||||
provides=('dssi-host' 'ladspa-host' 'lv2-host' 'vst-host' 'vst3-host')
|
||||
source=("https://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
|
||||
'04-q_atomic_ftbfs.patch')
|
||||
sha512sums=('fe57cc82d072ed49569441bb9f25f5233c0d7a6e7f0958a84247c8896741f2e4b83067e69d8e7999ccd9e68002b0e6ba4dc084674286952c17d472ae9f507bbd'
|
||||
'fe0e4d6adcd0eb64c39a194f16c026e6505d5f3b0537b7724ed9060443340559cc12a57665aec3e2a4d4c71ea05b1e575508cae334a8ca3a16543b5fdf55b4bf')
|
||||
b2sums=('6ccf22ccc21ad36aecff63a16de9e3bb2ae19ba6fd7475432c3cd1e37ce2468f837a68c160ceec0f9c7ec9931e1fc1614c3a84cd0dd34078d1e227868338c021'
|
||||
'ab86331b8cdc583cbe740c23e2a47280205cd20e80f23de1d8e189d6f2ea9a651caad14188656e5f85357cb444f9a51544871b2603ad54748db555ab6a9f4124')
|
||||
|
||||
prepare() {
|
||||
cd "${pkgname}-${pkgver}"
|
||||
|
||||
patch -p1 -i ../04-q_atomic_ftbfs.patch
|
||||
}
|
||||
source=("https://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
|
||||
sha512sums=('fe57cc82d072ed49569441bb9f25f5233c0d7a6e7f0958a84247c8896741f2e4b83067e69d8e7999ccd9e68002b0e6ba4dc084674286952c17d472ae9f507bbd')
|
||||
b2sums=('6ccf22ccc21ad36aecff63a16de9e3bb2ae19ba6fd7475432c3cd1e37ce2468f837a68c160ceec0f9c7ec9931e1fc1614c3a84cd0dd34078d1e227868338c021')
|
||||
|
||||
build() {
|
||||
cd "${pkgname}-${pkgver}"
|
||||
|
|
Loading…
Reference in a new issue