extra/qt5-doc: patch update

This commit is contained in:
Kevin Mihelich 2017-07-04 19:32:13 +00:00
parent 9a559bbd4c
commit f99963998d
2 changed files with 42 additions and 56 deletions

View file

@ -1,72 +1,58 @@
From 581e99bdd47340b9b3d41cffd51d8ac03422def6 Mon Sep 17 00:00:00 2001
From 95504f7bfc9c85d3148cec9c46084a8ab5e6ce8d Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 8 Jun 2017 20:41:08 -0600
Date: Tue, 4 Jul 2017 11:54:39 -0600
Subject: [PATCH] ARM toolchain fixes
---
chromium/build/toolchain/linux/BUILD.gn | 20 +++++++++++++++++++-
chromium/tools/gn/args.cc | 3 +++
2 files changed, 22 insertions(+), 1 deletion(-)
chromium/build/toolchain/linux/BUILD.gn | 24 ++++++++++--------------
1 file changed, 10 insertions(+), 14 deletions(-)
diff --git a/chromium/build/toolchain/linux/BUILD.gn b/chromium/build/toolchain/linux/BUILD.gn
index 548722d393..8a24c50f79 100644
index 86cd7dabc6..4b1e73b1ac 100644
--- a/chromium/build/toolchain/linux/BUILD.gn
+++ b/chromium/build/toolchain/linux/BUILD.gn
@@ -22,7 +22,7 @@ clang_toolchain("clang_arm64") {
@@ -22,15 +22,13 @@ clang_toolchain("clang_arm64") {
}
gcc_toolchain("arm64") {
- toolprefix = "aarch64-linux-gnu-"
-
- cc = "${toolprefix}gcc"
- cxx = "${toolprefix}g++"
+ cc = "gcc"
+ cxx = "g++"
- ar = "${toolprefix}ar"
+ ar = "ar"
ld = cxx
- readelf = "${toolprefix}readelf"
- nm = "${toolprefix}nm"
+ readelf = "readelf"
+ nm = "nm"
toolchain_args = {
current_cpu = "arm64"
@@ -40,15 +38,13 @@ gcc_toolchain("arm64") {
}
gcc_toolchain("arm") {
- toolprefix = "arm-linux-gnueabihf-"
+ toolprefix = ""
-
- cc = "${toolprefix}gcc"
- cxx = "${toolprefix}g++"
+ cc = "gcc"
+ cxx = "g++"
cc = "${toolprefix}gcc"
cxx = "${toolprefix}g++"
@@ -39,6 +39,24 @@ gcc_toolchain("arm") {
}
}
- ar = "${toolprefix}ar"
+ ar = "ar"
ld = cxx
- readelf = "${toolprefix}readelf"
- nm = "${toolprefix}nm"
+ readelf = "readelf"
+ nm = "nm"
+gcc_toolchain("arm64") {
+ toolprefix = ""
+
+ cc = "${toolprefix}gcc"
+ cxx = "${toolprefix}g++"
+
+ ar = "${toolprefix}ar"
+ ld = cxx
+ readelf = "${toolprefix}readelf"
+ nm = "${toolprefix}nm"
+
+ toolchain_args = {
+ current_cpu = "arm64"
+ current_os = "linux"
+ is_clang = false
+ }
+}
+
clang_toolchain("clang_x86") {
toolchain_args = {
current_cpu = "x86"
diff --git a/chromium/tools/gn/args.cc b/chromium/tools/gn/args.cc
index 7285d7a538..54703e1760 100644
--- a/chromium/tools/gn/args.cc
+++ b/chromium/tools/gn/args.cc
@@ -266,6 +266,7 @@ void Args::SetSystemVarsLocked(Scope* dest) const {
static const char kX86[] = "x86";
static const char kX64[] = "x64";
static const char kArm[] = "arm";
+ static const char kArm64[] = "arm64";
static const char kMips[] = "mipsel";
static const char kS390X[] = "s390x";
static const char kPPC64[] = "ppc64";
@@ -280,6 +281,8 @@ void Args::SetSystemVarsLocked(Scope* dest) const {
arch = kX64;
else if (os_arch.substr(0, 3) == "arm")
arch = kArm;
+ else if (os_arch == "aarch64")
+ arch = kArm64;
else if (os_arch == "mips")
arch = kMips;
else if (os_arch == "s390x")
current_cpu = "arm"
--
2.12.0
2.13.2

View file

@ -21,7 +21,7 @@ _pkgfqn="qt-everywhere-opensource-src-${_qtver}"
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/single/${_pkgfqn}.tar.xz"
'0001-ARM-toolchain-fixes.patch')
sha256sums=('7b41a37d4fe5e120cdb7114862c0153f86c07abbec8db71500443d2ce0c89795'
'897c5960db849211f525039d386e21692cad8a5ba056f3e22440146225c20df8')
'8202b09a1caa82538a2eacd79b62b61d8661c65cdfb275560d231aa31a362b12')
prepare() {
cd ${_pkgfqn}