mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/rust to 1.56.0-1
This commit is contained in:
parent
52a677442c
commit
f9d131a313
4 changed files with 14 additions and 14 deletions
|
@ -8,10 +8,10 @@ Subject: [PATCH] bootstrap: Change libexec dir
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
||||
index c37763243c0..889bcb7c081 100644
|
||||
index d4875cfe1b06..798c45506373 100644
|
||||
--- a/src/bootstrap/dist.rs
|
||||
+++ b/src/bootstrap/dist.rs
|
||||
@@ -992,7 +992,7 @@ fn run(self, builder: &Builder<'_>) -> GeneratedTarball {
|
||||
@@ -1004,7 +1004,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
||||
let dirent = dirent.expect("read dir entry");
|
||||
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
||||
|
|
|
@ -8,7 +8,7 @@ Subject: [PATCH] cargo: Change libexec dir
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/cargo/ops/registry/auth.rs b/src/cargo/ops/registry/auth.rs
|
||||
index d10b1988e..b58e05857 100644
|
||||
index d10b1988e920..b58e05857233 100644
|
||||
--- a/src/cargo/ops/registry/auth.rs
|
||||
+++ b/src/cargo/ops/registry/auth.rs
|
||||
@@ -223,7 +223,7 @@ fn sysroot_credential(
|
||||
|
|
|
@ -24,10 +24,10 @@ targets, as things break when this is done:
|
|||
4 files changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
||||
index 2d7f5f9b321..8213c10964c 100644
|
||||
index fdedb7e6a4af..c12568e77d83 100644
|
||||
--- a/compiler/rustc_session/src/config.rs
|
||||
+++ b/compiler/rustc_session/src/config.rs
|
||||
@@ -1534,7 +1534,7 @@ pub fn parse_target_triple(
|
||||
@@ -1512,7 +1512,7 @@ pub fn parse_target_triple(
|
||||
early_error(error_format, &format!("target file {:?} does not exist", path))
|
||||
})
|
||||
}
|
||||
|
@ -37,7 +37,7 @@ index 2d7f5f9b321..8213c10964c 100644
|
|||
}
|
||||
}
|
||||
diff --git a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||
index 165505ee731..00a7f5c2f8c 100644
|
||||
index 165505ee7313..00a7f5c2f8c1 100644
|
||||
--- a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
||||
@@ -9,7 +9,7 @@ pub fn target() -> Target {
|
||||
|
@ -50,10 +50,10 @@ index 165505ee731..00a7f5c2f8c 100644
|
|||
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
||||
f64:32:64-f80:32-n8:16:32-S128"
|
||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||
index 0185132ee36..b825fcb7260 100644
|
||||
index 273221360b8b..4bbfad8441f3 100644
|
||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||
@@ -2280,6 +2280,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
@@ -2296,6 +2296,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
Ok(TargetTriple::TargetPath(canonicalized_path))
|
||||
}
|
||||
|
||||
|
@ -70,7 +70,7 @@ index 0185132ee36..b825fcb7260 100644
|
|||
///
|
||||
/// If this target is a path, the file name (without extension) is returned.
|
||||
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
index 085079e06e5..2dfa6a040b1 100644
|
||||
index 085079e06e57..2dfa6a040b10 100644
|
||||
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
@@ -11,7 +11,7 @@ pub fn target() -> Target {
|
||||
|
|
|
@ -16,7 +16,7 @@ highmem=1
|
|||
|
||||
pkgname=('rust' 'rust-docs')
|
||||
epoch=1
|
||||
pkgver=1.55.0
|
||||
pkgver=1.56.0
|
||||
pkgrel=1
|
||||
|
||||
_llvm_ver=12.0.1
|
||||
|
@ -39,13 +39,13 @@ source=(
|
|||
0001-cargo-Change-libexec-dir.patch
|
||||
0002-compiler-Change-LLVM-targets.patch
|
||||
)
|
||||
sha256sums=('b2379ac710f5f876ee3c3e03122fe33098d6765d371cac6c31b1b6fc8e43821e'
|
||||
sha256sums=('cd0fd72d698deb3001c18e0f4bf8261d8f86420097eef94ca3a1fe047f2df43f'
|
||||
'SKIP'
|
||||
'b4c8d5f2a802332987c1c0a95b5afb35b1a66a96fe44add4e4ed4792c4cba0a4'
|
||||
'SKIP'
|
||||
'1259fd166de6289fb24e4ae09ebf1d18e10fc2777a8d6f90d9475c5d3aa6807b'
|
||||
'1833c3b5f8262b598115d13f08e2dcba792536768a2371869870e26244971112'
|
||||
'2d91730203d0e58b90365e4e5041d2bdffd500f1f9e6457c7d6256d0e65f1ad9')
|
||||
'a2a8a7c6a5732f79cc92f81d3c8380589c4e2b9a996fb565bbefe42f66b62597'
|
||||
'0f8cfbe0387dd62909fe9cb9523223ae1c2319494e2caf5fa4d0592198631b3e'
|
||||
'977da945985dce4484ace8794cbc91241b1f3c27311c1a8b201231db6e1d19e5')
|
||||
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE' # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||
'474E22316ABF4785A88C6E8EA2C794A986419D8A' # Tom Stellard <tstellar@redhat.com>
|
||||
'B6C8F98282B944E3B0D5C2530FC3042E345AD05D') # Hans Wennborg <hans@chromium.org>
|
||||
|
|
Loading…
Reference in a new issue