mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/libreoffice-still to 7.2.5-4
This commit is contained in:
parent
a5c3aecf25
commit
f9da9c276e
2 changed files with 63 additions and 1 deletions
|
@ -0,0 +1,56 @@
|
|||
From 5fd5e42bf28a7910321c6b6d76257e7386839fbc Mon Sep 17 00:00:00 2001
|
||||
From: Michael Weghorn <m.weghorn@posteo.de>
|
||||
Date: Wed, 16 Feb 2022 13:38:47 +0100
|
||||
Subject: configure.ac: Update kf5 include/lib check to work with KF5 >= 5.91
|
||||
|
||||
The 'kcoreaddons_version.h' header was moved to the 'KCoreAddons'
|
||||
subdirectory in kcoreaddons commit
|
||||
|
||||
commit d971ba9bb27a3e8f18a116692fdf98c1729ac244
|
||||
Author: Ahmad Samir <a.samirh78@gmail.com>
|
||||
Date: Sat Jan 15 14:14:13 2022 +0200
|
||||
|
||||
Install kcoreaddons_version.h in /usr/include/KF5/KCoreAddons/
|
||||
|
||||
Instead of /usr/include/KF5/kcoreaddons_version.h.
|
||||
|
||||
For more details see:
|
||||
https://invent.kde.org/frameworks/kservice/-/merge_requests/79
|
||||
|
||||
GIT_SILENT
|
||||
|
||||
Adapt the KF5 check to check for the 'KFileWidget' header and
|
||||
the 'libKF5KIOFileWidgets.so' library instead.
|
||||
This is more exact anyway, since we require KIOFileWidgets,
|
||||
and the previous check didn't ensure that.
|
||||
(So in case only KF5CoreAddons but not KIOFileWidgets was installed,
|
||||
configure would previously pass, but the build fail.)
|
||||
|
||||
[1] https://invent.kde.org/frameworks/kcoreaddons/-/commit/d971ba9bb27a3e8f18a116692fdf98c1729ac244
|
||||
|
||||
Change-Id: I7ecf7f29dce85e1a6e6b0d4f2519fa37ab04ca84
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/129996
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
|
||||
---
|
||||
configure.ac | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 6acb3107cea3..4e84f9a33980 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -13017,8 +13017,8 @@ then
|
||||
kf5_libdirs="$kf5_libdirs /usr/lib64 /usr/lib64/kf5 /usr/lib64/kf5/devel"
|
||||
fi
|
||||
|
||||
- kf5_test_include="KF5/kcoreaddons_version.h"
|
||||
- kf5_test_library="libKF5CoreAddons.so"
|
||||
+ kf5_test_include="KF5/KIOFileWidgets/KFileWidget"
|
||||
+ kf5_test_library="libKF5KIOFileWidgets.so"
|
||||
kf5_libdirs="$qt5_libdir $kf5_libdirs"
|
||||
|
||||
dnl kf5 KDE4 support compatibility installed
|
||||
--
|
||||
cgit v1.2.1
|
||||
|
|
@ -19,7 +19,7 @@ pkgbase=libreoffice-still
|
|||
pkgname=('libreoffice-still-sdk' 'libreoffice-still')
|
||||
_LOver=7.2.5.2
|
||||
pkgver=7.2.5
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
arch=('x86_64')
|
||||
license=('LGPL3')
|
||||
url="https://www.libreoffice.org/"
|
||||
|
@ -68,6 +68,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
|
|||
make-pyuno-work-with-system-wide-module-install.diff
|
||||
mdds-2.0-and-orcus-0.17.diff
|
||||
0001_drop_the_SolarMutex_before_QApplication.patch
|
||||
0002_update_kf5_include_lib_check.patch
|
||||
soffice-template.desktop.in
|
||||
libreoffice-still.sh libreoffice-still.csh)
|
||||
noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
|
||||
|
@ -118,6 +119,7 @@ sha256sums=('67c1bfb059d433286b0252a915627b33af63bb5f4b6ec9509d13b9dd475512a7'
|
|||
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
|
||||
'fd73edaa09a48e2b2c4f4f32af68f1ef01cc181d49a5dfc1f65a5ad4883d7db8'
|
||||
'81a8551aaea0ab1750d36fb8bfbd04340a43eaab349a43c1384d21ef6504ab47'
|
||||
'1cc5aeac9b8e91786701727d97b58039afc3db3dbc7977a3651d3263240798b3'
|
||||
'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
|
||||
'cd1b25ff390e436c6bffa65c6e12382236e3ccbf8d3aae51b1b59bcaed79fd8a'
|
||||
'de20f36d45f0fecc2d94176dd3ec7226ab07fa8ffb9b0bc73c200349a9273de1')
|
||||
|
@ -147,6 +149,10 @@ prepare() {
|
|||
# fix crash on start - FS#73471
|
||||
patch -Np1 -i "${srcdir}"/0001_drop_the_SolarMutex_before_QApplication.patch
|
||||
|
||||
# fix kf5 chances
|
||||
# https://cgit.freedesktop.org/libreoffice/core/commit/?id=5fd5e42bf28a7910321c6b6d76257e7386839fbc
|
||||
patch -Np1 -i "${srcdir}"/0002_update_kf5_include_lib_check.patch
|
||||
|
||||
#use the CFLAGS but remove the LibO overridden ones
|
||||
for i in $CFLAGS; do
|
||||
case "$i" in
|
||||
|
|
Loading…
Reference in a new issue