mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/qt to 4.7.4-1
This commit is contained in:
parent
14e855d641
commit
f9e0348aa6
2 changed files with 24 additions and 90 deletions
|
@ -1,4 +1,4 @@
|
||||||
# $Id: PKGBUILD 126981 2011-06-09 07:23:06Z andrea $
|
# $Id: PKGBUILD 136831 2011-09-01 23:43:27Z andrea $
|
||||||
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
|
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
|
||||||
# Contributor: Pierre Schmitz <pierre@archlinux.de>
|
# Contributor: Pierre Schmitz <pierre@archlinux.de>
|
||||||
|
|
||||||
|
@ -7,13 +7,14 @@
|
||||||
# - disabled distcc, ccache - bad things happen
|
# - disabled distcc, ccache - bad things happen
|
||||||
# - don't use -no-neon on armv7
|
# - don't use -no-neon on armv7
|
||||||
# - make -j1 for v5, -j2 for v7 (pandaboard builder)
|
# - make -j1 for v5, -j2 for v7 (pandaboard builder)
|
||||||
|
# - added -fno-strict-volatile-bitfields to CXXFLAGS to fix ARM bug
|
||||||
|
|
||||||
plugrel=1
|
plugrel=1
|
||||||
|
|
||||||
pkgbase=qt
|
pkgbase=qt
|
||||||
pkgname=('qt' 'qt-private-headers')
|
pkgname=('qt' 'qt-private-headers')
|
||||||
pkgver=4.7.3
|
pkgver=4.7.4
|
||||||
pkgrel=3
|
pkgrel=1
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url='http://qt.nokia.com/'
|
url='http://qt.nokia.com/'
|
||||||
license=('GPL3' 'LGPL')
|
license=('GPL3' 'LGPL')
|
||||||
|
@ -25,14 +26,12 @@ options=('!libtool' '!distcc' '!ccache')
|
||||||
_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
|
_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
|
||||||
source=("ftp://ftp.qt.nokia.com/qt/source/${_pkgfqn}.tar.gz"
|
source=("ftp://ftp.qt.nokia.com/qt/source/${_pkgfqn}.tar.gz"
|
||||||
'assistant.desktop' 'designer.desktop' 'linguist.desktop'
|
'assistant.desktop' 'designer.desktop' 'linguist.desktop'
|
||||||
'qtconfig.desktop'
|
'qtconfig.desktop')
|
||||||
'qtbug-16292.patch')
|
md5sums=('ddf7d83f912cf1283aa066368464fa22'
|
||||||
md5sums=('49b96eefb1224cc529af6fe5608654fe'
|
|
||||||
'fc211414130ab2764132e7370f8e5caa'
|
'fc211414130ab2764132e7370f8e5caa'
|
||||||
'85179f5e0437514f8639957e1d8baf62'
|
'85179f5e0437514f8639957e1d8baf62'
|
||||||
'f11852b97583610f3dbb669ebc3e21bc'
|
'f11852b97583610f3dbb669ebc3e21bc'
|
||||||
'6b771c8a81dd90b45e8a79afa0e5bbfd'
|
'6b771c8a81dd90b45e8a79afa0e5bbfd')
|
||||||
'dc7ed8c2e8c68a175f7f05a34dccc937')
|
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
unset QMAKESPEC
|
unset QMAKESPEC
|
||||||
|
@ -41,13 +40,10 @@ build() {
|
||||||
export LD_LIBRARY_PATH=${QT4DIR}/lib:${LD_LIBRARY_PATH}
|
export LD_LIBRARY_PATH=${QT4DIR}/lib:${LD_LIBRARY_PATH}
|
||||||
|
|
||||||
# FS#24601
|
# FS#24601
|
||||||
export CXXFLAGS="$CXXFLAGS -fno-strict-aliasing"
|
export CXXFLAGS="$CXXFLAGS -fno-strict-aliasing -fno-strict-volatile-bitfields"
|
||||||
|
|
||||||
cd $srcdir/$_pkgfqn
|
cd $srcdir/$_pkgfqn
|
||||||
|
|
||||||
# Already fixed upstream
|
|
||||||
patch -p1 -i "${srcdir}"/qtbug-16292.patch
|
|
||||||
|
|
||||||
sed -i "s|-O2|$CXXFLAGS|" mkspecs/common/g++.conf
|
sed -i "s|-O2|$CXXFLAGS|" mkspecs/common/g++.conf
|
||||||
sed -i "/^QMAKE_RPATH/s| -Wl,-rpath,||g" mkspecs/common/g++.conf
|
sed -i "/^QMAKE_RPATH/s| -Wl,-rpath,||g" mkspecs/common/g++.conf
|
||||||
sed -i "/^QMAKE_LFLAGS\s/s|+=|+= $LDFLAGS|g" mkspecs/common/g++.conf
|
sed -i "/^QMAKE_LFLAGS\s/s|+=|+= $LDFLAGS|g" mkspecs/common/g++.conf
|
||||||
|
|
|
@ -1,62 +0,0 @@
|
||||||
From e340844bd614add505a39a3a6b915632476f6305 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Gabriel de Dietrich <gabriel.dietrich-de@nokia.com>
|
|
||||||
Date: Tue, 15 Feb 2011 11:19:26 +0100
|
|
||||||
Subject: [PATCH] Fix crash in KPackageKit
|
|
||||||
|
|
||||||
QTreeViewPrivate::itemHeight() may refer to an invalid QModelIndex
|
|
||||||
after calling QTreeView::indexRowSizeHint().
|
|
||||||
|
|
||||||
Same thing inside QTreeView::indexRowSizeHint(), since
|
|
||||||
QHeaderView::count() will call
|
|
||||||
QAbstractItemViewPrivate::executePostedLayout() which may invalidate
|
|
||||||
all the QModelIndex.
|
|
||||||
|
|
||||||
Reviewed-by: Olivier
|
|
||||||
Task-number: QTBUG-16292
|
|
||||||
---
|
|
||||||
src/gui/itemviews/qtreeview.cpp | 11 ++++++-----
|
|
||||||
1 files changed, 6 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/gui/itemviews/qtreeview.cpp b/src/gui/itemviews/qtreeview.cpp
|
|
||||||
index f1f3236..c0573bb 100644
|
|
||||||
--- a/src/gui/itemviews/qtreeview.cpp
|
|
||||||
+++ b/src/gui/itemviews/qtreeview.cpp
|
|
||||||
@@ -2753,6 +2753,7 @@ int QTreeView::indexRowSizeHint(const QModelIndex &index) const
|
|
||||||
|
|
||||||
int start = -1;
|
|
||||||
int end = -1;
|
|
||||||
+ int indexRow = index.row();
|
|
||||||
int count = d->header->count();
|
|
||||||
bool emptyHeader = (count == 0);
|
|
||||||
QModelIndex parent = index.parent();
|
|
||||||
@@ -2789,7 +2790,7 @@ int QTreeView::indexRowSizeHint(const QModelIndex &index) const
|
|
||||||
int logicalColumn = emptyHeader ? column : d->header->logicalIndex(column);
|
|
||||||
if (d->header->isSectionHidden(logicalColumn))
|
|
||||||
continue;
|
|
||||||
- QModelIndex idx = d->model->index(index.row(), logicalColumn, parent);
|
|
||||||
+ QModelIndex idx = d->model->index(indexRow, logicalColumn, parent);
|
|
||||||
if (idx.isValid()) {
|
|
||||||
QWidget *editor = d->editorForIndex(idx).editor;
|
|
||||||
if (editor && d->persistent.contains(editor)) {
|
|
||||||
@@ -3224,14 +3225,14 @@ int QTreeViewPrivate::itemHeight(int item) const
|
|
||||||
if (viewItems.isEmpty())
|
|
||||||
return 0;
|
|
||||||
const QModelIndex &index = viewItems.at(item).index;
|
|
||||||
+ if (!index.isValid())
|
|
||||||
+ return 0;
|
|
||||||
int height = viewItems.at(item).height;
|
|
||||||
- if (height <= 0 && index.isValid()) {
|
|
||||||
+ if (height <= 0) {
|
|
||||||
height = q_func()->indexRowSizeHint(index);
|
|
||||||
viewItems[item].height = height;
|
|
||||||
}
|
|
||||||
- if (!index.isValid() || height < 0)
|
|
||||||
- return 0;
|
|
||||||
- return height;
|
|
||||||
+ return qMax(height, 0);
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
||||||
--
|
|
||||||
1.6.1
|
|
||||||
|
|
Loading…
Reference in a new issue