mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
alarm/uboot-tools: fix
This commit is contained in:
parent
cc65131e0b
commit
fa34f28aa4
4 changed files with 264 additions and 0 deletions
120
alarm/uboot-tools/0001-rsa-Fix-build-with-OpenSSL-1.1.x.patch
Normal file
120
alarm/uboot-tools/0001-rsa-Fix-build-with-OpenSSL-1.1.x.patch
Normal file
|
@ -0,0 +1,120 @@
|
|||
From d3afa5f4808b051411b286029aeeb449d460ecc7 Mon Sep 17 00:00:00 2001
|
||||
From: Jelle van der Waa <jelle@vdwaa.nl>
|
||||
Date: Tue, 4 Apr 2017 23:59:48 +0200
|
||||
Subject: [PATCH 1/3] rsa: Fix build with OpenSSL 1.1.x
|
||||
|
||||
The rsa_st struct has been made opaque in 1.1.x, add forward compatible
|
||||
code to access the n, e, d members of rsa_struct.
|
||||
|
||||
EVP_MD_CTX_cleanup has been removed in 1.1.x and EVP_MD_CTX_reset should be
|
||||
called to reinitialise an already created structure.
|
||||
|
||||
Tested-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
lib/rsa/rsa-sign.c | 36 +++++++++++++++++++++++++++++-------
|
||||
1 file changed, 29 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/lib/rsa/rsa-sign.c b/lib/rsa/rsa-sign.c
|
||||
index 8c6637e328..5b7022d428 100644
|
||||
--- a/lib/rsa/rsa-sign.c
|
||||
+++ b/lib/rsa/rsa-sign.c
|
||||
@@ -15,11 +15,25 @@
|
||||
#include <openssl/ssl.h>
|
||||
#include <openssl/evp.h>
|
||||
#include <openssl/engine.h>
|
||||
+#include <openssl/bn.h>
|
||||
|
||||
#if OPENSSL_VERSION_NUMBER >= 0x10000000L
|
||||
#define HAVE_ERR_REMOVE_THREAD_STATE
|
||||
#endif
|
||||
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
|
||||
+static void RSA_get0_key(const RSA *r,
|
||||
+ const BIGNUM **n, const BIGNUM **e, const BIGNUM **d)
|
||||
+{
|
||||
+ if (n != NULL)
|
||||
+ *n = r->n;
|
||||
+ if (e != NULL)
|
||||
+ *e = r->e;
|
||||
+ if (d != NULL)
|
||||
+ *d = r->d;
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
static int rsa_err(const char *msg)
|
||||
{
|
||||
unsigned long sslErr = ERR_get_error();
|
||||
@@ -286,7 +300,7 @@ static int rsa_init(void)
|
||||
{
|
||||
int ret;
|
||||
|
||||
- ret = SSL_library_init();
|
||||
+ ret = OPENSSL_init_ssl(0, NULL);
|
||||
if (!ret) {
|
||||
fprintf(stderr, "Failure to init SSL library\n");
|
||||
return -1;
|
||||
@@ -409,7 +423,11 @@ static int rsa_sign_with_key(RSA *rsa, struct checksum_algo *checksum_algo,
|
||||
ret = rsa_err("Could not obtain signature");
|
||||
goto err_sign;
|
||||
}
|
||||
- EVP_MD_CTX_cleanup(context);
|
||||
+ #if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
|
||||
+ EVP_MD_CTX_cleanup(context);
|
||||
+ #else
|
||||
+ EVP_MD_CTX_reset(context);
|
||||
+ #endif
|
||||
EVP_MD_CTX_destroy(context);
|
||||
EVP_PKEY_free(key);
|
||||
|
||||
@@ -479,6 +497,7 @@ static int rsa_get_exponent(RSA *key, uint64_t *e)
|
||||
{
|
||||
int ret;
|
||||
BIGNUM *bn_te;
|
||||
+ const BIGNUM *key_e;
|
||||
uint64_t te;
|
||||
|
||||
ret = -EINVAL;
|
||||
@@ -487,17 +506,18 @@ static int rsa_get_exponent(RSA *key, uint64_t *e)
|
||||
if (!e)
|
||||
goto cleanup;
|
||||
|
||||
- if (BN_num_bits(key->e) > 64)
|
||||
+ RSA_get0_key(key, NULL, &key_e, NULL);
|
||||
+ if (BN_num_bits(key_e) > 64)
|
||||
goto cleanup;
|
||||
|
||||
- *e = BN_get_word(key->e);
|
||||
+ *e = BN_get_word(key_e);
|
||||
|
||||
- if (BN_num_bits(key->e) < 33) {
|
||||
+ if (BN_num_bits(key_e) < 33) {
|
||||
ret = 0;
|
||||
goto cleanup;
|
||||
}
|
||||
|
||||
- bn_te = BN_dup(key->e);
|
||||
+ bn_te = BN_dup(key_e);
|
||||
if (!bn_te)
|
||||
goto cleanup;
|
||||
|
||||
@@ -527,6 +547,7 @@ int rsa_get_params(RSA *key, uint64_t *exponent, uint32_t *n0_invp,
|
||||
{
|
||||
BIGNUM *big1, *big2, *big32, *big2_32;
|
||||
BIGNUM *n, *r, *r_squared, *tmp;
|
||||
+ const BIGNUM *key_n;
|
||||
BN_CTX *bn_ctx = BN_CTX_new();
|
||||
int ret = 0;
|
||||
|
||||
@@ -548,7 +569,8 @@ int rsa_get_params(RSA *key, uint64_t *exponent, uint32_t *n0_invp,
|
||||
if (0 != rsa_get_exponent(key, exponent))
|
||||
ret = -1;
|
||||
|
||||
- if (!BN_copy(n, key->n) || !BN_set_word(big1, 1L) ||
|
||||
+ RSA_get0_key(key, &key_n, NULL, NULL);
|
||||
+ if (!BN_copy(n, key_n) || !BN_set_word(big1, 1L) ||
|
||||
!BN_set_word(big2, 2L) || !BN_set_word(big32, 32L))
|
||||
ret = -1;
|
||||
|
||||
--
|
||||
2.12.2
|
||||
|
|
@ -0,0 +1,34 @@
|
|||
From 606c1e88afb03aecc90b0d37ec093d687ed797e5 Mon Sep 17 00:00:00 2001
|
||||
From: Jelle van der Waa <jelle@vdwaa.nl>
|
||||
Date: Tue, 4 Apr 2017 23:59:49 +0200
|
||||
Subject: [PATCH 2/3] rsa: Fix deprecated warnings for OpenSSL 1.1.x
|
||||
|
||||
ERR_remove_thread_state is deprecated in OpenSSL 1.1.x and does not do
|
||||
anything anymore. Thread initialisation and deinitialisation is now
|
||||
handled by the OpenSSL library.
|
||||
|
||||
Signed-off-by: Jelle van der Waa <jelle@vdwaa.nl>
|
||||
Reviewed-by: Simon Glass <sjg@chromium.org>
|
||||
---
|
||||
lib/rsa/rsa-sign.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lib/rsa/rsa-sign.c b/lib/rsa/rsa-sign.c
|
||||
index 5b7022d428..711501741a 100644
|
||||
--- a/lib/rsa/rsa-sign.c
|
||||
+++ b/lib/rsa/rsa-sign.c
|
||||
@@ -357,9 +357,9 @@ static void rsa_remove(void)
|
||||
{
|
||||
CRYPTO_cleanup_all_ex_data();
|
||||
ERR_free_strings();
|
||||
-#ifdef HAVE_ERR_REMOVE_THREAD_STATE
|
||||
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L && OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
|
||||
ERR_remove_thread_state(NULL);
|
||||
-#else
|
||||
+#elif OPENSSL_VERSION_NUMBER < 0x10000000L
|
||||
ERR_remove_state(0);
|
||||
#endif
|
||||
EVP_cleanup();
|
||||
--
|
||||
2.12.2
|
||||
|
|
@ -0,0 +1,96 @@
|
|||
From 8ebb38414e39c43ea6e6ef940c5e316a96ef8043 Mon Sep 17 00:00:00 2001
|
||||
From: Jelle van der Waa <jelle@vdwaa.nl>
|
||||
Date: Tue, 4 Apr 2017 23:59:50 +0200
|
||||
Subject: [PATCH 3/3] tools: kwbimage fix build with OpenSSL 1.1.x
|
||||
|
||||
The rsa_st struct has been made opaque in 1.1.x, add forward compatible
|
||||
code to access the n, e, d members of rsa_struct.
|
||||
|
||||
EVP_MD_CTX_cleanup has been removed in 1.1.x and EVP_MD_CTX_reset should be
|
||||
called to reinitialise an already created structure.
|
||||
|
||||
Signed-off-by: Jelle van der Waa <jelle@vdwaa.nl>
|
||||
---
|
||||
tools/kwbimage.c | 35 +++++++++++++++++++++++++++++------
|
||||
1 file changed, 29 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/tools/kwbimage.c b/tools/kwbimage.c
|
||||
index 2c637c7446..97f96cce54 100644
|
||||
--- a/tools/kwbimage.c
|
||||
+++ b/tools/kwbimage.c
|
||||
@@ -22,6 +22,26 @@
|
||||
#include <openssl/pem.h>
|
||||
#include <openssl/err.h>
|
||||
#include <openssl/evp.h>
|
||||
+#include <openssl/bn.h>
|
||||
+
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
|
||||
+static void RSA_get0_key(const RSA *r,
|
||||
+ const BIGNUM **n, const BIGNUM **e, const BIGNUM **d)
|
||||
+{
|
||||
+ if (n != NULL)
|
||||
+ *n = r->n;
|
||||
+ if (e != NULL)
|
||||
+ *e = r->e;
|
||||
+ if (d != NULL)
|
||||
+ *d = r->d;
|
||||
+}
|
||||
+
|
||||
+#else
|
||||
+void EVP_MD_CTX_cleanup(EVP_MD_CTX *ctx)
|
||||
+{
|
||||
+ EVP_MD_CTX_reset(ctx);
|
||||
+}
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
static struct image_cfg_element *image_cfg;
|
||||
@@ -470,12 +490,15 @@ static int kwb_export_pubkey(RSA *key, struct pubkey_der_v1 *dst, FILE *hashf,
|
||||
char *keyname)
|
||||
{
|
||||
int size_exp, size_mod, size_seq;
|
||||
+ const BIGNUM *key_e, *key_n;
|
||||
uint8_t *cur;
|
||||
char *errmsg = "Failed to encode %s\n";
|
||||
|
||||
- if (!key || !key->e || !key->n || !dst) {
|
||||
+ RSA_get0_key(key, &key_n, &key_e, NULL);
|
||||
+
|
||||
+ if (!key || !key_e || !key_n || !dst) {
|
||||
fprintf(stderr, "export pk failed: (%p, %p, %p, %p)",
|
||||
- key, key->e, key->n, dst);
|
||||
+ key, key_e, key_n, dst);
|
||||
fprintf(stderr, errmsg, keyname);
|
||||
return -EINVAL;
|
||||
}
|
||||
@@ -490,8 +513,8 @@ static int kwb_export_pubkey(RSA *key, struct pubkey_der_v1 *dst, FILE *hashf,
|
||||
* do the encoding manually.
|
||||
*/
|
||||
|
||||
- size_exp = BN_num_bytes(key->e);
|
||||
- size_mod = BN_num_bytes(key->n);
|
||||
+ size_exp = BN_num_bytes(key_e);
|
||||
+ size_mod = BN_num_bytes(key_n);
|
||||
size_seq = 4 + size_mod + 4 + size_exp;
|
||||
|
||||
if (size_mod > 256) {
|
||||
@@ -520,14 +543,14 @@ static int kwb_export_pubkey(RSA *key, struct pubkey_der_v1 *dst, FILE *hashf,
|
||||
*cur++ = 0x82;
|
||||
*cur++ = (size_mod >> 8) & 0xFF;
|
||||
*cur++ = size_mod & 0xFF;
|
||||
- BN_bn2bin(key->n, cur);
|
||||
+ BN_bn2bin(key_n, cur);
|
||||
cur += size_mod;
|
||||
/* Exponent */
|
||||
*cur++ = 0x02; /* INTEGER */
|
||||
*cur++ = 0x82;
|
||||
*cur++ = (size_exp >> 8) & 0xFF;
|
||||
*cur++ = size_exp & 0xFF;
|
||||
- BN_bn2bin(key->e, cur);
|
||||
+ BN_bn2bin(key_e, cur);
|
||||
|
||||
if (hashf) {
|
||||
struct hash_v1 pk_hash;
|
||||
--
|
||||
2.12.2
|
||||
|
|
@ -12,10 +12,24 @@ provides=('uboot-env' 'uboot-mkimage')
|
|||
replaces=('uboot-env' 'uboot-mkimage')
|
||||
backup=(etc/fw_env.config)
|
||||
source=(ftp://ftp.denx.de/pub/u-boot/u-boot-$pkgver.tar.bz2
|
||||
0001-rsa-Fix-build-with-OpenSSL-1.1.x.patch
|
||||
0002-rsa-Fix-deprecated-warnings-for-OpenSSL-1.1.x.patch
|
||||
0003-tools-kwbimage-fix-build-with-OpenSSL-1.1.x.patch
|
||||
fw_env.config)
|
||||
md5sums=('52fed6ce16e0c4a50e2cd4defdf9097a'
|
||||
'0b9dbef637a2d063f4282cc23f1f8fbc'
|
||||
'b21e23f823fcbdabbb84da568e9ac10c'
|
||||
'ba73fb9d3da714745729d6114f91538c'
|
||||
'5a9dcbae5957f8621080d4bbc0e1520f')
|
||||
|
||||
prepare() {
|
||||
cd u-boot-${pkgver}
|
||||
|
||||
patch -p1 -i ../0001-rsa-Fix-build-with-OpenSSL-1.1.x.patch
|
||||
patch -p1 -i ../0002-rsa-Fix-deprecated-warnings-for-OpenSSL-1.1.x.patch
|
||||
patch -p1 -i ../0003-tools-kwbimage-fix-build-with-OpenSSL-1.1.x.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd u-boot-${pkgver}
|
||||
|
||||
|
|
Loading…
Reference in a new issue