remove extra/spice

This commit is contained in:
Kevin Mihelich 2016-01-23 02:14:24 +00:00
parent 35671762fd
commit fa763c8243
2 changed files with 0 additions and 66 deletions

View file

@ -1,40 +0,0 @@
# $Id$
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: Patryk Kowalczyk < patryk at kowalczyk dot ws>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - drop qemu, libcacard deps
# - --disable-smartcard in configure
# - add v5 arch to configure
# - patch to remove x86 assembly breakpoint
pkgname=spice
pkgver=0.12.6
pkgrel=1
pkgdesc="SPICE client and server"
arch=('i686' 'x86_64')
url="http://spice-space.org"
license=('LGPL2.1')
depends=(alsa-lib celt0.5.1 libjpeg-turbo libsasl libxinerama libxfixes libxrandr pixman)
makedepends=(python2-pyparsing python2-six spice-protocol)
source=(http://spice-space.org/download/releases/$pkgname-$pkgver.tar.bz2
alarm.patch)
prepare() {
cd "$srcdir/$pkgname-$pkgver"
sed -i 's/|armv6|/|armv5tel|armv6|/' configure
patch -p1 -i ../alarm.patch
}
build() {
cd "$srcdir/$pkgname-$pkgver"
PYTHON=python2 ./configure --prefix=/usr --disable-static --enable-client --disable-smartcard
make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
}
md5sums=('605a8c8ea80bc95076c4b3539c6dd026'
'fb88aba84f39baa118fcd9da82b10b78')

View file

@ -1,26 +0,0 @@
diff -urN a/client/red_pixmap.h b/client/red_pixmap.h
--- a/client/red_pixmap.h 2014-05-14 05:14:34.000000000 -0600
+++ b/client/red_pixmap.h 2014-07-07 05:29:00.121233414 -0600
@@ -46,8 +46,6 @@
spice_printerr("equal fails at (+%d+%d) +%d+%d:%d in %dx%d",
rect.left, rect.top, x-rect.left, y-rect.top, i,
_width-rect.left, _height-rect.top);
- if (getenv("DIFFBP"))
- SPICE_BREAKPOINT();
return false;
}
}
diff -urN a/client/utils.h b/client/utils.h
--- a/client/utils.h 2014-05-14 05:14:34.000000000 -0600
+++ b/client/utils.h 2014-07-07 05:29:16.866177393 -0600
@@ -50,10 +50,6 @@
throw Exception(exption_string, err); \
}
-#define SPICE_BREAKPOINT() do{ \
- __asm__ __volatile__ ("int $03"); \
-}while(0)
-
template <class T>
class AutoRef {
public: