community/gap to 4.10.2-9

This commit is contained in:
Kevin Mihelich 2020-01-12 02:36:56 +00:00
parent 73da53dd6e
commit fa87241ff9
2 changed files with 28 additions and 5 deletions

View file

@ -8,17 +8,21 @@
pkgbase=gap
pkgname=(gap gap-doc gap-packages)
pkgver=4.10.2
pkgrel=8
pkgrel=9
pkgdesc="Groups, Algorithms, Programming: a system for computational discrete algebra"
arch=(x86_64)
url="https://www.gap-system.org/"
license=(GPL)
source=("https://www.gap-system.org/pub/gap/gap-${pkgver%.*}/tar.gz/gap-$pkgver.tar.gz" gap.sh
libsemigroups-1.0.patch)
libsemigroups-1.0.patch
git+https://github.com/gap-packages/NormalizInterface#commit=cd69a42
normalizinterface-missing-include.patch)
sha256sums=('11175bed0234101643d510d4ab94c44db30bd303bfe63d86b9b86ae67cff9e49'
'143fb8a79a52c007903cce13407850df309ef803a9b00398d05169355917de46'
'ccd95de4f48d26b73d6df7c1847855f68ee70644d130d32f14213988c3e286e3')
makedepends=(libxaw givaro mpfi normaliz boost libsemigroups c-xsc zeromq fplll polymake wget chrpath fmt)
'ccd95de4f48d26b73d6df7c1847855f68ee70644d130d32f14213988c3e286e3'
'SKIP'
'2410dfc69f1f4d2f320e91590d55e59c7b557637f9f60b9e609b318cfc21c181')
makedepends=(libxaw givaro mpfi normaliz boost libsemigroups c-xsc zeromq fplll polymake wget chrpath fmt git)
prepare() {
cd gap-$pkgver
@ -33,7 +37,13 @@ prepare() {
sed -e '/xgap/d' -i pkg/sonata-*/PackageInfo.g
sed -e '/XGAP/d' -i pkg/cryst/PackageInfo.g
cd pkg/semigroups-*
# Update NormalizInterface to support recent normaliz
rm -r pkg/NormalizInterface-1.0.2
cp -r ../NormalizInterface pkg
cd pkg/NormalizInterface
patch -p1 -i "$srcdir"/normalizinterface-missing-include.patch
cd ../semigroups-*
patch -p1 -i "$srcdir"/libsemigroups-1.0.patch # Fix build with libsemigroups 1.0
}
@ -55,6 +65,7 @@ build() {
export CXXFLAGS+=" -I/usr/include/cxsc" # Find c-xsc headers
export LDFLAGS+=" -L$srcdir/gap-$pkgver/tmp-install -lgap" # See https://trac.sagemath.org/ticket/27372
export LD_LIBRARY_PATH="$srcdir"/gap-$pkgver/tmp-install
export MAKEFLAGS="-j1"
../bin/BuildPackages.sh
}

View file

@ -0,0 +1,12 @@
diff --git a/src/normaliz.cc b/src/normaliz.cc
index a2ef45d..9768988 100644
--- a/src/normaliz.cc
+++ b/src/normaliz.cc
@@ -27,6 +27,7 @@
#include "libnormaliz/cone.h"
#include "libnormaliz/map_operations.h"
+#include "libnormaliz/dynamic_bitset.h"
#include <vector>