extra/thunderbird fix

This commit is contained in:
Kevin Mihelich 2015-08-09 00:02:50 +00:00
parent 2697b51665
commit fa8c5fffd9
2 changed files with 50 additions and 163 deletions

View file

@ -10,7 +10,7 @@
# - memory saving LDFLAGS
# - enable calendar in mozconfig
buildarch=20
buildarch=28
pkgname=thunderbird
pkgver=38.1.0
@ -37,7 +37,7 @@ sha256sums=('ddf1fd6048f07370bb0375eac76e687c19d29100c19e9f86fc04bb88d4409787'
'3fba13d88aeb003ab0811ef739463858172ce0662a1c7d62835df3d83ddbb8fb'
'24599eab8862476744fe1619a9a53a5b8cdcab30b3fc5767512f31d3529bd05d'
'e4ea8e6788163d9f8db8f1f40023db3ea0a1358f9a4510169f2d4c4fe6a887ed'
'1ecdb17848df46c1820bcf071b24e588f29f99ba860821d2b960c75f4ff1c6a4')
'd46ac749f8be3250fa70a13cd67b5f9204bedf8ff8955d3a71e1b8b2f4f48382')
prepare() {
cd comm-esr${pkgver%%.*}

View file

@ -1,34 +1,9 @@
--- ./mozilla/configure.orig 2015-06-11 19:05:34.195096563 -0600
+++ ./mozilla/configure 2015-06-11 19:06:44.405101697 -0600
@@ -7096,98 +7096,9 @@
-if test "$CPU_ARCH" = "arm"; then
- echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
-echo "configure:7102: checking for ARM SIMD support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 7106 "configure"
-#include "confdefs.h"
-
-int main() {
-asm("uqadd8 r1, r1, r2");
-; return 0; }
-EOF
-if { (eval echo configure:7113: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- result="no"
-fi
-rm -f conftest*
- echo "$ac_t"""$result"" 1>&6
- if test "$result" = "yes"; then
--- mozilla/configure.orig 2015-08-08 14:58:36.593927523 -0600
+++ mozilla/configure 2015-08-08 15:01:37.743857135 -0600
@@ -7121,14 +7121,7 @@
rm -f conftest*
echo "$ac_t"""$result"" 1>&6
if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_SIMD ''', ' 1 ')
-EOF
@ -37,37 +12,14 @@
-EOF
-
- HAVE_ARM_SIMD=1
- fi
-
- echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
-echo "configure:7136: checking ARM version support in compiler" >&5
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9][0-9]*\).*/\1/p'`
- echo "$ac_t"""$ARM_ARCH"" 1>&6
-
- echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
-echo "configure:7141: checking for ARM NEON support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 7145 "configure"
-#include "confdefs.h"
-
-int main() {
-asm(".fpu neon\n vadd.i8 d0, d0, d0");
-; return 0; }
-EOF
-if { (eval echo configure:7152: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- result="no"
-fi
-rm -f conftest*
- echo "$ac_t"""$result"" 1>&6
- if test "$result" = "yes"; then
+ HAVE_ARM_SIMD=
fi
echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
@@ -7160,27 +7153,13 @@
rm -f conftest*
echo "$ac_t"""$result"" 1>&6
if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_NEON ''', ' 1 ')
-EOF
@ -76,11 +28,12 @@
-EOF
-
- HAVE_ARM_NEON=1
-
- if test -n "$ARM_ARCH"; then
- if test "$ARM_ARCH" -lt 7; then
- BUILD_ARM_NEON=
- else
+ HAVE_ARM_NEON=
if test -n "$ARM_ARCH"; then
if test "$ARM_ARCH" -lt 7; then
BUILD_ARM_NEON=
else
- cat >> confdefs.pytmp <<\EOF
- (''' BUILD_ARM_NEON ''', ' 1 ')
-EOF
@ -89,50 +42,16 @@
-EOF
-
- BUILD_ARM_NEON=1
- fi
- fi
- fi
-
-fi # CPU_ARCH = arm
-
-
+HAVE_ARM_NEON=0
+BUILD_ARM_NEON=0
+HAVE_ARM_SIMD=0
--- ./mozilla/js/src/configure.orig 2015-06-11 19:05:34.155096560 -0600
+++ ./mozilla/js/src/configure 2015-06-11 19:07:17.065104453 -0600
@@ -6235,99 +6235,9 @@
-if test "$CPU_ARCH" = "arm"; then
- echo $ac_n "checking for ARM SIMD support in compiler""... $ac_c" 1>&6
-echo "configure:6241: checking for ARM SIMD support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 6245 "configure"
-#include "confdefs.h"
-
-int main() {
-asm("uqadd8 r1, r1, r2");
-; return 0; }
-EOF
-if { (eval echo configure:6252: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- result="no"
-fi
-rm -f conftest*
- echo "$ac_t"""$result"" 1>&6
- if test "$result" = "yes"; then
+ BUILD_ARM_NEON=
fi
fi
fi
--- mozilla/js/src/configure.orig 2015-08-08 14:58:44.998935015 -0600
+++ mozilla/js/src/configure 2015-08-08 15:02:01.643605841 -0600
@@ -6260,14 +6260,7 @@
rm -f conftest*
echo "$ac_t"""$result"" 1>&6
if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_SIMD ''', ' 1 ')
-EOF
@ -141,37 +60,14 @@
-EOF
-
- HAVE_ARM_SIMD=1
- fi
-
- echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
-echo "configure:6275: checking ARM version support in compiler" >&5
- ARM_ARCH=`${CC-cc} ${CFLAGS} -dM -E - < /dev/null | sed -n 's/.*__ARM_ARCH_\([0-9][0-9]*\).*/\1/p'`
- echo "$ac_t"""$ARM_ARCH"" 1>&6
-
- echo $ac_n "checking for ARM NEON support in compiler""... $ac_c" 1>&6
-echo "configure:6280: checking for ARM NEON support in compiler" >&5
- # We try to link so that this also fails when
- # building with LTO.
- cat > conftest.$ac_ext <<EOF
-#line 6284 "configure"
-#include "confdefs.h"
-
-int main() {
-asm(".fpu neon\n vadd.i8 d0, d0, d0");
-; return 0; }
-EOF
-if { (eval echo configure:6291: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- result="yes"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- result="no"
-fi
-rm -f conftest*
- echo "$ac_t"""$result"" 1>&6
- if test "$result" = "yes"; then
+ HAVE_ARM_SIMD=
fi
echo $ac_n "checking ARM version support in compiler""... $ac_c" 1>&6
@@ -6299,27 +6292,13 @@
rm -f conftest*
echo "$ac_t"""$result"" 1>&6
if test "$result" = "yes"; then
- cat >> confdefs.pytmp <<\EOF
- (''' HAVE_ARM_NEON ''', ' 1 ')
-EOF
@ -180,11 +76,12 @@
-EOF
-
- HAVE_ARM_NEON=1
-
- if test -n "$ARM_ARCH"; then
- if test "$ARM_ARCH" -lt 7; then
- BUILD_ARM_NEON=
- else
+ HAVE_ARM_NEON=
if test -n "$ARM_ARCH"; then
if test "$ARM_ARCH" -lt 7; then
BUILD_ARM_NEON=
else
- cat >> confdefs.pytmp <<\EOF
- (''' BUILD_ARM_NEON ''', ' 1 ')
-EOF
@ -193,17 +90,7 @@
-EOF
-
- BUILD_ARM_NEON=1
- fi
- fi
- fi
-
-fi # CPU_ARCH = arm
-
-
-
+HAVE_ARM_NEON=0
+BUILD_ARM_NEON=0
+HAVE_ARM_SIMD=0
+ BUILD_ARM_NEON=
fi
fi
fi