extra/chromium: patch to kill sysrooting

This commit is contained in:
Kevin Mihelich 2013-02-24 22:14:41 +00:00
parent aa16aaf365
commit fb36f7381b
2 changed files with 18 additions and 9 deletions

View file

@ -40,20 +40,24 @@ source=(http://commondatastorage.googleapis.com/chromium-browser-official/$pkgna
chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch
chromium-system-libpng-r0.patch
chromium-ppapi-r0.patch
chromium-no-pnacl-r0.patch)
chromium-no-pnacl-r0.patch
die-sysroot-die.patch)
sha256sums=('15be31be9614c68b0bc3efc594eea65942a7bb433819736279a60ac4228313e5'
'09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
'478340d5760a9bd6c549e19b1b5d1c5b4933ebf5f8cfb2b3e2d70d07443fe232'
'4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9'
'c1baf14121502efbc2a31b64029dcafa0e28ca5b71ad0e28a3c6342d18198615'
'9fd5cb18b109e172e6244456ba265c343460537d6acc0eb5c3def6ebc8272056'
'd0a8b8f5b3d25be4bd2f060422c467dc827997a0b69dfc34a6d18dc9d2f36868'
'1f4b57670d317959bc2dc60e5d2a44aa8fc6028f7ed540cdb502fa0aa99c81bd'
'44061e1648ac4674ad0b9990c265c96c33de435679f6854e4b54a421d81cbe6c')
'44061e1648ac4674ad0b9990c265c96c33de435679f6854e4b54a421d81cbe6c'
'66705264d9e679a58ed522b4475a06c8a5a4fe52a709c537b1a7d5aa43fb6c84')
build() {
cd "$srcdir/chromium-$pkgver"
# Remove ARM sysroot garbage
patch -Np1 -i "$srcdir/die-sysroot-die.patch"
# Fix build with glibc 2.16
patch -Np1 -i "$srcdir/chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch"
@ -159,9 +163,3 @@ package() {
}
# vim:set ts=2 sw=2 et:
sha256sums=('c21bdee0ec136102e10c527a0d98e3a29e40406d8f7eb63e8e0ac23801722824'
'09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
'478340d5760a9bd6c549e19b1b5d1c5b4933ebf5f8cfb2b3e2d70d07443fe232'
'4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9'
'f607347ba8477d3c8e60eb3803d26f3c9869f77fd49986c60887c59a6aa7d30d'
'a700aa054800d1b21d84eaba27c38a703dfa023e9226d11a942690c2a0630aff')

View file

@ -0,0 +1,11 @@
--- a/build/common.gypi 2013-01-09 07:02:00.000000000 -0700
+++ b/build/common.gypi 2013-01-11 20:09:13.380197474 -0700
@@ -594,7 +594,7 @@
'linux_use_gold_flags%': 0,
# sysroot needs to be an absolute path otherwise it generates
# incorrect results when passed to pkg-config
- 'sysroot%': '<!(cd <(DEPTH) && pwd -P)/arm-sysroot',
+ #'sysroot%': '<!(cd <(DEPTH) && pwd -P)/arm-sysroot',
}], # OS=="linux" and target_arch=="arm" and chromeos==0
],