mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
working touchscreen server
This commit is contained in:
parent
464d4aeb00
commit
fb4c8b3b67
2 changed files with 50 additions and 0 deletions
39
extra/tenderloin-touchserver/PKGBUILD
Executable file
39
extra/tenderloin-touchserver/PKGBUILD
Executable file
|
@ -0,0 +1,39 @@
|
|||
plugrel=1
|
||||
noautobuild=1
|
||||
|
||||
pkgname=tenderloin-touchserver
|
||||
pkgver=20111218
|
||||
pkgrel=1
|
||||
pkgdesc="Touch input for HP TouchPad - Tenderloin"
|
||||
arch=('armv7h')
|
||||
url="http://www.quicinc.com/"
|
||||
license=('GPL')
|
||||
depends=('xorg-server')
|
||||
makedepends=('git')
|
||||
source=('linux-input.patch')
|
||||
md5sums=(9bf8f56ef91c5c77c74ea76c9c870ddb)
|
||||
_gitroot="git://github.com/jcsullins/ts_srv_tenderloin.git"
|
||||
_gitname="ts_srv_tenderloin"
|
||||
|
||||
build() {
|
||||
cd $srcdir
|
||||
|
||||
## Git checkout
|
||||
msg "Git checkout: Retrieving sources"
|
||||
rm -rf ${_gitname}
|
||||
git clone ${_gitroot}
|
||||
msg "Checkout completed"
|
||||
|
||||
cd $srcdir/${_gitname}
|
||||
# PATCH: Change location of input for Linux kernel
|
||||
cp $srcdir/linux-input.patch $srcdir/${_gitname}/
|
||||
patch -p1 < linux-input.patch
|
||||
|
||||
gcc -lm ts_srv.c -o ts_srv
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $srcdir/${_gitname}/
|
||||
install -d $pkgdir/usr/bin
|
||||
install -D -m755 ts_srv $pkgdir/usr/bin/
|
||||
}
|
11
extra/tenderloin-touchserver/linux-input.patch
Normal file
11
extra/tenderloin-touchserver/linux-input.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/ts_srv.c 2011-12-18 11:11:44.000000000 -0600
|
||||
+++ b/ts_srv.c 2011-12-18 11:12:09.000000000 -0600
|
||||
@@ -46,7 +46,7 @@
|
||||
#include <math.h>
|
||||
#include <sys/select.h>
|
||||
|
||||
-#if 0
|
||||
+#if 1
|
||||
// This is for Android (or OS using Android kernel)
|
||||
#define UINPUT_LOCATION "/dev/uinput"
|
||||
#else
|
Loading…
Reference in a new issue